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TeleVantage overview _____________________________________
Welcome to TeleVantage!

TeleVantage is a feature-rich, software-based phone system that combines rock-solid stability 
with the most advanced communications technology available today. TeleVantage delivers 
greater functionality, flexibility, and value than proprietary PBXs to a variety of customers, 
from small offices to large enterprise organizations with sophisticated call centers. 

About this manual
This manual provides instructions for installing the hardware and software necessary to run 
TeleVantage. For instructions on running TeleVantage after it is installed, see Administering 
TeleVantage and Using TeleVantage.

Major TeleVantage features 
Major TeleVantage features include:

Q Fault tolerant architecture. Designed to keep your phone system up and running. If the 
network or your desktop computer goes down, your phone lines are unaffected. Even in 
the case of a TeleVantage Server malfunction or power outage, your critical phone lines 
will stay open.

Q Graphical call control. Gives you an easy visual way to place calls, transfer, put on 
hold, send to voice mail, set up conference calls and more.

Q Verbal menus. Guide you through all call handling and user management tasks so that 
you can use TeleVantage even without a computer.

Q Full-featured voice mail. Lets you create caller-specific greetings, log in remotely, and 
manage your voice messages graphically from the TeleVantage Client or your e-mail 
Inbox. You can also easily call back the person who left you a message.

Q Powerful call center options. Two types of call centers are available in 
TeleVantage—call center queues and ACD workgroups. Call center queues provide a 
full-featured call distribution system, enabling you to customize your callers’ hold 
experience, play single or repeating prompts, prompt callers to enter data, configure call 
priority, and set up multi-level supervisor permissions. ACD workgroups provide fewer 
features and are available to you if you have not purchased the Call Center Agent 
licenses that are required for call center queues. You can use the TeleVantage Call 
Center Reporter to run a variety of reports on call center activity for both call center 
queues and ACD workgroups.

Q E-mail, pager, and call notification. Receive notification of incoming voice mail, 
using e-mail, pager, or by having TeleVantage call you.

Q Advanced caller identification. Using PIN numbers or Caller ID, TeleVantage lets you 
easily screen every call and message, either visually or by announcing the caller's name 
when you answer the phone. 
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Q Call recording. Lets you record conversations of calls or conferences, on demand or 
automatically across the entire company or specified individuals.

Q Personal statuses. Lets you create “Vacation,” “Out of the Office,” and other personal 
statuses to let your coworkers know what you are doing. Personal status can set whether 
your phone rings, the greeting that plays, and routing list behavior when you are not able 
to answer calls.

Q The TeleVantage Web Client. Enables users with a Web browser to access voice mail 
or manage personal settings from anywhere in the world over the Internet or from 
non-Windows platforms in the office.

Q “Follow-me” call forwarding. Features routing lists that try several locations to find 
you. You can create several routing lists and apply them to specific callers.

Q Call logging. Lets users see a record of their own calls and gives TeleVantage system 
administrators access to your company’s complete log.

Q Scheduled auto attendants. Allows you to schedule an auto attendant’s use of specific 
greetings and the way it routes calls according to the time of the day and days of the 
week.

Q Flexible Internet-ready architecture. Supports pure IP telephony and hybrid solutions 
such as IP-connected phones. Lets you adapt to Internet telephony at your own pace.

Q TAPI Service Provider and Contact Manager Assistant. Lets you use Act!, Outlook, 
GoldMine, GoldMine FrontOffice, or other TAPI-compliant applications with 
TeleVantage. You can place calls and receive screen-pop identifications when you 
receive calls from contacts in these applications.

Q The TeleVantage Software Development Kit and open architecture. Use one of the 
many off-the-shelf applications available from third-party vendors to customize 
TeleVantage behavior and call processing. Programmers can use the comprehensive 
TeleVantage Software Development Kit (SDK) for the ultimate in flexibility. The SDK 
includes the Client API to access all Client functions, calls and data; the IVR Plug-in API 
to perform any custom call and voice processing; and the Device Status API to get 
real-time information on any trunk or station.

Q Multi-lingual system prompts. Lets both users and callers select the language in which 
they hear TeleVantage prompts.

Q CLASS, ADSI, IP, and Toshiba digital phone support. QFor analog CLASS phones, 
Caller ID, call waiting, and message waiting lights are supported.

Q Tenanting support. Tenanting allows one Server to be shared between multiple 
companies or groups, with each user's outbound calls to be tracked in the Call Log by 
organization.
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Significant new features in TeleVantage 5 
For a complete list of new features, do either of the following:

Q Double-click the WHATSNEW.HTM document on the TeleVantage Master CD

Q Select the Show What’s New checkbox at the end of any TeleVantage installation 
programs.

How to install TeleVantage using this manual__________________
This manual contains two main sections:

Q Section 1, “Preparing for Installation”. The chapters in this section describe the 
TeleVantage components, PC and network requirements, and the various trunk and 
station options you can use with TeleVantage. 

If you are installing TeleVantage for the first time—or even if you are upgrading from a 
previous version—read the chapters in this section thoroughly for information that will 
help you plan and prepare for installation, including current TeleVantage requirements, 
and how to order trunks and services. 

Q Section 2, “Performing the Installation”. The chapters in this section describe the 
installation process in detail. 

Follow the steps in each chapter before going to the next chapter. The Introduction in 
each chapter explains exactly which of the steps in that chapter you must perform.

Where to get help_________________________________________
Contact your TeleVantage provider for technical support—Artisoft only provides technical 
support through TeleVantage providers. For information about how to report problems, see 
Administering TeleVantage.

You can get help through TeleVantage documentation as described in the next section.

TeleVantage documentation 
TeleVantage includes the following documentation:

Q Administering TeleVantage—This manual contains instructions for configuring and 
managing your TeleVantage system, including TeleVantage Administrator system 
settings, licenses, trunks, stations, users, dialing services, auto attendants, call routing, 
and system prompts.

Q Using TeleVantage—This manual describes how to use the TeleVantage Client, Web 
Client, Contact Manager Assistant, TAPI Service Provider, and the TeleVantage 
telephone commands.

Q TeleVantage Call Center Administrator’s Guide—This manual contains complete 
instructions for setting up and maintaining a call center in which multiple agents answer 
calls to a single number, such as a sales or customer support department.
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Q TeleVantage Developer’s Guide—This manual describes how to extend TeleVantage's 
built-in features using the Client API, the IVR Plug-in API, and the Device Status API.

Q TeleVantage Pocket Reference Card—This wallet-sized card is a convenient reference 
for the TeleVantage telephone commands.

Q TeleVantage QuickStart Guide—This quick-start guide for new users describes basic 
TeleVantage commands for the telephone and the Client.

Q Online Help—Context-sensitive help is available in all TeleVantage applications. In any 
dialog box, click the Help button or press F1 for help on that dialog box.

The following table shows the TeleVantage documentation set and the formats in which it is 
available.

Accessing online documentation
The online books are available in HTML-based format. To access an online book, click 
Help > Online Books in any TeleVantage application.

The PDF versions of the books are available on the TeleVantage Master CD in the \Manuals 
directory. To view and print these files, use Adobe Acrobat Reader, available on the 
TeleVantage Master CD in the \Adobe directory.

Document Printed
Online 
Book

Acrobat (PDF)

Installing TeleVantage Yes Yes Yes

Administering TeleVantage Yes Yes Yes

Using TeleVantage Yes Yes Yes

TeleVantage Call Center 
Administrator’s Guide 

Yes No Yes

TeleVantage Developer’s 
Guide 

No No Yes

TeleVantage Pocket 
Reference Card 

Yes No No

TeleVantage QuickStart 
Guide 

Yes No Yes
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About TeleVantage components_____________________________
TeleVantage consists of several components that you will be installing separately. This chapter 
provides an overview and a description of the purpose of each of the following components that 
you can install:

Q TeleVantage Server

Q TeleVantage Administrator

Q TeleVantage Client

Q TeleVantage Web Services

Q TeleVantage TAPI Service Provider

Q TeleVantage Contact Manager Assistant

Q TeleVantage Station Message Detail Recording (SMDR) Service

Q TeleVantage Robbed Bit T1 Experimenter

Q TeleVantage Software Development Kit

TeleVantage workstation applications
The Administrator, the Client, the TAPI Service Provider, and the Contact Manager Assistant 
are also referred to within this manual as the TeleVantage workstation applications.

TeleVantage Server _______________________________________
The TeleVantage Server is the heart of the TeleVantage system. It controls phone traffic in and 
out of your office, and it stores your database of user and system information as well as all voice 
files, including voice messages. 

The TeleVantage Server runs on a Windows NT 4.0 or Windows 2000 PC on which your 
telephony boards have been installed.

The Device Monitor 
The Device Monitor lets you see the current activity and status of each trunk and station on the 
TeleVantage Server. You can also start and stop the Server by using the Device Monitor, which 
you can run independently of the TeleVantage Administrator application. The Device Monitor 
is installed automatically on the TeleVantage Server PC. 

The same information is also available in the Device Monitor view of the TeleVantage 
Administrator. 
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Server reliability features 
Because consistent phone service is vital to any business, the TeleVantage Server takes steps to 
ensure continued phone service, even when the phone system is impaired.

Watchdog mode 
With analog phone service, Watchdog mode ensures limited telephone support in the event of a 
power failure or Windows Server failure.

Watchdog mode requires that you connect user stations and analog trunk lines to the 
TeleVantage Server through the Intel Dialogic Business Communications Platform (BCP) 
connection panel, instead of using standard telephone patch panels or breakout boxes.

In Watchdog mode, if a Server or power failure occurs, the BCP routes the first four incoming 
analog trunk lines (T1-T4) to the first four stations (S1-S4). Each incoming trunk call rings on 
the corresponding station, and each station can then make outgoing calls on its corresponding 
trunk. All other system features are disabled during the Server or power failure. When power is 
restored, TeleVantage automatically restarts and restores normal phone service.

For systems with more than one BCP, the second BCP (and any others) will receive the same 
limited support—the first four trunks (for example, T9-T12) on the second BCP panel will be 
mapped to the first four stations on that panel—but only in the event of a power failure. When 
the Server is shut down for any reason other than a power failure, there is no Watchdog mode 
support for additional BCP panels. 

Note: Watchdog mode is only available for analog trunks. On systems that primarily use digital 
(T1, E1, or IP) trunks, configure several analog trunks so that Watchdog mode can be used.

Other reliability features 
For further reliability, Windows NT and Windows 2000 support RAID drives and 
uninterruptible power supplies. 

TeleVantage Administrator_________________________________
The TeleVantage Administrator application enables you to configure, maintain, and monitor 
your TeleVantage system. You can use the Administrator to manage trunks, extensions, users, 
create and modify auto attendant menus, and manage all aspects of your TeleVantage system. 
You can install the Administrator on any PC on your network, including the TeleVantage Server 
PC.

See “Administrator and Client requirements” on page 3-22 for specific requirements.
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TeleVantage Client ________________________________________
TeleVantage users can use the TeleVantage Client application in conjunction with their 
telephones to place and receive calls, access voice messages visually, and use all the features of 
the TeleVantage system. You can install a Client application on any PC on your network.

See “Administrator and Client requirements” on page 3-22 for specific requirements.

While the Client enhances your access to TeleVantage, it is not required. Most TeleVantage 
features are also available to users over the phone through the telephone commands.

A Web browser-accessible version of the Client is available by installing TeleVantage Web 
Services. 

TeleVantage Call Center Reporter 
The TeleVantage Call Center Reporter is installed automatically when you install the Client. 

The Call Center Reporter allows you to run more than a dozen detailed reports on call activity 
and telephone usage in TeleVantage. By carefully tracking only the call activity on which you 
want to report, it allows you to quickly identify how effectively your phone system is being used 
by agents, queues, and trunks. The Call Center Reporter is even more useful if you run a call 
center—using either call center queues or ACD workgroups—because it can generate reports on 
agent efficiency, average caller hold time, and more. 

The TeleVantage Call Center Reporter has additional requirements beyond those of the 
TeleVantage Client. See “Call Center Reporter requirements” on page 3-24 for details.

TeleVantage Web Services _________________________________
With TeleVantage Web Services, users can access an HTML version of the Client via any Web 
browser through the Internet or their Intranet. With the Web Client, users can access 
TeleVantage remotely or from non-Windows platforms such as Macintosh. The Web Client 
offers all TeleVantage views and access to most Client functions.

See “Web Services requirements” on page 3-23 for specific requirements.

TeleVantage TAPI Service Provider __________________________
The TAPI Service Provider allows any TAPI-compatible application on a networked PC to 
access your phone lines through TeleVantage. See “TAPI Service Provider/Contact Manager 
Assistant requirements” on page 3-23 for specific requirements.

Users who install the TAPI Service Provider on their PCs can place calls using contact managers 
such as Microsoft Outlook, Act!, GoldMine, and GoldMine FrontOffice. 

The TAPI Service Provider runs in the background and enables the contact manager or other 
application to use TeleVantage. You can install the TAPI Service Provider with or without the 
TeleVantage Client.
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TeleVantage Contact Manager Assistant _____________________
The TeleVantage Contact Manager Assistant tightly integrates with Outlook, GoldMine, or 
GoldMine FrontOffice, so that you can receive screen-pop notification when any of your 
Outlook, GoldMine, or GoldMine FrontOffice contacts call you. See “TAPI Service 
Provider/Contact Manager Assistant requirements” on page 3-23 for specific requirements.

The TeleVantage Contact Manager Assistant is not required if you are using Act! as your contact 
manager.

TeleVantage Station Message Detail Recording (SMDR) Service __
The TeleVantage SMDR Service lets you send real-time call data from TeleVantage to a third-party 
application. Third-party applications might be anything from a printer that prints a line for each call, 
to call accounting software that generates detailed reports. For complete information about 
supported output formats, as well as how to install, configure, and use the TeleVantage SMDR 
Service, see Administering TeleVantage.

Note: The TeleVantage SMDR Service is not normally needed, since TeleVantage has 
comprehensive call logging and reporting built in.

TeleVantage Robbed Bit T1 Experimenter ____________________
The TeleVantage Robbed Bit T1 Experimenter is a utility that lets you configure a Robbed Bit 
T1 line to match the signaling specifications used by your carrier and make test calls until the 
line is operating properly. You can also use the TeleVantage Administrator to configure Robbed 
Bit T1 settings. 

TeleVantage Software Development Kit ______________________
The TeleVantage Software Development Kit (SDK) lets you extend TeleVantage functionality. 
The TeleVantage SDK consists of the following components:

Q The Client Application Programming Interface (API) gives custom applications the 
ability to access all functions and data in the TeleVantage Client. 

Q The IVR Plug-in API is a powerful way to integrate virtually any interactive voice 
response or voice processing application with your TeleVantage system. 

Q The Device Status API gives custom applications the ability to get detailed information 
about trunks and stations from the TeleVantage Server. 

For more information about extending TeleVantage, see Administering TeleVantage and 
TeleVantage Developer’s Guide. The TeleVantage Developer’s Guide is available as an Acrobat 
file (tvsdk.pdf) in the \manuals directory on the TeleVantage Master CD.
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Introduction _____________________________________________
This chapter describes hardware and software requirements for the PCs on which the various 
TeleVantage components will run. It also describes the requirements for telephone lines and the 
local area network (LAN) configuration in your office environment. Make sure all these 
requirements are met before you begin the installation.

Choosing a location for the TeleVantage 
Server PC _______________________________________________

The TeleVantage Server must be located in a dust-free environment that is close to the location 
at which the trunk lines from your telephone company enter the premises and your inside phone 
lines begin. The existing telephone wiring closet that is available in most offices is a suitable 
location. 

The Server must also have access to your network wiring if you plan to use any TeleVantage 
components on your LAN or remotely, or if you plan to use the Internet telephony features 
provided by TeleVantage. See “Network requirements” on page 3-17.

The location does not have to be easily accessible, since you can remotely reconfigure and 
manage a TeleVantage Server running Windows 2000 Server using Windows Terminal Server.

TeleVantage Server requirements____________________________
The TeleVantage Server PC works optimally if it is dedicated to TeleVantage. 

The minimum requirements for the TeleVantage Server PC are as follows.

Q Operating system. The following operating systems can be used:

Q Microsoft® Windows® 2000 Server. TeleVantage supports the base release as 
well as SP1, SP2, or SP3. The advantage to using Windows 2000 Server is that it 
offers Windows Terminal Server for remote management.

Q Windows NT 4.0 Server, SP6 or higher. SP6a is provided on the TeleVantage 
Master CD and is installed automatically during the TeleVantage installation if 
your system does not have SP6 or higher.

Q Windows 2000 Professional. TeleVantage supports the base release as well as 
SP1, SP2, or SP3. See “Important operating system limitations” below.

Q Windows NT 4.0 Workstation, SP6 or higher. SP6a is provided on the 
TeleVantage Master CD and is installed automatically during the TeleVantage 
installation if your system does not have SP6 or higher. See “Important operating 
system limitations” below.

Important operating system limitations
Q While Windows 2000 Professional or Windows NT 4.0 Workstation are supported, 

a Server using these operating systems is limited to supporting a maximum of 10 
simultaneous connections to any TeleVantage workstation application 
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(TeleVantage Client, Administrator, TAPI Service Provider, Contact Manager 
Assistant, or Web Client session.)

Q Windows XP is not supported by the Intel Dialogic drivers and so cannot be used 
for the TeleVantage Server.

Q TeleVantage requires a full version of Windows. Do not install a Not for Resale 
(NFR) version or a Microsoft Developer’s Network (MSDN) copy. 

Note: Throughout this manual, the term “Windows 2000” refers to both Windows 2000 
Server and Windows 2000 Professional. “Windows NT 4.0” refers to both Windows NT 
4.0 Server and Windows NT 4.0 Workstation. “Windows Server” refers to both Windows 
2000 Server and Windows NT 4.0 Server.

Q Processor and memory. Processor and memory requirements depend both on call 
activity and on how many trunks and stations the TeleVantage system will support. The 
following table lists recommendations for various configurations. In the table, Total # of 
ports is the total number of trunks and stations. In any configuration, the total number 
of trunks cannot exceed 192, and the total number of stations cannot exceed 480.

Note: For systems with very heavy call volumes, you should increase processor 
speed and memory beyond the amounts recommended in the table. For example, a 
system that handles 5000 calls per day requires more memory and a faster CPU than 
a system that handles only 500 calls each day.

Memory availability has a direct effect on TeleVantage performance. While the 
minimum memory required by TeleVantage is 128 MB—adequate for lightly-used, 
demonstration, or test systems—additional memory is recommended for systems with 
heavier usage. 

Intel Dialogic recommends at least 512 MB of memory for systems with 3 or more DM3 
telephony boards. The DM3 boards include any of the Internet telephony boards, DI/SIx 
or HDSI/x station boards, or the DM/V2400A conference bridge board.

System 
size

Total # of 
ports

Examples
Recommended 

processor
Recommended 

memory

Small 32 8 trunks and 24 
stations

Pentium II 233 MHz 
or higher

at least 256 MB

Medium 168 48 trunks and 
120 stations

Pentium II 400 MHz 
or higher

at least 512 MB

Large 360 96 trunks and 
264 stations

Pentium III 800 
MHz or higher

at least 768 MB

Very large 672 192 trunks and 
480 stations

Pentium IV 2 GHz 
or higher

at least 1 GB
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Q Hard drives and available disk space. It is recommended that you format the hard 
drives on the TeleVantage Server with NTFS—not FAT or FAT32—as the Server file 
system. This is especially important for the hard drive where the TeleVantage voice files 
are stored. All drives do not have to be formatted the same way.

The amount of disk space you need depends on the size of your system, because each 
user requires significant space for voice files such as voice messages and greetings. 

The following table lists the minimum disk space required for systems with different 
numbers of users, all of whom have voice mailboxes. By default, TeleVantage allows a 
maximum of 30 minutes of voice files per user—20 minutes for voice messages and 10 
minutes for personal recordings such as greetings and voice titles. Increasing the default 
per-user settings for voice messages and personal recordings requires more disk space, 
as indicated in the table. 

If you want to calculate the total disk space required for your specific configuration (for 
example, 175 users with 45 minutes of voice files per user), add the following together 
and then round up to the nearest .5 GB:

1 GB for Windows. Microsoft recommends at least 1 GB disk space for Windows 
2000 Server.

1.2 GB for Intel Dialogic drivers

2 GB for the TeleVantage database server and TeleVantage system files

# of users * (.46 MB * minutes of voice files per user)

Minimum disk space requirements

Minutes of voice files per user

Users 30 minutes 60 minutes 90 minutes 120 minutes 180 minutes 240 minutes

24 4.7 GB 5 GB 5.3 GB 5.7 GB 6.3 BG 7 GB

48 5 GB 5.7 GB 6.3 BG 7 GB 8.3 GB 9.6 GB

96 5.7 GB 7 GB 8.3 GB 9.6 GB 12.3 GB 15 GB

144 6.3 BG 8.3 GB 10.3 GB 12.3 GB 16.2 GB 20.2 GB

264 8 GB 12 GB 15.1 GB 19 GB 26.1 GB 33.4 GB

300 8.5 GB 12.6 GB 16.7 GB 20.8 GB 29.1 GB 37.3 GB

360 9.3 GB 14.2 GB 19.2 GB 24.1 GB 34 GB 43.9 GB

420 10.1 GB 15.9 GB 21.7 GB 27.4 GB 39 GB 50.5 GB

480 10.9 GB 17.5 GB 24.1 GB 30.7 GB 43.9 GB 57.1 GB
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Q RAID. TeleVantage supports and recommends Windows Server RAID implementations. 
To ensure maximum uptime, configure your TeleVantage Server PC with RAID as you 
would any other mission-critical system. Some options are listed in the following table. 
Contact your server manufacturer for more detailed information.

Q Slots. The TeleVantage Server PC requires slots for telephony boards. The type of 
available slots—ISA or PCI—depends on the boards that you use. See “Intel Dialogic 
hardware requirements” on page 3-7.

Q COM ports. Up to 3 COM ports may be required, as follows:

Q If you are using analog trunks, 1 COM port for the Dialogic BCP connection panel, 
to support Watchdog mode. See “Watchdog mode” on page 2-3 for more 
information.

Q 1 COM port for an optional UPS with power-down alarm feature.

Q 1 COM port if you are using the TeleVantage Station Message Detail Recording 
(SMDR) Service. See Administering TeleVantage for information about installing, 
configuring, and using TeleVantage SMDR Service.

Q Modem or LAN Internet connection. If you will be using the TeleVantage Web Client, 
you will need Internet access for the Web Client Server PC. For more information, see 
Chapter 13, “Installing TeleVantage Web Services.” 

Q Network card. Although TeleVantage can run without being connected to a network, 
many of its features are unavailable without a network. If you are using a network, you 
must have a network interface card (NIC) installed in the Server. See “Network 
requirements” on page 3-17 for a discussion of network-related requirements, including 
a list of TeleVantage features that require a network. 

Version
Disk controllers/
Drives required

Comments

RAID 1
1 controller (disk mirroring);
2 drives

Provides fault tolerance in the event of a 
single drive failure, but not a controller 
failure. Slower, because data must be 
written to both drives.

RAID 1
2 controllers (disk duplexing);
2 drives

Provides fault tolerance in the event of a 
single disk or single controller failure.

RAID 5
1 controller;
at least 3 drives

Provides continual operation in the 
event of a single drive failure, but not a 
controller failure.
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Q Power supply. It is highly recommended that you use an uninterruptible power supply 
(UPS) in conjunction with the TeleVantage Server to protect against power surges and 
failures.

Make sure that your power supply meets the requirements of the installed Intel Dialogic 
telephony boards. DM3 boards (DM/IPx Internet telephony boards, DISI/x or HDSI/x 
station boards, or DM/V2400A conference bridge boards) in particular require a lot of 
power. For more information about power requirements for a specific board, look it up 
in the Intel Telecom Products Index at the following location:

http://www.intel.com/network/csp/products/indx_001.htm 

Q Cooling. If you will be using Internet telephony, your PC may need multiple fans to cool 
the Intel Dialogic Internet telephony boards. 

Q CD ROM drive. One drive is required to install the TeleVantage software and related 
components from the TeleVantage CD.

Q Offline storage. An offline storage device such as a tape drive or Zip drive is useful for 
backing up the TeleVantage database, voice messages, and Windows event logs.

Q Dongle. A dongle is one of the hardware locking options for TeleVantage licenses, and 
is not required. If you want a dongle, contact your TeleVantage provider. Two Rainbow 
Technologies dongles are supported with TeleVantage:

Q Artisoft Computer ID Key Parallel Port Dongle (part #SLM25-4) 

Q Artisoft Computer ID Key USB Dongle (part #SLMUSB-4)

See “How hardware locking works” on page F-9 for more information about dongles 
and other options for hardware locking.

Note: A Server license is required for each TeleVantage Server. See “TeleVantage license 
requirements” on page 3-20 for more information.

TeleVantage system configuration limits 
A single TeleVantage Server can support up to 192 trunks and 480 stations.

Multiple TeleVantage Servers can be connected together using the IP Gateway feature to create 
a combined system with greater capacity. See Administering TeleVantage for details.

Using industrial PCs for large systems 
Small- to medium-size TeleVantage systems can be configured on a standard PC that meets the 
requirements outlined earlier in this chapter. Systems that are not expected to exceed 16 trunks 
by 48 lines—or other configurations not exceeding four telephony boards—can usually be 
constructed in this way. 

Larger systems may require more ISA or PCI slots than are found in a standard PC. These 
systems may also require a bigger power supply to power all the telephony boards. Large 
systems can be built using industrial PCs.

For information about recommended industrial PCs, contact your TeleVantage provider.
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TeleVantage database server requirements ___________________
TeleVantage uses a database server to manage and access the TeleVantage database. 

Q Small, medium, or large TeleVantage Servers with typical office call volumes can use 
Microsoft Data Engine (MSDE), Microsoft SQL Server 7.0 (any edition), or Microsoft 
SQL Server 2000 (any edition.) MSDE is included on the TeleVantage Master CD.

Very large TeleVantage Servers or Servers with heavy call volumes should consider 
using Microsoft SQL Server 2000 Standard or Enterprise Edition, because MSDE 
contains a performance governor that prevents more than 5 simultaneous transactions 
and has a database size limit of 2 GB. SQL Server 2000 must be purchased separately.

Note: SQL Server 2000 Personal, Developer, Evaluation Editions, and the SQL 
Server 2000 Desktop Engine contain the same performance governor as MSDE.

The requirements for the database server are:

Q The database server must be installed on a local drive of the TeleVantage Server. You 
cannot run the database server from a remote PC.

Q 300 MB of free space must be available on the hard drive on which you install the 
database server.

Q Microsoft Internet Explorer 5.0 or higher must be installed on the PC on which the 
database server runs. Internet Explorer 5.5 is included on the TeleVantage Master CD.

Database server memory usage
By default, the TeleVantage database uses up to 50% of the available system memory. 
TeleVantage automatically allocates to itself half of the available system memory.

The memory size is set when the TeleVantage Server starts. If you add more memory to the 
system (for example, to support more extensions or trunks), the new memory size is reset the 
next time you start the TeleVantage Server.

Intel Dialogic hardware requirements ________________________
The particular Dialogic telephony boards you must use with TeleVantage are determined by the 
trunk types that your office uses and the number of internal phones that you need to support. 
Trunk lines from the phone company connect to trunk boards, and internal phones connect to 
station boards.

Dialogic boards must be installed on the TeleVantage Server PC. For installation and 
configuration instructions, see Chapter 8, “Installing Intel Dialogic Hardware” and Chapter 9, 
“Installing and Configuring the Intel Dialogic Drivers.” 
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Board types
TeleVantage supports four types of boards: 

Q Trunk boards. Trunk boards connect the TeleVantage Server PC to trunk lines from 
your telephone service provider. There are trunk boards for analog trunks, T1 trunks, E1 
trunks, and ISDN BRI trunks. There are also Internet telephony boards that support 
Voice-over-IP (VoIP) connections. For details, see “Supported trunk boards” on 
page 3-10.

Q Station boards. Station boards support internal analog phones, music-on-hold devices, 
and paging systems. Most station boards also provide resources for conference calls. For 
details, see “Supported station boards” on page 3-14.

Q Conference bridge boards. Conference bridge boards provide extended conferencing 
capabilities, with up to 60 parties per conference. For details, see “Supported conference 
bridge boards” on page 3-17.

Most TeleVantage configurations have sufficient conference resources available on 
station boards, and do not need to add conference bridges. 

Q Dedicated voice resource boards. Dedicated voice resource boards provide additional 
resources for carrying out audio-processing tasks such as recording or playing audio, and 
detecting touchtone digits. For details, see “Supported station boards for Toshiba digital 
phones” on page 3-15.

While many TeleVantage hardware configurations have sufficient audio-processing 
resources available on trunk boards and do not need to add dedicated voice resource 
boards, others may need additional resources, especially international systems or large 
call center systems. 

Slot types
The type of slot and number of slots required vary by board type. A particular board may require 
1 or 2 ISA or PCI slots, or 1 Universal PCI (UPCI) slot. 

There are 2 voltage specifications for PCI slots, 3.3 and 5 volts. A UPCI board can be installed 
in either type of PCI slot, while regular PCI boards can only be installed in a 5V PCI slot.
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Using the hardware tables: an example
Use the information in the tables on the following pages to determine which boards your system 
requires, based on the number and types of trunks you plan to use, the number of phones you 
need to support, and how you will use TeleVantage. 

In this example, information from the tables has been excerpted for a 3-board hardware 
configuration—an analog trunk board, a station board, and an Internet telephony board: 

Based on the information in this example, you know the following about this hardware 
configuration:

Q This configuration supports an analog phone system with 8 trunks, 24 stations, and 
24-call VoIP capability.

Q The analog trunk board provides 16 Voice resources. See Appendix A, “Voice 
Resource Usage in TeleVantage” for information on how TeleVantage uses voice 
resources, and how to add more if you need them.

Q The configuration in this example uses 112 Timeslots. The total number of timeslots 
used by all the boards in your system cannot exceed 1024 or 4096, depending on several 
factors. See “Timeslot limits” on page 3-10 for more information.

Q In order to install these 3 boards in the chassis of your TeleVantage Server PC, 4 PC 
slots are required—2 ISA slots and 2 PCI slots. 

Be sure that the chassis of your TeleVantage Server PC can accommodate all the boards 
that you require. 

Q This hardware configuration contains 2 SCbus boards and one CTbus board. SCbus and 
CTbus boards use different cables and Physical connectors. 

All Dialogic boards are interconnected by a voice bus within the PC chassis that allows 
for the switching of phone calls and sharing of resources between boards. There are 2 
voice bus types, the SCbus and the CTbus. All ISA boards supported by TeleVantage 
have SCbus connectors. All PCI boards have CTbus connectors. 

Q None of the boards in this example support native CTbus H.100 mode signalling. This 
means that this system will only use SCbus signalling, and the size of the system is 
restricted to a maximum of 1024 timeslots. See “Timeslot limits” on page 3-10 for more 
information.

Intel Dialogic 
model number

Supports
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

D/160SC-8LS 8 analog trunks 16 32 1 ISA SCbus No

MSI/240-GBL 24 stations 0 56 1 ISA SCbus No

DM/IP2431A-T1 24 VoIP calls 0 24 2 PCI CTbus No
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Timeslot limits
The number of timeslots consumed by the Dialogic boards in your TeleVantage Server 
determine the number of trunks and stations your system can support. The information in this 
section is particularly important if you are using a combination of SCbus and CTbus boards.

Q The SCbus supports a maximum of 1024 timeslots, which means that the total number 
of timeslots used by all of the installed Dialogic boards cannot exceed 1024.

Q The CTbus can support 2 signaling modes:

Q In native H.100 mode, the CTbus supports a maximum of 4096 timeslots. Some of 
the CTbus boards supported by TeleVantage support H.100 mode. 

If all the Dialogic boards in the TeleVantage Server are H.100 CTbus boards H.100 
mode is used automatically, and your system supports a maximum of 4096 
timeslots.

Q In legacy SCbus mode, the CTbus supports a maximum of 1024 timeslots, the same 
as the SCbus.

However, if any SCbus or non-H.100 CTbus boards are combined with H.100 
CTbus boards, the CTbus will automatically use legacy SCbus signalling and be 
subject to the 1024-timeslot limit. 

Using the information in the Intel Dialogic Hardware Specification tables, add up the timeslots 
used by each board to make sure you do not exceed the maximum number of timeslots 
supported. For example, you cannot install 10 D/480SC-2T1 SCbus boards, and 5 MSI/80-GBL 
(PCI) CTbus boards, because the total number of timeslots required by this configuration is 
1160, which exceeds the system limit of 1024 timeslots. 

Supported trunk boards
The following tables describe in detail the Dialogic trunk boards supported by TeleVantage. 

Q Analog trunk boards. See page 3-11.

Q T1 trunk boards. See page 3-12.

Q E1 trunk boards. See page 3-12.

Q BRI trunk boards. See page 3-13.

Q Internet telephony boards. See page 3-13.

Depending on the type of phone service you have, some types of trunks may require additional 
hardware. See Chapter 4, “Trunk Options and Requirements” for details.

TeleVantage licenses are required for each trunk line. See “TeleVantage license requirements” 
on page 3-20 for more information.

Important: TeleVantage Watchdog mode works with analog trunks only. In the event of a power 
failure or Windows Server crash, TeleVantage routes the first four incoming analog trunks to the 
first four stations through the Dialogic BCP panel. If you want to use Watchdog mode, your 
TeleVantage system must include some analog trunks. See “Watchdog mode” on page 2-3 for 
more information.
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Supported analog trunk boards
Use analog trunk boards to connect the TeleVantage Server PC to regular analog trunks, analog 
DID trunks, or Centrex/PBX trunks. Most analog trunk boards also supply voice resources. 

The D/41ESC, D/41ESC-Euro, D/41EPCI, and D/41JCT-LS boards require extra voice 
resources when used with TeleVantage. For guidelines on determining how many voice 
resources your system needs, and for instructions on how to install more voice resources, see 
Appendix A, “Voice Resource Usage in TeleVantage.” 

Individual analog trunk boards are designed for use in specific geographical areas. The 
D/41ESC-Euro board can be used in any European country that supports the CTR21 telephony 
standard. 

Note: On the D/120JCT-LS board, only 8 of the 12 ports are used in most configurations, in 
order to reserve 4 voice resources for use by station boards. 

Analog trunk boards

Model number
Analog 
trunks

Voice 
resources

Timeslots Slots
Physical 

connector
H.100 
mode

For use in

D/80SC-4LS 4 8 16

1 ISA SCbus No

North 
America

D/160SC-8LS 8 16 32

D/160SC-LS 16 16 48

D/41ESC 4 4 8

D/41ESC-Euro 4 4 8 Europe

D/41EPCI 4 4 8 1 PCI

CTbus

No
North 

America

D/41JCT-LS 4 4 8 1 UPCI

Yes

North 
America, 
Europe, 
Japan

D/120JCT-LS
12 

(see Note 

below)

12 36 1 PCI
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Supported T1 trunk boards
Use T1 trunk boards to connect the TeleVantage Server PC to ISDN PRI T1 trunks or Robbed 
Bit T1 trunks. T1 trunk boards can be used in North America and Japan.

The following table lists the number of T1 lines and channels supported by each board.

Supported E1 trunk boards
Use E1 trunk boards to connect the TeleVantage Server PC to ISDN PRI E1 trunks or E1 CAS 
trunks. E1 trunk boards can be used in Europe.

E1 boards used with the CAS protocol require extra voice resources when used with 
TeleVantage. For guidelines on determining how many voice resources your system needs, and 
for instructions on how to install more voice resources, see Appendix A, “Voice Resource Usage 
in TeleVantage.” 

The following table lists the number of E1 lines and channels supported by each board.

T1 trunk boards

Model number T1 lines Channels
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

D/240SC-T1

1 24 24 48

1 ISA SCbus
No

D/240PCI-T1 1 PCI
CTbus

D/240JCT-T1 1 UPCI Yes

D/480SC-2T1
2 48 48 96

1 ISA SCbus No

D/480JCT-2T1 1 UPCI CTbus Yes

E1 trunk boards

Model number E1 lines Channels
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

D/300SC-E1

1 30 30
60

1 ISA SCbus
No

D/300PCI-E1 1 PCI
CTbus

D/300JCT-E1 62 1 UPCI Yes

D/600SC-2E1
2 60 60

180 1 ISA SCbus No

D/600JCT-2E1 124 1 UPCI CTbus Yes
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Supported ISDN BRI trunk boards
Use ISDN BRI trunk boards to interface with ISDN BRI trunks. BRI trunk boards can be used 
in Europe.

The BRI/x boards—with the exception of the BRI/2VD—do not provide any voice resources. 
The BRI/2VFD board provides only 4 voice resources. These boards require extra voice 
resources when used with TeleVantage. For guidelines on determining how many voice 
resources your system needs, and for instructions on how to install more voice resources, see 
Appendix A, “Voice Resource Usage in TeleVantage.” 

The following table lists the number of ISDN BRI trunks supported by each board.

Supported Internet telephony boards
Use Internet telephony boards to support Voice-over IP (VoIP) calls. Internet telephony boards 
can be used anywhere in the world.

Internet telephony boards do not provide any voice resources. These boards require extra voice 
resources when used with TeleVantage. For guidelines on determining how many voice 
resources your system needs, and for instructions on how to install more voice resources, see 
Appendix A, “Voice Resource Usage in TeleVantage.” 

TeleVantage uses the Internet telephony boards only to support VoIP calls. T1 and E1 interfaces 
on these boards are not supported.

Intel Dialogic Hardware Specifications

ISDN BRI trunk boards

Model number Trunks
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

BRI/80SC 16

0

24
1 ISA SCbus

No

BRI/160SC 32 48

BRI/80-PCI 16 16
1 PCI

CTbusBRI/160-PCI 32 32

BRI/2VFD 4 4 6 1 PCI
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The following table lists the number of VoIP calls supported by each board. 

Supported station boards
Use station boards to support internal phones, music-on-hold devices, and paging systems. 
Station boards—with the exception of HDSI/x boards—also provide basic conferencing 
resources. Station boards can be used anywhere in the world.

Note: TeleVantage licenses are required for each station. See “TeleVantage license 
requirements” on page 3-20 for more information.

Please note:

Q All MSI/x-GBL boards produce a ringing voltage of approximately 50 volts or about 2 
REN. Verify that your phones meet this specification.

Q HDSI/x boards include an external station interface box (SIB) which provides the analog 
interface for station activity. The SIB sits between the board and the Dialogic Business 
Communications Platform (BCP) connection panel.

Q MSI/xSC-R boards (not listed in the following table) continue to be supported in existing 
TeleVantage systems, but are no longer distributed with new systems. 

Internet telephony boards

Model number
VoIP 
calls

Voice 
resources

Timeslots Slots
Physical 

connector
H.100

DM/IP241-1T1-10P 12

0

48

1 PCI

CTbus

YesDM/IP301-1E1-10P 12 30

DM/IP241-1T1 100BT (PCI) 24 48

DM/IP2431A-T1 24 24 2 PCI No

DM/IP301-1E1 100BT (PCI)
30

62 1 PCI Yes

DM/IP3031A-E1-120 30 2 PCI No

DM/IP481-2T1 100BT (PCI) 48 96
1 PCI Yes

DM/IP601-2E1 100BT (PCI) 60 120
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The following table lists the maximum number of simultaneous conference participants 
supported by each station board, as well as the maximum number of participants that can be 
included in a single conference.

Supported station boards for Toshiba digital phones
If you use Toshiba Strata DKT 2000-series digital phones with TeleVantage, you must use the 
Strata CS-DKTU station board to support them. Strata CS-DKTU station boards can be used 
globally.

Station boards

Model number Stations
Maximum 

conference 
resources

Voice 
resources

Timeslots Slots
Physical 

connector
H.100

MSI/80-GBL 8

32 total, 
up to 7 per 
conference

0

40

1 ISA SCbus NoMSI/160-GBL 16 48

MSI/240-GBL 24 56

MSI/80-GBL 
(PCI)

8 40
1 

PCI
CTbus No

MSI/160-GBL 
(PCI)

16
48

16

DI/SI32 32

12 total, 
up to 12 

per 
conference

44
1 

UPCI

CTbus YesHDSI/480 48

0

48

1 
PCI

HDSI/720 72 72

HDSI/960 96 96

HDSI/1200 120 120
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The CS-DKTU station board supports a maximum of 4 simultaneous conference parties. You 
can add MSI/x or other boards with more conference resources to the TeleVantage Server in 
order to support larger conferences with these phones.

Supported dedicated voice resource boards
Use dedicated voice resource boards if you require additional audio-processing resources for 
carrying out tasks such as recording or playing audio, and detecting touchtone digits. 

See Appendix A, “Voice Resource Usage in TeleVantage” to determine if your hardware 
configuration requires additional voice resources.

Dedicated voice resource boards can be used anywhere in the world.

Station board for digital phones

Model number Stations
Maximum 

conference 
resources

Voice 
resources

Timeslots Slots
Physical 

connector
H.100

CS-DKTU 16
32 total, up 

to 4 per 
conference

0 48 1 PCI CTbus Yes

Intel Dialogic Hardware Specifications

Dedicated voice resource boards

Model number
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

D/80SC 8 8

1 ISA SCbus

No

D/160SC 16 16

D/240SC 24 24

D/320SC 32 32

D/80-PCI 8 8
1 PCI

CTbus
D/320-PCI 32 32

D/160-JCT 16 16
1 UPCI Yes

D/320-JCT 32 32
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Supported conference bridge boards
Use the conference bridge board if you require extended conferencing capabilities beyond the 
conference resources supplied by station boards. 

The conference bridge board supports a maximum of 120 simultaneous conference parties, with 
up to 60 parties per conference.

Note: When more than one type of board that provides conference resources is installed on the 
TeleVantage Server, conference calls may be automatically shifted to a board that supports more 
simultaneous conference participants as parties are added, without interrupting the ongoing 
conference. For more information on how TeleVantage uses conference resources, see 
Administering TeleVantage.

Network requirements ____________________________________
TeleVantage runs simultaneously on two communication systems: 

Q Your internal telephone wiring connects the TeleVantage Server to users’ telephones 
around the office. 

Q A Microsoft TCP/IP local area network connects the TeleVantage Server to users’ 
Windows PCs. This is the typical setup in most installations.

Note: TeleVantage runs on Microsoft networking over TCP/IP. If your site already runs 
a different network protocol, such as Novell IPX, you will need to run a dual stack 
configuration. The TCP/IP networking protocol must be installed on your network.

Using TeleVantage with a LAN
You must use a LAN if any of the following circumstances exist:

Q You are installing TeleVantage software, such as the TeleVantage Client or the 
TeleVantage Administrator, on a remote PC.

Q You are installing an Intel Dialogic DM/IPx board in order to use the TeleVantage 
Internet telephony features.

Q You are using TeleVantage Web Services to provide a Web Client to users via their Web 
browsers.

Q You are using the TeleVantage e-mail notification feature.

Intel Dialogic Hardware Specifications

Conference bridge board

Model number
Maximum conference 

resources
Voice 

resources
Timeslots Slots

Physical 
connector

H.100

DM/V2400A
120 total, up to 60 
per conference

0 240 1 PCI CTbus Yes
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TCP/IP and the Microsoft Network Client software are used to provide three kinds of 
communication for TeleVantage, as follows: 

Q Communication between the TeleVantage database and the Client or Administrator is 
provided by MDAC inter-process communication. This mechanism delivers 
information such as mailbox contents, greetings lists, and Call Log data. 

Q Communications between the TeleVantage Server and the Client or Administrator is 
provided by Microsoft Distributed Component Object Model (DCOM). DCOM allows 
real-time monitoring, call control, and media control, for example, when initiating file 
recording or playing from Windows.

Q Access to voice files stored on the Server is provided by Microsoft networking file 
services so that audio can be played over the speakers on TeleVantage users’ PCs.   

Using TeleVantage without a LAN
It is possible, although not recommended, to run a TeleVantage system without a LAN. In such 
a configuration, users would access TeleVantage only through their phones, not through the 
Client program, and some Client-only features would be unavailable to them. (See Using 
TeleVantage for details about the telephone commands). System administrators would have to 
run the Administrator program on the TeleVantage Server PC itself. 

Note: This manual explains how to configure your network for TeleVantage, but it does not 
describe wiring your premises or installing your LAN itself.

Network configuration requirements
This section explains network configuration requirements for workgroup-based and 
domain-based Windows networks.

Note: If you are installing TeleVantage on a network, the TeleVantage Server PC must be a 
member (stand-alone) Server, not a domain controller.

Microsoft Windows workgroup-based network 
In a Windows workgroup-based network, or a non-Microsoft network such as LANtastic, 
anyone who runs a TeleVantage workstation application requires a network connection to the 
TeleVantage Server. In order for the TeleVantage Server PC to be accessible via the network, 
you must do one of the following:

Q Set up an account for every user who will run a TeleVantage workstation application on 
a different PC in the workgroup. These accounts must be kept in sync with users’ 
accounts on their PCs, for example if a user changes their password, that change must 
be made on the TeleVantage Server as well.

Q Enable the Guest account with an empty password on the TeleVantage Server (not 
recommended for security reasons)

Note: The Windows Server installations disable the Guest account by default.
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Microsoft Windows domain-based network 
In a Windows domain-based network, authentication is provided by the domain controller. In 
this configuration, each TeleVantage user must be a member of the domain that contains the 
TeleVantage Server.

The TeleVantage Server PC must be a member of the domain, or a stand-alone server, but not a 
domain controller.

Novell networks 
To run TeleVantage on a Novell network, you must add Gateway and Client services for 
NetWare as a service on the TeleVantage Server PC.

Requirements for e-mail notification of voice messages 
TeleVantage can automatically send an e-mail message to any address whenever a user receives 
a new voice message. Users can also choose to have the recorded voice message attached to the 
e-mail as a .WAV file. This enables users to receive e-mail and voice mail in one place, and to 
monitor voice mail from a remote location as it arrives. You can also synchronize TeleVantage 
with Microsoft Exchange Server so that voice messages deleted in one place are deleted from 
the other as well.

To use the e-mail notification feature, you must have a Microsoft Windows Messaging 
Application Programming Interface (MAPI) compliant e-mail client, such as Microsoft Outlook 
or Lotus Notes, installed on your TeleVantage Server. You do not need a MAPI-compliant 
e-mail Server. For example, if your mail server does not support MAPI but does support SMTP, 
you can still use Outlook (which does support MAPI) to enable TeleVantage e-mail notification.

Supported e-mail clients
TeleVantage has been tested with Microsoft Outlook and Lotus Notes e-mail clients. E-mail 
notification should work with any MAPI-compliant e-mail client. Microsoft Outlook Express is 
not supported.

Note: When using MAPI e-mail clients other than Outlook, the MAPI subsystem must be 
installed separately. The MAPI subsystem is included on the Windows NT 4 CD. On a Windows 
2000 Server, the only way to get the MAPI subsystem is to install Outlook.

See the documentation that came with your e-mail client for installation and configuration 
procedures.
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IP telephony requirements 
IP telephony uses the H.323 protocol, which can be incompatible with the following network 
devices:

Q Firewalls

Q Network Address Translators (NATs)

Q Packet filters

Q Proxy servers

If you are planning to use IP telephony, check with the vendors of these devices to make sure 
that they support H.323. 

Proxy server requirements 
If your network uses a proxy server to access the Internet, a special configuration is required on 
Windows NT and Windows 2000 PCs in order to run TeleVantage workstation applications. See 
“Configuring TeleVantage for use with a proxy server” on page 11-14.

If you are using Microsoft Proxy Server, TeleVantage requires version 2.0 or later. 

TeleVantage license requirements ___________________________
TeleVantage licenses can be used for 60 days before they must be activated to a hardware key 
over the Internet. See “Entering and activating your TeleVantage licenses” on page 11-7 for 
details.

The following licenses are available. The specific licenses that you need depend on how you 
plan to use TeleVantage.

Q Server license. Required for each TeleVantage Server. You must have a valid Server 
license in order to start the TeleVantage Server. A Server license is provided when you 
purchase TeleVantage, and authorizes you to run one copy of the TeleVantage Server. 
Only one Server license is required per TeleVantage Server regardless of the number of 
trunks or users the Server supports.

In order to answer or place calls, you need the following licenses:

Q Trunk license. Required for each trunk line. You must have a valid Trunk license for 
each analog, T1, E1, or BRI trunk connected to the TeleVantage Server.

Q IP Port license. Required for each Internet telephony port. You must have a valid IP 
Port license for each Internet trunk connected to the TeleVantage Server.

Q Station license. Required for each internal phone. You must have a valid Station license 
for each internal phone connected to the TeleVantage Server. 

A valid Station license is also required for each running instance of an IVR Plug-in. For 
more information about IVR Plug-in licensing, see Administering TeleVantage.
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In order to use the TeleVantage Client, TeleVantage Call Center, or TeleVantage Call Center 
Reporter, you need the following licenses:

Q Client license. Used by the TeleVantage Client, Web Client, or custom applications 
developed with the TeleVantage SDK that use a Client API session. 

The TeleVantage Client requires one Client license per PC. With one Client license, a 
user can log on to multiple Clients on a single PC. 

Unlike the Client, the Web Client and Client API sessions are licensed per user, not per 
PC. Therefore, a user can log on to multiple Web Clients or Client API sessions with 
only one Client license, even on multiple PCs. Also, only one Client license is used if 
the same user is logged on simultaneously to the Client, multiple Web Clients, and 
multiple Client API sessions.

Q Call Center Agent license. Required for each agent who is a member of a call center 
queue. A single licensed agent can participate in multiple call center queues. 

Q Reporter license. Required to run the TeleVantage Call Center Reporter. If you want to 
use the Reporter, even for non-queue reports such as call activity on trunks, you need a 
Call Center Reporter license. 

See “How TeleVantage licenses affect system behavior” on page F-1 for more information.

To see a license summary that shows the total number of each type of license currently installed 
on the TeleVantage Server, in the Administrator choose Tools > System Settings, and then 
click the Licenses tab. The Stations field under License summary displays the total number of 
licenses.

You must supply valid license serial numbers and verification keys to the TeleVantage Server 
before you can use the corresponding trunks, stations, and TeleVantage Clients. For this reason, 
you may want to purchase additional licenses from your TeleVantage provider to allow for 
expected system growth so that you do not have to wait for a license the next time you expand 
your system.
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Administrator and Client requirements _______________________
PCs running the Administrator or the Client workstation applications must meet the following 
requirements:

Q Operating system. Windows XP, 2000, or NT 4.0 SP6a or higher.

Note: Windows 98 or ME can be used but are not recommended because of the 
multi-tasking performance limitations of those operating systems. For users running 
high call volumes, such as operators or call center agents, Windows 98 or ME should 
not be used. 

Q Processor. Minimum Pentium II 400 MHz.

Q Memory. Minimum 128 MB RAM for Windows NT, 2000, 98, or ME. Minimum 256 
MB RAM for Windows XP.

Q Disk space. 10 MB free disk space.

Q Software. 

Q TCP/IP with Microsoft Network Client.

Q Internet Explorer 5.0 or later. Internet Explorer 5.5 is provided on the TeleVantage 
Master CD.

Q On Windows 98 PCs, Microsoft DCOM 98. See “Downloading DCOM 98 onto 
your TeleVantage Server” on page 12-3.

Q Hardware. Sound card and speakers for the TeleVantage Client.

Q Network connection. TCP/IP connection to the TeleVantage Server. See “Network 
requirements” on page 3-17.

Q Associated station port. You cannot use a station ID of 0.

Note: A Client license is required in order to use the TeleVantage Client. See “TeleVantage 
license requirements” on page 3-20 for more information.

Using a wheel mouse with TeleVantage 
To scroll through Client or Administrator views using a Microsoft mouse with a mouse wheel, 
you must have installed the latest Microsoft Intellipoint driver. 

To obtain the latest Intellipoint driver, go to the following location and search for a download 
using the keyword “Intellipoint”:

http://www.microsoft.com/downloads
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TAPI Service Provider/Contact Manager Assistant requirements _
The PC on which you want to install the TeleVantage TAPI Service Provider or the TeleVantage 
Contact Manager Assistant workstation applications must meet the following minimum 
requirements:

Q Operating system. Windows 98, ME, XP, 2000, or Windows NT 4.0 SP6a or higher.

Q Software. The Contact Manager Assistant requires the TAPI Service Provider. Neither 
the Contact Manager Assistant or the TAPI Service Provider require the presence of the 
TeleVantage Client on the same PC.

The following contact managers are also supported:

Q Act! 3.0, 4.0, and 2000

Q Goldmine 4.0 and 5.0, and Goldmine Business Contact Manager 5.7

Q Goldmine FrontOffice 2000

Q Microsoft Outlook 98, 2000, and XP

Q Network connection. To the TeleVantage Server. See “Network requirements” on 
page 3-17. 

Web Services requirements________________________________
The PC on which you want to install TeleVantage Web Services must meet the following 
minimum requirements:

Q Operating system. Windows 2000 or Windows NT 4.0 SP6a or higher support up to 5 
users connected to the Web Server simultaneously. Windows 2000 Server or Windows 
NT Server 4.0 SP6a or higher support more than 5 simultaneous users.

Q Windows NT 4.0 requirements: 

Microsoft Internet Information Server (IIS) 4.0 or greater. IIS 4.0 is part of the 
Windows NT 4.0 Option Pack. To download it, go to the following location and 
search for “Option Pack”.

http://www.microsoft.com/ntworkstation/downloads/

Q Processor. Minimum Pentium II 400 MHz.

Q Memory. 256 MB or more depending on the number of simultaneous users.

Q Disk space. 200 MB.

Q Network connection. To the TeleVantage Server. See “Network requirements” on 
page 3-17. 
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You can install the TeleVantage Web Services on the same PC as the TeleVantage Server if you 
plan to use the Microsoft Internet Information Server to support a small number of simultaneous 
connections for TeleVantage purposes only. However, if you plan to use the TeleVantage Web 
Services to support many TeleVantage users or for other high-volume Web-related activity, it is 
strongly recommended that you install it on a separate networked PC, not the TeleVantage 
Server.

Note: A Client license is required in order to use the TeleVantage Web Client. See “TeleVantage 
license requirements” on page 3-20 for more information.

Call Center Reporter requirements___________________________
The Call Center Reporter is installed along with the TeleVantage Client. To run the TeleVantage 
Call Center Reporter you must have the following: 

Q A PC that meets the requirements listed in “Administrator and Client requirements” on 
page 3-22.

Q Microsoft Excel 2000 or Excel XP installed on the PC. Excel 97 is not supported.

Q A Reporter license. See “TeleVantage license requirements” on page 3-20 for more 
information.

TeleVantage SMDR Service requirements _____________________
The TeleVantage Station Message Detail Recording (SMDR) Service requires the following on 
the TeleVantage Server:

Q An available COM port, if your call accounting package requires one. 

Q The TeleVantage Client workstation application. The Client can share a license with 
another user (See “TeleVantage license requirements” on page 3-20.) 

Emergency dialing service requirements _____________________
TeleVantage supports standard 911 and Enhanced 911 (E-911) emergency dialing services as 
follows:

Q A standard 911 call does not require any additional hardware. All standard 911 calls use 
a TeleVantage trunk and go through the local carrier to the emergency dispatching 
center. 

Q All E-911 calls go through a special E-911 device and do not use a TeleVantage trunk. 
Typically, a dedicated trunk connects the E-911 device directly to the emergency 
dispatching center. 
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An E-911 call transmits the Automatic Number Identification (ANI) of the calling 
station as the TeleVantage station ID. This information allows the E-911 center at the 
telephone company to identify the location of the person who made the emergency call. 
For example, this information includes the specific floor and office in a large building 
from which the call was made. 

Contact your local telephone company to determine the emergency dialing services that are 
available in your area. 

Enhanced 911 service requirements 
After you determine that E-911 service is available from your phone company, you need to 
install and configure an E-911 device to make E-911 calls from TeleVantage stations. 

Note: When configuring the E-911 device, enter each station number as a 4-digit number, 
adding a leading zero if necessary. For example, enter station 3 as 0003, station 123 as 0123, etc.

Once the E-911 device is installed and configured, use telephone cable to connect it to an 
available station port. See Administering TeleVantage for more about setting up E-911 stations.

E-911 device suppliers 
For more information about obtaining, installing, and configuring an E-911 device, contact:

Teltronics, Inc.
www.teltronics.com
800-877-8358 (U.S.)
941-753-5000 ext 7315
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Introduction _____________________________________________ 
Trunks are the phone lines that you order from the telephone company. This chapter describes 
requirements for the trunks and services you can use with TeleVantage.

See “Supported trunk boards” on page 3-10 for information about the Intel Dialogic boards 
required to support various trunk types.

Connecting trunk lines to the Dialogic boards in your TeleVantage Server PC is covered in 
Chapter 8.

After you have connected your trunks to the TeleVantage Server, you must configure them in 
the TeleVantage Administrator. See Administering TeleVantage for details.

Ordering services from your telephone company ______________
You can order the following services when you order trunks from your telephone company.

Q Caller identification 

Q Direct Inward Dial (DID)

Q Hunt groups

Q Inbound-only and outbound-only trunks

Q Emergency Dialing service

Q Call waiting

Caller identification

Inbound caller identification
Caller ID or Automatic Number Identification (ANI) is used by TeleVantage as a means of 
identifying incoming calls. Many useful TeleVantage features rely on caller identification. 
Customized greetings, customized routing lists, and call rules for individuals all use caller 
identification. 

It is highly recommended that you order a caller identification service for all of your trunk lines. 

Q For analog trunks, order Caller ID.

Q For T1, E1, ISDN BRI, or analog DID trunks, order ANI.

Note: For Internet telephony, Caller ID is automatically supported by the Dialogic IP boards.
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Outbound caller identification
TeleVantage allows you to specify custom outbound Caller ID information on ISDN trunks. 

Not all ISDN providers support custom numbers as outbound Caller ID—some restrict you to 
using only registered numbers for your trunks, and some do not allow you to set custom Caller 
ID at all. If you want to specify custom numbers as outbound caller ID on your ISDN trunks, 
ask your ISDN provider if they support custom calling party numbers, sometimes referred to as 
custom Caller ID or customer-defined Caller ID.

For more about configuring outbound Caller ID, see Administering TeleVantage.

Direct Inward Dial 
When you order DID, your site is given a block of sequential telephone numbers. You then 
assign these numbers to individual phones within TeleVantage. In this way callers can dial users 
assigned to those phones directly, without having to go through an auto attendant or operator. 
DID generally transmits the last three or four digits of the phone number dialed. TeleVantage 
recognizes the DID digits and routes the call to the appropriate user or auto attendant. DID 
enables you to set up private phone numbers for users without having to dedicate trunks.

Another service, Dialed Number Identification Service (DNIS) works in the same way as DID, 
but is used for toll-free lines such as 800, 877, and 888 numbers. In TeleVantage, DID refers to 
both DID and DNIS.

To use DID, you must configure your TeleVantage trunks to recognize it. For instructions, see 
Administering TeleVantage.

Hunt groups 
Trunks used with TeleVantage must be configured by the phone company in a terminated hunt 
group so that calls roll over to the next trunk if the first one is busy.

In this arrangement, incoming calls try the lowest numbered phone line first. If that line is busy, 
they try the next higher phone line and continue trying lines until a free line is found. If you will 
be using the same trunks for both inbound and outbound calls, you must configure dialing 
services in the Administrator so that on outbound calls, TeleVantage starts searching for a free 
line from the highest numbered trunk. This configuration helps to limit glare conflicts on lines.

Inbound- and outbound-only trunks
Inbound-only trunks and outbound-only trunks do not affect TeleVantage performance, but they 
may be of benefit in your organization. If you order them, you must configure them in the 
Administrator. See Administering TeleVantage for details.
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Emergency dialing service 
Consult your local phone company to determine the emergency dialing services that are 
available in your area. For information about using Enhanced 911 service, which is designed to 
help the local emergency dispatching center identify the precise location of a caller making an 
emergency call, see “Enhanced 911 service requirements” on page 3-25. 

Call waiting 
It is strongly recommended that you do not order call waiting on analog trunk lines. TeleVantage 
provides its own call waiting tone to users on incoming calls. If telephone company call waiting 
tones arrive as well, they can confuse users.

Analog trunk requirements_________________________________
TeleVantage supports standard loop-start analog trunks. TeleVantage can also use Centrex 
trunks or operate behind a PBX that is connected to the central office at the telephone company.

Additional required hardware for analog service
No additional hardware is required for analog or Centrex/PBX trunks.

To support analog DID service, you need a DID interface unit which sits between TeleVantage 
and your phone company. One DID interface unit can support up to 4 analog DID trunks. For 
information about DID interface units that work with TeleVantage, see your TeleVantage 
provider. 

To support Watchdog mode, you need an Intel Dialogic Business Communications Platform 
(BCP) Connection Panel. See “Watchdog mode” on page 2-3 for details.

T1 trunk requirements_____________________________________
TeleVantage supports two protocols over T1 lines:

Q Robbed Bit

Q ISDN

T1 carrier requirements 
The following table lists the T1 configuration requirements for TeleVantage. You must supply 
this information to your phone company when you order T1 service.

T1 Requirements for TeleVantage

Framing Type D4 Superframe or Extended Superframe

Interface DSX-1

Supervisory signal 2- or 4-wire E&M
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T1 ISDN PRI Protocols
TeleVantage currently supports the following ISDN PRI protocols over T1 lines. The drivers for 
these protocols are provided on the TeleVantage CD. Contact your TeleVantage provider if your 
protocol is not listed.

Q 4ESS

Q 5ESS

Q CR13

Q DMS/100

Q DMS/250

Q INS1500

Q National ISDN 2 (NI2) 

Additional required hardware for T1 service
Robbed Bit T1 service requires the following:

Q Channel Service Unit (CSU). 

Q Cable. Connects the CSU to the Dialogic board, provided by the CSU vendor.

ISDN T1 service requires the following:

Q Network Termination Unit (NTU). Most ISDN installations include an NTU from the 
phone company, so you should ask your phone company for details. Connect the NTU 
between TeleVantage and the digital line coming in from the phone company. 

If you do not have an NTU available, you can use a standard Channel Service Unit 
(CSU) that handles Extended Superframe Format (ESF) instead.

Q Network Termination type 1 adapter (NT1). Typically supplied by the phone 
company.

Wink Wink and double wink

Line coding/Framing For D4 Superframe: AMI
For Extended Superframe: B8ZS

Digit signaling Robbed Bit: DTMF or MF 
ISDN: DTMF

T1 Requirements for TeleVantage
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Q Cable. Connects the NTU to the Dialogic board. When ordering one from your supplier, 
specify the following:

Q Recommended cable type. Twisted-pair, in which each of the two pairs is 
shielded and the two pairs also have a common shield.

Q Connectors. The cable connects to the board via a RJ-45 Modular connector on the 
front or rear bracket of the board.

Connect the CSU or NTU between TeleVantage and the digital line coming in from the phone 
company. 

Note: A Digital Service Unit (DSU) is not required because the Dialogic boards supply DSU 
functionality.

U.S. local and long-distance service
Two kinds of T1 trunks are available from phone companies in the United States, local and 
long-distance.

Local T1 trunks
Local T1 trunks operate similarly to local analog lines, in that local calls are free, and you can 
place long-distance calls using the long-distance carrier of your choice.

Important: It is recommended that you not use local T1 lines because they do not supply ANI 
Caller ID information used by TeleVantage to recognize contacts when they call. Most incoming 
calls from contacts on local T1 trunks will display as “Unknown” in the Call Log and in the Client 
Call Monitor and Voice Messages views. Also, call rules for external contacts will not work.

Local T1 trunks support DID, and you can order blocks of DID numbers for each T1 line.

Long-distance T1 trunks
Long-distance T1 trunks handle local and long-distance calls through the same carrier, so that 
all outbound calls are charged at the rate charged by your long-distance carrier.

Long-distance T1 trunks do not support outbound toll-free calls, for example, to 411 or 800 and 
888 numbers, and require that you dial the area code for all numbers, even those in your local 
area.

Long-distance T1 trunks provide ANI, which enables full TeleVantage functionality. DID is 
supported on incoming calls only if the line is used for toll-free calling, for example, 800 or 888 
numbers.

Because of the higher cost and limitations on outbound calls, long-distance T1 lines are 
recommended for inbound-only trunks, for example, in call centers. 

Installing T1 trunk boards and connecting trunks
For instructions on installing the Dialogic D/240SC-T1 or D/480SC-2T1 voice board and 
connecting trunks, see Chapter 8.
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E1 trunk requirements ____________________________________
TeleVantage supports both kinds of E1 service:

Q ISDN

Q CAS

E1 carrier requirements 
TeleVantage currently supports the following ISDN PRI protocols over E1 lines. The drivers for 
these protocols are provided on the TeleVantage CD. Contact your TeleVantage provider if your 
protocol is not listed here.

E1 ISDN PRI Protocols
Q Austel

Q CTR4 (ETSI 300)

Q DASS2

Q EuroISDN

Q ITR6

Q PTC132

Q VN3

Q VN4

E1 CAS Protocols
For information about the E1 CAS protocols supported, see your TeleVantage provider,

Additional required hardware for E1 service
No additional hardware is required to support E1 CAS service.

To support E1 ISDN service, you need the following:

Q Network Termination Unit (NTU). Most ISDN installations include an NTU from the 
phone company, so you should ask your phone company for details. Connect the NTU 
between TeleVantage and the digital line coming in from the phone company. 

If you do not have an NTU available, you can use a standard Channel Service Unit 
(CSU) that handles Extended Superframe Format (ESF) instead.

Q Network Termination type 1 adapter (NT1). Typically supplied by the phone 
company. 
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Q Cable. Connects an NTU to the Dialogic board. When ordering one from your supplier, 
specify the following:

Q Recommended cable type. Twisted-pair, in which each of the two pairs is 
shielded and the two pairs also have a common shield.

Q Connectors. The cable connects to the board via a RJ-45 Modular connector on the 
front or rear bracket of the board.

Note: A Digital Service Unit (DSU) is not required because the Dialogic boards supply DSU 
functionality.

ISDN BRI trunk requirements _______________________________
TeleVantage supports ISDN BRI trunks. Connecting BRI devices such as BRI phones to 
Dialogic ISDN BRI boards is not supported.

ISDN BRI carrier requirements
TeleVantage supports the following ISDN BRI protocols. The drivers for these protocols are 
provided on the TeleVantage Drivers CD. Contact your TeleVantage provider if your protocol 
is not listed here.

ISDN BRI Protocols
Q 5ESS (ATT 5ESS BRI)

Q DMS100 (Northern Telecom DMS100 BRI)

Q NTT (Japanese INS-Net 64 BRI)

Q NET3 (EuroISDN BRI)

Q NI1 (National ISDN 1)

Q NI2 (National ISDN 2)

North American ISDN BRI installations should receive a unique Service Profile Identifier 
(SPID) number for each ISDN BRI channel from their carrier.

Additional required hardware for ISDN BRI service
To support ISDN BRI service, you need the following:

Q Intel Dialogic shielded breakout box. Part number 89-0592-001.

Q Intel Dialogic SCSI-3 BRI breakout box cable. Part number 99-2280-003.

Q Network Termination type 1 adapter (NT1). Typically supplied by the phone 
company. Connect the NT1 between TeleVantage and the digital line coming in from 
the phone company.

All BRI/SCx and BRI/x-PCI boards require an NT1. Contact your phone company to 
determine if your BRI/2VFD board needs a termination device.
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Q Cable. Connects the NT1 to the Dialogic board. See the Quick Install Card included 
with your Dialogic BRI board for details.

Q BRI/SCx and BRI/x-PCI boards require a special cable with pins 3 and 4 crossed, 
pins 5 and 6 crossed, and pins 1, 2, 7, and 8 wired straight through. 

Q The BRI/2VFD board uses an RJ-45 cable.

Shareable voice resources
Unlike other Dialogic trunk boards, the BRI boards—with the exception of the 
BRI/2VFD—do not supply any voice resources to handle auto attendants, voice mail 
access, or other TeleVantage features. To use BRI boards with TeleVantage, you must 
install extra Dialogic boards that provide shareable voice resources. See “Supported 
station boards for Toshiba digital phones” on page 3-15 for a list of Dialogic boards that 
provide dedicated voice resources.

ISDN Megacom requirements ______________________________
If you are using ISDN Megacom service, you must make specific modifications to the Windows 
registry on the TeleVantage Server PC in order to make outbound international calls. See 
Administering TeleVantage for details.

Internet telephony requirements ____________________________
Placing TeleVantage calls over the Internet or your private TCP/IP network does not require 
additional telephone company trunks. The Dialogic Internet telephony board connects directly 
to your network and accesses the Internet over the normal Internet or TCP/IP network 
connection used in your company.
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Introduction
For instructions on connecting your phones to the Intel Dialogic boards in your TeleVantage 
Server PC, see Chapter 8.

Supported phones________________________________________

Using IP phones with TeleVantage
Supported IP phones include Microsoft NetMeeting software, Polycom IP phones, and other 
H.323-compliant devices. For more information about using IP phones with TeleVantage, see 
Administering TeleVantage, Chapter 13, “Configuring Internet Telephony Support” and 
Appendix E, “Using the Polycom IP Phone with TeleVantage”.

Using analog phones with TeleVantage
TeleVantage supports standard analog touchtone telephones—called 2500 sets in U.S. 
telephone terminology—for internal stations. Multiline analog phones can also be used, but line 
use indicator lights may not perform correctly on some models.

CLASS feature support
TeleVantage supports analog phones with the following CLASS features:

Q Caller ID.

Q Caller ID on call waiting.

Q A CLASS Bellcore message waiting indicator. Message waiting lights other than 
CLASS Bellcore are not supported with TeleVantage.

On most phones that support CLASS features, the features are activated by default. Refer to the 
documentation that came with your phone for any setup steps required to activate these features.

Note: Two TeleVantage Windows registry settings specify the format used to send Caller ID or 
visual message waiting information to CLASS phones. See Administering TeleVantage for more 
information.
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ADSI support
TeleVantage supports Analog Display Service Interface (ADSI) phones. In addition to the 
CLASS features described in the previous section, ADSI phones provide soft-button access to 
most TeleVantage functions. ADSI phones support the following TeleVantage features:

Q Voice-first answering

Q Intercom

Q Paging

Important: You may need to update the script that is running on your ADSI phone. To do this, 
contact your phone supplier. Phone scripts for ADSI phones can also be obtained from a variety 
of ADSI script developers, for example:
Telephony Supply, Inc.
info@telephonysupply.com
http://www.telephonysupply.com)

See Administering TeleVantage and Using TeleVantage for more about setting up and using these 
features.

Supported analog phones
Analog phones tested with TeleVantage include those listed in the following table. Talk to your 
TeleVantage provider for more information about phones to use with TeleVantage.

Manufacturer Model CLASS features ADSI

Aastra 9316CW Caller ID
Caller ID on call waiting 
Message waiting indicator

No

Maestro 900 DSS Caller ID
Caller ID on call waiting

No

PowerTouch 390
PowerTouch 480

Caller ID
Caller ID on call waiting 
Message waiting indicator

Yes

AT&T 956
957
960

Caller ID
Caller ID on call waiting
Message waiting indicator

No

951 Message waiting indicator No

9130 Cordless Caller ID
Caller ID on call waiting

No
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Wiring requirements ______________________________________
Stations are connected to the Server using standard 2-wire tip and ring telephone cable. 
Four-wire cabling can be used if it is already in use at your facility. All connections to the Server, 
both station and analog trunk lines, must be terminated with RJ-11 connectors. For digital trunk 
line requirements, see your local service provider.

Replacing an existing PBX 
If you are replacing an existing PBX with TeleVantage, the information in this section may 
apply to you.

Wiring punch down blocks to TeleVantage
Punch down blocks are commonly used to terminate 50-pair cables from offices to the wiring 
closet at the company location, and from the wiring closet to the telephone company. Each 
phone connection from this punch down block—that is, each station or trunk—must be 
connected to a wire terminated with an RJ-11 connector in order to be connected to the Dialogic 
BCP panel.

Wiring patch panels to TeleVantage
If your offices are wired to patch panels, you can use a standard phone cord with RJ-11 
connectors from the patch panel to the Dialogic BCP panel. This method assumes that the patch 
panel accepts RJ-11 connectors. Network patch panels generally use RJ-45 connectors but often 
accept RJ-11 connectors as well.

Cybiotronics Ltd. Cybiolink P-I
CybioLink CY-2135-B
CybioLink CY-2135-BH
(model -BH includes headset 
jack)

Caller ID
Caller ID on call waiting 
Message waiting indicator

Yes

Sony Caller ID IT70 Caller ID
Caller ID on call waiting

No

Radio Shack System 1350 Caller ID 
Speakerphone (430-0987)

Caller ID
Caller ID on call waiting 
Message waiting indicator

No

Vodavi 
Communications 
Systems

STARPLUS 2706 (Caller ID) Caller ID
Caller ID on call waiting 
Message waiting indicator

No

Manufacturer Model CLASS features ADSI
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Replacing telephones connected directly to trunk lines 
If you are not replacing a PBX and your office phones are connected directly to trunk lines, the 
office may need to be rewired. Trunk lines must come to a central location at the TeleVantage 
Server and station lines must be wired from the TeleVantage Server to the offices.

Using TeleVantage with a paging system _____________________
You can attach an external paging device to a station or trunk port. For a station port, you must 
then activate the hands-free feature for that extension as described in Administering 
TeleVantage.

For more information about standard PBX paging systems from various manufacturers, contact:

Graybar Electric Company, Inc.
http://www.graybar.com
1-800-472-9227
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Introduction _____________________________________________
All the software that you need to upgrade your existing TeleVantage system or to install a new 
TeleVantage system is contained on two CDs. To use the setup program on a CD, start it as 
directed in this manual, and then follow the on-screen instructions. Not all screens are described 
in detail in this manual. 

Note: The setup program starts automatically when you insert either CD into your CD-ROM 
drive. You can also start the setup program manually by running autorun.exe from the root 
directory on either CD. If the message “Corrupt installation detected” appears after you insert the 
CD or run autorun.exe, log on as a local administrator, and then reinsert the CD.

The TeleVantage Drivers CD
The Driver Setup program on the TeleVantage Drivers CD allows you to install the following 
TeleVantage components:

Q Intel Dialogic System Release 5.1.1 Drivers

Q Intel Dialogic SR 5.1.1 SP1

Q Intel Dialogic Driver Updates

You can also view the product release notes from the Driver Setup on the TeleVantage Drivers 
CD.

The TeleVantage Master CD
The Master Setup program on the TeleVantage Master CD allows you to install the following 
TeleVantage components:

Q Microsoft Data Engine (MSDE)

Q TeleVantage Server

Q TeleVantage Web Services

The TeleVantage Master CD also contains the TeleVantage workstation applications. For 
information on installing the TeleVantage workstation applications, see Chapter 12.

Upgrading vs. installing for the first time
If you are upgrading from a previous version of TeleVantage, go to “Upgrading from a previous 
version of TeleVantage” on page 6-3.

If you are installing a new TeleVantage system, go to “Installing a TeleVantage system for the 
first time” on page 6-10.

Troubleshooting installation problems
If you experience problems after completing a first-time installation or upgrade, see Appendix 
D, “Troubleshooting” for more information. 
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Upgrading from a previous version of TeleVantage_____________
Read this section carefully if you are upgrading an existing TeleVantage system. Be sure to 
follow the instructions in “Preparing your system for upgrade” on page 6-6. 

Important: Do not under any circumstances uninstall the TeleVantage Server or SQL Server. 
If you uninstall either one, you will lose your TeleVantage database and voice messages. The 
TeleVantage installation program preserves your earlier TeleVantage Server configuration, 
including voice messages and prompts. If you follow the instructions in this manual, you will not 
lose any data when you upgrade.

Scheduling an upgrade
If you are upgrading the live telephone system at your company, you must schedule the 
installation after business hours. The process of installing TeleVantage can take more than two 
hours. It can take significantly longer if you must configure and test T1, E1, BRI, or IP trunks. 
During this time, your telephone system will be offline and unavailable.

Notes for specific upgrade paths
This section contains information about specific upgrades. Be sure to read the information that 
applies to your upgrade.

Upgrading from TeleVantage 4.x
Note the following changes in TeleVantage 5:

Q Dialogic DNA 3.3 drivers and Dialogic Driver Updates are replaced by Dialogic SR 
5.1.1, SR 5.1.1 SP1, and Driver Updates.

Upgrading from TeleVantage 3.5
Note the following changes in TeleVantage 5:

Q Dialogic DNA 3.3 drivers are replaced by Dialogic SR 5.1.1, SR 5.1.1 SP1, and Driver 
Updates.

Q MediaCom least cost routing (LCR) software is no longer included with TeleVantage. 
This functionality has been replaced by routing services, which are a special type of 
dialing service.

Upgrading from TeleVantage 3.5 onto a different TeleVantage Server PC
The following procedure describes how to upgrade from TeleVantage 3.5 on one TeleVantage 
Server PC to TeleVantage 5 on a different TeleVantage Server PC. 

1. Back up the TeleVantage database and voice files on the old TeleVantage Server 
according to the instructions in “Backing up the TeleVantage database and voice files” 
on page 6-6.

2. Install TeleVantage 3.5 on the PC that will be used as the new TeleVantage Server. 
Use the documentation that came with your copy of TeleVantage 3.5.
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3. Restore the backed-up database files (backup.dmp, extension.mdb, and tvrdb.mdb) 
onto the new TeleVantage Server. See Administering TeleVantage for information 
about how to restore files after a backup.

4. Upgrade the new TeleVantage Server PC to TeleVantage 5 according to the 
instructions in this manual.

Upgrading from TeleVantage 3.0
Note the following changes in TeleVantage 5:

Q Dialogic DNA 3.2 drivers are replaced by Dialogic SR 5.1.1, SR 5.1.1 SP1, and Driver 
Updates.

Q Internet-to-Phone Number and Internet-to-Centrex/PBX Extension dialing services do 
not upgrade automatically. Before you upgrade to TeleVantage 5, write down all the 
following information:

Q All field information contained on the General tab in the User dialog box for any 
user with the This user authenticates IP Gateway calls feature enabled. 
Double-click each user in the Users view to open the User dialog box.

Q All field information contained on each of the tabs of the Internet-to-Phone Number 
Service dialog box. Double-click the dialing service in the Dialing Services view to 
open the dialog box.

Q All field information contained on each of the tabs of the Internet-to-Centrex/PBX 
Extension Service dialog box. Double-click the dialing service in the Dialing 
Services view to open the dialog box.

See Administering TeleVantage for more information about configuring these dialing 
services and their associated IP Gateways after the upgrade is complete.

You do not need to enter Internet Address dialing services again after the upgrade is 
complete because they upgrade automatically.

Upgrading from TeleVantage 2.1 or earlier
Note the following changes in TeleVantage 5:

Q Dialogic 98.02 Streams-based drivers are replaced by Dialogic SR 5.1.1, SR 5.1.1 SP1, 
and Driver Updates.

Q MediaCom least cost routing software is no longer included with TeleVantage. This 
functionality has been replaced by routing services, which are a special type of dialing 
service.

Q Business hours are not retained during the upgrade. Make a note of the business hours 
that you have set up in Tools > System Settings > Business Hours, so that after 
installation you can enter them again in the Administrator. See Administering 
TeleVantage for more information.
6-4 INSTALLING TELEVANTAGE



Q Microsoft Data Engine (MSDE) is installed from the TeleVantage CD to upgrade your 
TeleVantage database. Leave Microsoft SQL Server 6.5 or later installed until the 
TeleVantage system is installed and running correctly. You can uninstall SQL Server 6.5 
or later after the upgrade is complete.

Important special upgrade scenarios
This section contains information about other tasks you may want to do at the same time that 
you upgrade.

Adding voice resources
If you are planning to use the TeleVantage intercom, paging, voice-first answering, or system 
call reporting features, you may need to add voice resources to your system. See Appendix A, 
“Voice Resource Usage in TeleVantage” for more information. For information about these 
features, see Administering TeleVantage.

Changing the domain of the TeleVantage Server
See Appendix E, “Changing the Domain of the TeleVantage Server” if any of the following 
conditions apply to your upgrade:

Q Your network configuration has changed, and you now have a domain that you want the 
TeleVantage Server to be a part of.

Q You recently installed a Microsoft Exchange Server on your network, and you now want 
to support e-mail notification in TeleVantage. To support this feature, the TeleVantage 
Server must be on a domain.

Q You changed the name or password of the domain user.

Q You moved the TeleVantage Server to a different domain.

Moving the TeleVantage voice files
If you want to upgrade your TeleVantage system, but do not have enough free space on your 
disk to perform the installation, you can move the TeleVantage voice files to another location 
before performing the upgrade. See Administering TeleVantage for more information about 
moving voice files.

Moving the TeleVantage Server to a new PC
You can move the TeleVantage Server to a new PC when you upgrade, for example, if you have 
outgrown the original PC you are using for your TeleVantage Server. If the original PC is 
running TeleVantage 5.x, see “Moving the TeleVantage Server” on page F-11 for information 
about license activation considerations.
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To move the TeleVantage Server to a new PC

1. Make sure that the Windows user name you log in as to install TeleVantage on the new 
PC is the same user name as on the original PC.

2. On the new PC, install the exact same version of TeleVantage that is installed on the 
original PC (for example, version 4.1), plus any TeleVantage service packs and hot 
fixes that you have installed. 

Note: Be sure to install exactly the same TeleVantage system prompt languages on 
the new TeleVantage Server PC as on the original PC. For example, if you installed 
Spanish and English system prompts on the original PC, install those languages on the 
new PC as well.

3. Backup the TeleVantage database and voice files on the original PC. Then, restore the 
TeleVantage database and voice files to the new PC. See “Backing up the TeleVantage 
database and voice files” on page 6-6.

4. Make sure that the new PC is operating properly.

5. Upgrade the new PC to version 5.0 according to the instructions in this manual.

Preparing your system for upgrade __________________________
To maintain the integrity of your existing TeleVantage system and ensure a successful upgrade, 
you must perform the tasks described in detail in this section. 

Important: It is critical for a successful upgrade that you perform these tasks exactly as 
described in the remainder of this section.

The following steps are necessary to prepare your system for upgrade:

Q Back up your TeleVantage database and voice files to a safe location off the 
TeleVantage Server PC. 

Q Archive your Call Center Reporter database if you are upgrading from TeleVantage 3.x. 

Q Shut down the TeleVantage Server and exit all TeleVantage workstation applications, 
including the Device Monitor. 

Q Stop the Dialogic drivers, and then uninstall them. 

Backing up the TeleVantage database and voice files
By backing up your system, you will be able to reconstruct your current system if the installation 
process fails. Backing up an existing TeleVantage system may take an hour or more, especially 
if there are many voice messages stored in your database.

Note: You can only restore the TeleVantage database and voice files to a Server that is running 
the exact same version of TeleVantage (including service packs and hot fixes) as the Server on 
which you performed the backup. For example, you cannot backup a TeleVantage 4.x Server and 
restore it to a TeleVantage 5.x Server. This restriction applies to minor releases as well, for 
example, 5.0 and 5.1.
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To backup the TeleVantage database and voice files, perform an offline backup according to the 
instructions in Administering TeleVantage. Be sure to refer to the copy of Administering 
TeleVantage that matches the TeleVantage version of the system that you are backing up, 
because the process is different for each version of TeleVantage.

If for any reason you are unable to start the TeleVantage Administrator, you can back up your 
files by running the Administrator from the command line. See “Cannot start Administrator to 
back up the TeleVantage database” on page D-17.

Archiving TeleVantage 3.x Call Center Reporter data
Note: Perform this step only if you are upgrading from TeleVantage 3.x.

The TeleVantage 5 Call Center Reporter can generate reports for both ACD workgroups and call 
center queues, but it only reports on data collected after you upgrade to TeleVantage 5. 
Therefore, if you want to report on Call Center Reporter data collected before the upgrade, you 
must archive that data and report on it separately using the TeleVantage 3.x Call Center 
Reporter.

Important: Failure to back up your existing Call Center Reporter data can prevent you from 
printing reports based on pre-upgrade data.

To archive existing TeleVantage Call Center Reporter data

1. Roll up the Call Center Reporter data. For more information, see Administering 
TeleVantage for TeleVantage 3.5.

2. If you have not previously done so, install the Call Center Reporter for TeleVantage 
3.x on the same PC that has the Statistics Database. 

3. Maintain the archive for as long as you want to report on data collected prior to the 
upgrade to TeleVantage 5.

Important: After the upgrade to TeleVantage 5, you cannot run a report that uses data from 
before and from after the upgrade. You must run separate reports on your archived data and your 
new data.

Shutting down TeleVantage components
1. If you have not already done so, stop the TeleVantage Server by choosing Tools > 

Shut down Server in the Administrator.

2. Exit all TeleVantage workstation applications (Client, Administrator, TAPI Service 
Provider, and Contact Manager Assistant) running on any PCs in the network. 

3. Exit the Device Monitor by right-clicking its icon in the system tray and choosing Exit 
Device Monitor. Make sure that you exit the Device Monitor and that you do not just 
minimize it.
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4. Remove the Device Monitor from the Startup Group. To do so, right-click the Start 
button and then choose Explore All Users. Browse to the following location and then 
delete the shortcut:

Start Menu\Programs\Startup\TeleVantage Device Monitor

Delete any other TeleVantage component shortcuts from the Startup Group if they are 
present.

5. Turn off auto-start for the TeleVantage Server. To do so:

Q Do one of the following:

Q In Windows NT, click Start > Settings > Control Panel > Services. 

Q In Windows 2000, click Start > Settings > Control Panel > Administrative 
Tools > Services. 

Q In the Services dialog box, locate and double-click TeleVantage server. 

Q In the TeleVantage server Properties dialog box, select Manual from the Startup 
type drop-down list. 

Q Click OK, and then exit the Services dialog box.

Uninstalling the Dialogic drivers
If you are upgrading from a previous version of TeleVantage, you must uninstall the old 
Dialogic drivers. 

Important: If you have modified any Dialogic firmware files, for example you edited 
spandti.prm in order to support extended superframe T1 service, save the files before you 
uninstall the old Dialogic drivers. Once the new drivers are installed, make a backup copy of the 
new files for future use, and restore your modified versions.

To uninstall the Dialogic drivers

1. Verify that the Dialogic drivers are stopped. To do so:

Q If the Dialogic Configuration Manager (DCM) is not already running, start it. See 
Appendix H, “Using the Intel Dialogic Configuration Manager”  for instructions.

Q If you are upgrading from TeleVantage 3.0 or higher:

Q Click Dialogic Configuration Manager - DCM. Click OK at the DCM 
warning message.

Q In DCM, choose Service > Stop Service. Click OK when the service has 
stopped, and then exit DCM.

Q If you are upgrading from TeleVantage 2.1:

Q Click Set Dialogic Service Start Up Mode.

Q Click Manual, and then click Stop Now. Click OK when service has 
stopped.

Q Exit DCM.
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2. Click Start > Programs > Dialogic System Software > Uninstall. Click Yes or OK at 
the confirmation messages. 

3. If the Remove Shared File dialog box opens, click Yes to All, and then click Yes to 
confirm your choice.

4. Click OK when all files have been removed. When you are prompted to restart your 
PC, do so.

5. Log on again to Windows NT or 2000 using the same administrator account that you 
used when you backed up the TeleVantage database and voice files. 

Important: If the Found New Hardware wizard starts, click Cancel to close the wizard. 
You will take steps to eliminate this behavior in Chapter 9.

6. Search for the following directories, and if you find one or both of them, delete them.

C:\DLGCDEV

C:\Program Files\Dialogic

7. Check to see if the old Dialogic program group was removed by the uninstall. To do 
so, right-click the Start button on your Windows desktop and click Explore. Browse 
to the following location and delete the shortcut if necessary:

Start Menu\Programs\Startup

8. If you are upgrading from TeleVantage 2.1 or earlier, remove the Streams 
environment. Doing this will improve performance. 

To remove the Streams environment, click Start > Settings > Control Panel, and then 
double-click Network. Click the Protocols tab, select Streams Environment, and then 
click Remove. Restart your PC when prompted to do so.

Upgrade checklist
If you are upgrading TeleVantage from any previous version, you must perform the steps listed 
in the following table in the order specified. This list is only an overview of the steps you must 
perform—later chapters in this manual present detailed instructions for each step.

Step Description

1
If you plan to upgrade your Dialogic hardware, do so before you 
upgrade the Dialogic drivers.

2
Install and configure the database server. This step is not 
required when upgrading from TeleVantage 3.5 or higher. 

3
Upgrade the TeleVantage Server and TeleVantage 
Administrator.
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Starting the upgrade 
To begin the upgrade to TeleVantage 5, do one of the following:

Q If you are upgrading and installing new Dialogic hardware on the TeleVantage Server, 
go to Chapter 8, “Installing Intel Dialogic Hardware.” 

Q If you are leaving your TeleVantage hardware intact, go to Chapter 9, “Installing and 
Configuring the Intel Dialogic Drivers.” 

Installing a TeleVantage system for the first time _______________
Read this section carefully if you are installing a new TeleVantage system. 

Installation checklist 
If you are installing TeleVantage for the first time, you must perform the steps listed in the 
following table in the order specified. This list is only an overview of the steps you must 
perform. The remaining chapters in this manual present detailed instructions for each step.

4

Add and activate your TeleVantage 5 licenses. You must have a 
valid Server license to start the TeleVantage Server. Trunk, 
Station, IP Port, Client, Call Center Agent, and Reporter 
licenses are optional, and are only required if you want to use 
these components.

5 Upgrade the TeleVantage workstation applications.

6
Upgrade the TeleVantage Web Services to support the 
TeleVantage Web Client.

Step Description

Step Description

1

Verify that the PCs you plan to use for the TeleVantage Server 
and to run the TeleVantage workstation applications and 
TeleVantage Web Services meet the requirements described in 
Chapter 3.

2
Verify your Microsoft network type and the IP address of the 
TeleVantage Server PC, as detailed in the next section. You will 
need this information during the installation.

3
Install and configure Windows NT or Windows 2000 on the 
TeleVantage Server PC.

4 Install Dialogic hardware.

5 Install and configure Dialogic drivers.
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What you must know before installing 
For a smooth first-time installation, gather the following information before you begin:

Q Network environment type. Is your Microsoft network a domain or workgroup 
environment? 

Q If you are in a domain environment, you must know the name of the domain and the 
name and password of a domain user with administrator privileges on the PC on 
which the TeleVantage Server will be installed. See “Network requirements” on 
page 3-17 for more information.

Q If you are in a workgroup environment, you do not need to know this information.

Q The IP address of the TeleVantage Server PC. Do you use static or dynamic IP 
addressing?

Q If you use static IP addressing, you must know the IP address of the Server PC, your 
Subnet Mask, and the IP address of your default gateway to properly configure the 
TeleVantage Server on a network.

Q If you use dynamic IP addressing, you do not need to know this information.

Starting the first-time installation
To begin installing TeleVantage for the first time, go to Chapter 7, “Installing and Configuring 
Windows on the TeleVantage Server.” 

Read the Introduction in Chapter 7 and follow the steps as directed. The Introduction also 
addresses site-specific installation considerations, such as the versions of operating system or 
other system components already present on your PC. 

6 Install and configure the database server. 

7
Install the TeleVantage Server and TeleVantage Administrator 
on the TeleVantage Server.

8

Add and activate your TeleVantage 5 licenses. You must have a 
valid Server license to start the TeleVantage Server. Trunk, 
Station, IP Port, Client, Call Center Agent, and Reporter 
licenses are optional, and are only required if you want to use 
these components.

9 Install the TeleVantage workstation applications.

10 Install the TeleVantage Web Services to support the 
TeleVantage Web Client.

Step Description
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Introduction _____________________________________________
Before you install TeleVantage components, you or your system administrator must install and 
configure one of the Windows operating systems listed on page 3-2 on the TeleVantage Server 
PC. 

If you are upgrading from a previous version of TeleVantage, go to Chapter 8. Otherwise, 
continue reading this chapter.

Perform these steps
You will perform the following steps as you install the TeleVantage Server:

Q Install and configure Windows 2000 or Windows NT 4.0.

Q Configure Windows 2000 or Windows NT 4.0 for TeleVantage.

Q Create the Windows 2000 or Windows NT 4.0 user for TeleVantage.

Note: Even if Windows 2000 or Windows NT 4.0 is already installed on your PC, you 
must perform these two steps to ensure that your system is set up correctly for use by 
TeleVantage.

Q Windows NT 4.0: Install Windows NT 4.0 SP6a, if necessary.

To install and configure Windows 2000, go to page 7-3.

To install and configure Windows NT 4.0, go to page 7-6.
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Installing and configuring Windows 2000_____________________
Install Windows 2000 on a clean PC according to the instructions that came with the software. 

When you are done, you are ready to perform the following tasks:

Q Configure Windows 2000

Q Create a Windows 2000 user

Go to the next section.

Configuring Windows 2000 for TeleVantage
Use the information in the following table to configure Windows 2000 for use with 
TeleVantage.

Go to the next section. 

Creating the Windows 2000 user for TeleVantage
After installing and configuring Windows 2000, you must create the Windows 2000 user that 
will install and run TeleVantage. Depending on your environment, do one of the following:

Q If you are not in a domain environment, go to the next section.

Q If you are in a domain environment, go to “If you are in a Windows 2000 domain 
environment using Microsoft Exchange” on page 7-5.

Dialog Box Name TeleVantage Requirement

Licensing Modes If each TeleVantage user’s PC already has a Windows 2000 
per-seat license to connect to other Windows 2000 Servers, 
you do not need any more licenses.

If TeleVantage users’ PCs use concurrent licenses, you must 
estimate the number of users who will play voice messages 
and custom recordings over their computer speakers 
concurrently to determine how many concurrent licenses you 
need. Playing voice files over the telephone does not use the 
network, so you do not need to allocate licenses for this 
purpose.

Computer Name 
and Administrator 
Password

Enter the network name for the TeleVantage Server PC. Use 
the name “TeleVantage” to make the Server easily identifiable.
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If you are not in a Windows 2000 domain environment using Microsoft 
Exchange
If you are not in a domain environment, you can create a new user with administrator privileges 
on the local system, or you can log on yourself as the TeleVantage system administrator. 

To create a new user with administrator privileges

1. Log on to the TeleVantage Server PC as the local administrator user. 

2. Click Start > Programs > Administrative Tools > Computer Management. 

3. Select System Tools > Local Users and Groups > Users. 

4. Click Action > New User. 

5. Enter properties for the new user and make a note of the user name you enter. 

6. Click Create to create the new user. Close the dialog box but do not exit Computer 
Management. 

7. Select System Tools > Local Users and Groups > Groups. 

8. Select the Administrators group. 

9. Click Add. 

10. Make sure the local computer is selected in the Look in drop-down list. 

11. Select the new user and click Add. 

12. Click OK to close the Select Users or Groups dialog box. 

13. Click OK to close the Administrator Properties dialog box. 

14. Exit Computer Management.

To add required rights for the new user

1. Click Start > Programs > Administrative Tools > Local Security Policy. 

2. Select Security Settings > Local Policies > User Rights Assignment. 

3. Select Log on as a batch job. 

4. Click Action > Security and click Add. 

5. Make sure the local computer is selected in the Look in drop-down list. 

6. Select the new user and click Add. 

7. Click OK to close the Select Users or Groups dialog box. 

8. Click OK to close the Local Security Policy Setting dialog box. 

9. Exit Local Security Settings.

When you are done, go to Chapter 8, “Installing Intel Dialogic Hardware.” 
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If you are in a Windows 2000 domain environment using Microsoft 
Exchange
If you are in a domain environment in which you will use Microsoft Exchange with TeleVantage 
for e-mail notification or synchronization, you must create a domain user so that TeleVantage 
can communicate with Exchange. The domain user must be a member of the Domain Users 
Group, which is the default group for a new domain user.

To create a domain user that is a member of the Domain Users Group

1. Log on to your Windows 2000 primary domain controller (PDC) PC as a domain 
administrator user. 

2. Click Start > Programs > Administrative Tools > Active Directory Users and 
Computers. 

3. In the console tree, double-click the domain node.

4. In the details pane, right-click the organizational unit to which you want to add the 
user, point to New, and then click User.

5. Enter properties for the new user and make a note of the user name you enter. For 
information about individual properties, see your Windows 2000 documentation.

6. Click Add to add the new user. 

7. Log off. 

To add the new user to the local Administrator group

1. Log on to your TeleVantage Server PC as a member of the Domain Administrators 
group. 

2. Click Start > Programs > Administrative Tools > Computer Management. 

3. Select System Tools > Local Users and Groups > Groups. 

4. Select the Administrators group. 

5. Click Action > Add to Group and click Add. 

6. Make sure the local computer is selected in the Look in drop-down list. 

7. Select the new user and click Add. 

8. Click OK to close the Select Users or Groups dialog box. 

9. Click OK to close the Administrator Properties dialog box. 

10. Exit Computer Management.
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To add required rights for the new user

1. Click Start > Programs > Administrative Tools > Local Security Policy. 

2. Select Security Settings > Local Policies > User Rights Assignment. 

3. Select Log on as a batch job. 

4. Click Action > Security and click Add. 

5. Make sure the local computer is selected in the Look in drop-down list. 

6. Select the new user and click Add. 

7. Click OK to close the Select Users or Groups dialog box. 

8. Click OK to close the Local Security Policy Setting dialog box. 

9. Exit Local Security Settings.

When you are done, go to Chapter 8, “Installing Intel Dialogic Hardware.” 

Installing and configuring Windows NT 4.0____________________
Install Windows NT 4.0 on a clean PC according to the instructions that came with the software. 

When the PC restarts at the end of the disk-based portion of the installation, you are ready to 
perform the following tasks:

Q Configure the Windows NT 4.0. 

Q Create a Server user.

Q Install Windows NT 4.0 SP6a, if necessary.

Go to the next section. 
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Configuring Windows NT 4.0 for TeleVantage 
Use the information in the following table to configure Windows NT 4.0 for use with 
TeleVantage.

Dialog Box Name TeleVantage Requirement

Licensing Modes If each TeleVantage user’s PC already has a Windows NT 
per-seat license to connect to other Windows NT Servers, you 
do not need additional Windows NT Server licenses.

If TeleVantage users’ PCs use concurrent licenses, you must 
estimate the number of users who will play voice messages 
and custom recordings over their computer speakers 
concurrently to determine how many concurrent licenses you 
need. Playing voice files over the telephone does not use the 
network, so you do not need to allocate licenses for this 
purpose.

Computer Name Enter the network name for the TeleVantage Server. Use the 
name “TeleVantage” to make the Server easily identifiable.

Select 
Components

If you want to enable TeleVantage e-mail notification of voice 
mail messages, install the Windows Messaging component. 
TeleVantage does not require any of the other components 
listed in this dialog box. You can deselect unnecessary items 
to save disk space. See “Configuring e-mail notification 
support” on page 11-15.

Server Setup - IIS 
Installation

Deselect the Microsoft Internet Information Server (IIS) 
checkbox.TeleVantage Web Services requires Microsoft 
Internet Information Server (IIS), but you must install IIS from 
the Windows NT Option Pack. See “Web Services 
requirements” on page 3-23 for more information.

Server Setup - 
Protocol

Specify the network protocols used by Windows NT. For the 
TeleVantage Server:

Q Verify that TCP/IP Protocol is selected.

Q Deselect the IPX/SPX checkbox unless your network 
needs it.

Q Select any additional protocols required by your 
network.
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Go to the next section. 

Creating the Windows NT 4.0 user for TeleVantage
After installing and configuring the Windows NT 4.0, you must create the Windows NT 4.0 user 
that will install and run TeleVantage. Depending on your environment, do one of the following:

Q If you are not in a domain environment, go to the next section.

Q If you are in a domain environment, go to “If you are in a Windows NT domain 
environment using Microsoft Exchange” on page 7-9.

If you are not in a Windows NT domain environment using Microsoft 
Exchange
If you are not in a domain environment, you can create a new user with administrator privileges 
on the local system, or you can log on yourself as the TeleVantage system administrator. 

To create a new user with administrator privileges

1. Log on to your TeleVantage Server PC as an administrator user. 

2. Click Start > Programs > Administrative Tools > User Manager for Domains. 

3. Click User > New User. 

4. Enter properties for the new user and make a note of the user name you enter. 

5. Click the Groups button and verify that the user is a member of the Administrators 
Group. If the user is not a member, select Administrators Group in the Not member 
of list and click Add. 

6. Click OK to close the dialog box. 

7. Click Add to add the new user. Do not exit User Manager for Domains. 

TCP/IP Setup 
Prompt

When prompted to use Dynamic Host Configuration Protocol 
(DHCP), you can choose either Yes or No. TeleVantage can 
run with or without DHCP with most types of Dialogic boards. 
If any of the Dialogic Internet telephony boards are installed 
on the Server, you can choose Yes or No for DHCP depending 
on how your network is configured. Each of these boards has 
its own network card. The IP address assigned to them must 
be static.

TCP/IP Properties 
- WINS Address 
tab

The WINS Address is not a TeleVantage issue unless your site 
is using routed NetBEUI with a tunneling protocol. In normal 
networks, the NetBEUI-to-TCP/IP name resolution is 
accomplished through the broadcast protocols built into 
Microsoft TCP/IP.

Dialog Box Name TeleVantage Requirement
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To add required rights for the new user

1. Click Policies > User Rights. 

2. Select the Show Advanced User Rights checkbox. 

3. Select Log on as a batch job from the Right drop-down list. 

4. Click Add > Show Users. 

5. Select the new user and click Add. 

6. Click OK to close the Add Users and Groups dialog box. 

7. Click OK to close the User Rights Policy dialog box. 

8. Exit User Manager for Domains. 

9. Log off and log on again as the new user.

When you are done, go to “Installing Windows NT 4.0 SP6a” on page 7-10.

If you are in a Windows NT domain environment using Microsoft 
Exchange
If you are in a domain environment in which you will use Microsoft Exchange with TeleVantage 
for e-mail notification or synchronization, you must create a domain user so that TeleVantage 
can communicate with Exchange. The domain user must be a member of the Domain Users 
Group, which is the default group for a new domain user. 

To create a domain user that is a member of the Domain Users Group

1. Log on to your Windows NT primary domain controller (PDC) PC as a domain 
administrator user. 

2. Click Start > Programs > Administrative Tools > User Manager for Domains. 

3. Click User > New User. 

4. Enter properties for the new user and make a note of the user name you enter. For 
information about individual properties, see your Windows NT documentation.

5. Click Groups and verify that the user is a member of the Domain Users Group. If the 
user is not a member, select Domain Users Group in the Not member of list and click 
Add. 

6. Click OK to close the Group Memberships dialog box. 

7. Click Add to add the new user. 

8. Log off.
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To add the new user to the local Administrator group

1. Log on to the TeleVantage Server PC as a member of the Domain Administrators 
group. 

2. Click Start > Programs > Administrative Tools > User Manager for Domains. 

3. Double-click the Administrators group under Groups at the bottom of the dialog box. 

4. Click Add and make sure your domain is selected in the List Names From drop-down 
list. 

5. Select the new user. 

6. Click Add and then OK to close the Add Users and Groups dialog box. 

7. Click OK to close the Local Group Properties dialog box. Do not exit User Manager 
for Domains. 

To add required rights for the new user

1. Click Policies > User Rights. 

2. Select the Show Advanced User Rights checkbox. 

3. Select Log on as a batch job from the Right drop-down list. 

4. Click Add > Show Users. 

5. Select the new user and click Add. 

6. Click OK to close the Add Users and Groups dialog box. 

7. Click OK to close the User Rights Policy dialog box. 

8. Exit User Manager for Domains. 

9. Log off and log on as the new user.

When you are done, go to the next section.

Installing Windows NT 4.0 SP6a
To determine if you must install Windows NT 4.0 SP6a, do either of the following:

Q Try to install the TeleVantage Server from \server\netsetup\ntsp\ntsp.exe on the 
TeleVantage Master CD. The TeleVantage Master Setup program automatically checks 
your PC to see if SP6 or later is installed. 

Q Manually check the version of your existing Service Pack by clicking Start > Programs 
> Administrative Tools (Common) > Windows NT Diagnostics and looking on the 
Version tab.
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If SP6 or later is installed on your PC, go to Chapter 8 now. Otherwise, the TeleVantage Server 
Installer prompts you to install SP6a. If you are prompted to replace existing drivers on your PC 
with Windows drivers, use your best judgement—TeleVantage does not require that you replace 
any of your existing drivers. 

If you install SP6a on your PC, click Restart to restart the PC, and then go to Chapter 8.

Where to go next_______________________________________
When you have installed and configured Windows NT 4.0 or Windows 2000, go to Chapter 8.
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Introduction _____________________________________________
TeleVantage runs on Intel Dialogic telephony boards that connect your trunk lines and phones 
to the TeleVantage Server. The Dialogic boards must be installed in the TeleVantage Server PC. 
This chapter provides instructions for installing Dialogic telephony boards and their associated 
hardware.

If you experience problems with the Dialogic hardware after following the instructions in this 
chapter, see “Troubleshooting Intel Dialogic problems” on page D-3.

Perform these steps
Use the following checklist as you install Dialogic hardware.

Q Set the Dialogic board IDs. Each Dialogic board in your system must have a unique 
board ID, which you set using a physical switch on the boards. Because the board IDs 
are physical switches on the boards, it is easiest to set the IDs for all boards before 
installing them in the PC.

Q Install the Dialogic boards in the TeleVantage Server PC. This step includes the 
following:

Q Inserting each board into the PC

Q Installing a Network Interface Card (NIC), if you are using an Internet telephony 
board

Q Connecting all ISA boards with the SCbus ribbon cable, and all PCI boards with the 
CTbus ribbon cable

Q Attaching the SCbus-to-CTbus adapter, if you are using a both ISA and PCI boards

Q Connect Dialogic trunk boards to trunk lines. Depending on the type of trunk boards 
you are using, this step may include installing additional required hardware. See 
Chapter 4 for more information.

Q Connect analog station boards. 

Q Connect the power supply. Only on systems with analog trunk boards.

Q Set up Watchdog mode. Only on systems with analog trunk boards.
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The following diagram depicts how the hardware components in a basic TeleVantage 
configuration are connected. Not all of the hardware components discussed in this chapter are 
depicted.

Static warning
Important: Read and follow the recommendations in this section.

Handle all PC boards and components at a static-safeguarded work area, as described in this 
chapter. The work area must have a static-dissipative wrist strap connected to a grounded, 
static-dissipative mat or table surface upon which you place the PC and static-sensitive 
components. 

The following additional safeguards will help prevent static damage during installation:

Q Keep the boards in their plastic anti-static shipping containers until you are ready to 
install them.

Q Arrange the PC, all tools, documentation, and hardware so that you can reach them 
without moving your feet. Doing this reduces the risk of picking up static charges from 
the floor.

Q Attach a static-dissipative wrist strap to an electrical ground or to the PC chassis and to 
your wrist before removing the Dialogic boards from their anti-static shipping 
containers.

Q Always handle the boards by their edges or by the metal brackets.

Q Always place the Dialogic boards inside the anti-static shipping containers when the 
boards are not being handled.
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Setting Dialogic board IDs _________________________________
Board IDs allow the system to uniquely identify the devices on each Dialogic board. For 
example, if you have two D/80SC-4LS boards in your system, the board IDs provide a way for 
the system to distinguish between the trunk lines on each board. 

It is recommended that you assign board IDs in the following order, from lowest to highest:

Q Analog trunk boards

Q T1, E1, and BRI trunk boards

Q Internet telephony boards

Q Station boards

Dedicated voice resource boards and conference bridge board can be assigned in any order

Important: If you have T1, E1, or BRI trunks boards installed on the same system with analog 
trunk boards, the analog trunks boards must be assigned lower board IDS than the digital trunks.

You do not need to start with board ID 0, as long as each board has a unique ID and IDs are 
assigned in the correct order. 

To assign board IDs

1. Locate the switch or switches on the side of each board. 

2. Set the board ID:

Q Dialogic trunk boards, IP telephony boards, dedicated voice resource boards, 
and conference bridge boards. Set the board ID by dialing the single SW100 
rotary switch to one of the 16 available settings (0-F).

Q Station boards. Set the board ID to one of the 32 available settings (0-31) using the 
two switches on the board:

Q To set board IDs 0-15, set the SW2 switch to OFF and dial the SW1 rotary 
switch to one of the sixteen settings from 0-F. 
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Q To set board IDs 16-31, set SW2 to ON and dial the SW1 rotary switch to one 
of the sixteen settings from 0-F.

The ON and OFF positions of the SW2 switch are indicated by silk-screened letters on 
the board.

When you have set your board IDs, go to the next section.

Installing Dialogic boards__________________________________
1. Shut down the TeleVantage Server PC, switch off the power, and unplug the power 

cords before opening the PC cover, to avoid the risk of electric shock.

2. Insert the board’s edge connector into the bus slot. The boards fit tightly. Insert the 
front portion of the board first. The notch on the other end allows the board to be tipped 
forward, making insertion easier.

3. Apply pressure only to the top edge of the board, and gently rock the board forward 
and backward to seat the edge connector into the slot.

4. If you are using Internet telephony boards: Install a third-party Network Interface 
Card (NIC) in the TeleVantage Server PC, and connect it to your network, if you have 
not already done so. Refer to the documentation that came with your NIC for 
instructions.

Note: Even if your DM/IPx board contains a built-in NIC, you must install a third-party 
NIC and connect to your network.

5. Connect ISA or PCI boards with the appropriate ribbon cable. Be sure to adhere to the 
following guidelines when connecting boards with ribbon cables:

Q If you have more connectors than boards, be sure to use both end connectors, 
leaving the unused connectors in the middle of the ribbon cable. This is especially 
important with the CTbus ribbon cable, since it runs at a higher frequency and is 
more prone to termination or antenna effects.

Q Make sure that there is no more than 7 inches of unconnected cable (5 unused 
connectors on a standard Intel Dialogic H.100 cable) between any two adjacent 
boards. If necessary, rearrange the boards in your system or use a cable with fewer 
connectors. 
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Q Tuck the cable down so that unused connectors do not get in the way when you 
replace the PC cover.

Q If you have ISA boards: Attach the end connector of the SCbus ribbon cable to the 
SCbus connector on the top edge of the first board. Match up the notches on the 
connectors for proper insertion—there is only one way that the connector fits.

Attach the ribbon cable to the SCbus connector on the next board until all ISA 
boards are connected by the cable. 

Q If you have PCI boards: Connect them in the same way using the CTbus ribbon 
cable.

Q If you have both ISA and PCI boards: Use the SCbus-to-CTbus adapter to connect 
all the boards together so that they can use the same telephony bus. Only one 
SCbus-to-CTbus is required per PC. See “Troubleshooting mixed CTbus board 
systems” on page D-9 for more information about mixed-board configurations.

Q Place the adapter on the 68-pin CTbus edge connector on the PCI board that is 
adjacent to the first ISA board. The adapter hangs off the end of the board.

Q Connect the SCbus ribbon cable to the SCbus side of the adapter.

Q Connect the CTbus ribbon cable to the CTbus side of the adapter.

When properly connected, the two ribbon cables will lie flat, and the colored stripe 
on one edge of both ribbon cables will face toward the bracket end of the boards.

6. After installing and connecting all the boards, replace the PC cover and power cords.

When you have installed all of your Dialogic boards, go to the next section.
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Connecting Dialogic trunk boards to trunk lines _______________
Connect the Dialogic trunk boards to trunk lines according to the type of phone service you use. 

Connecting regular analog trunk boards
1. Using the 37-pin LSI cable, attach the connector on the rear of the analog trunk board 

to the BCP connection panel port labeled A) LS 1-8. Only the correct cable will fit. If 
you are installing two D/80SC-4LS boards, connect the second board to the port 
labeled B) LS 4-8.

2. Using phone cable, connect the analog loop-start trunk lines from the telephone 
company to the RJ-11 jacks labeled Outside Lines (Trunks) on the BCP connection 
panel. Use jacks T1-T4 for 4 lines and jacks T1-T8 for 8 lines.

The first trunk line in your incoming hunt group must be attached to T1, the second to 
T2, and so on in order to minimize conflicts between incoming and outgoing calls. 

Note: If you install a D/41ESC board, you must enable software tone generation in the 
Administrator. See Administering TeleVantage for instructions.

Connecting analog DID trunk boards
See “Additional required hardware for analog service” on page 4-4.

1. Using the 37-pin LSI cable, attach the connector on the rear of the analog trunk board 
to the BCP connection panel port labeled A) LS 1-8. Only the correct cable will fit. If 
you are installing two D/80SC-4LS boards, connect the second board to the port 
labeled B) LS 4-8.

2. Connect the DID interface unit to the RJ-11 jacks labeled Outside Lines (Trunks) on 
the BCP connection panel. Use jacks T1-T4 for 4-line systems and jacks T1-T8 for 
8-line systems.

3. Using phone cable, connect the analog DID trunks from the telephone company to the 
DID interface unit.

4. Connect the DID Interface Unit as follows:

Q Plug a DID trunk from your phone company into the leftmost socket of the 
three-hole connector.

Q Plug the TeleVantage trunk from the BCP connection panel into the middle socket 
of the three-hole connector.

Q If you will be using this trunk for both inbound and outbound calls, and you have a 
DID Interface Unit that supports it, plug a regular analog trunk—not a DID 
trunk—into the rightmost socket of the three-hole connector. See the next section 
for details.

Q Plug the DID Interface Unit into a power outlet using its power connector. 
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Refer to the documentation that came with your DID Interface Unit for more 
information.

Normally, analog DID trunks handle inbound calls only. However, certain DID interface units 
allow you to circumvent this limitation and make outbound calls. These DID interface units 
connect one TeleVantage trunk to both a DID trunk and a non-DID trunk. Outbound calls are 
routed on the non-DID trunk. In this way, you can configure the TeleVantage trunk for both 
inbound and outbound calls.

Note that with this configuration, a call on either trunk—the DID trunk or the regular analog 
trunk—results in the TeleVantage trunk being busy. Adding outbound capability increases 
traffic on the line. It also increases the chance that incoming DID calls will be blocked. If you 
think you will be receiving many DID calls, you might want to leave your DID trunks as 
inbound-only.

Connecting Robbed Bit T1 trunk boards
See “Additional required hardware for T1 service” on page 4-5.

1. Connect the trunk lines from the telephone company to the Channel Switching Unit 
(CSU). 

2. Using phone cable, connect the CSU directly to the Dialogic T1 trunk board. 
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Connecting ISDN PRI T1 trunk boards
See “Additional required hardware for T1 service” on page 4-5.

1. Connect the trunk lines from the telephone company to the Network Termination Unit 
(NTU). 

2. Using phone cable, connect the NTU directly to the Dialogic ISDN PRI T1 trunk 
board. 

Connecting ISDN PRI E1 trunk boards
See “Additional required hardware for E1 service” on page 4-7.

1. Connect the trunk lines from the telephone company to the Network Termination Unit 
(NTU). 

2. Using phone cable, connect the NTU directly to the Dialogic ISDN PRI E1 trunk 
board. 

Connecting E1 CAS trunk boards
Connect the E1 CAS trunk lines from the telephone company directly into the Dialogic E1 trunk 
board. 

Connecting ISDN BRI trunk boards
See “Additional required hardware for ISDN BRI service” on page 4-8.

The connection procedure for an ISDN BRI trunk board depends on which board you are using. 

To connect BRI/xSC or BRI/x-PCI boards

1. Connect the ISDN BRI trunk lines from the telephone company to the Network 
terminal type 1 adapter (NT1). 

2. Connect the NT1 to the Dialogic shielded breakout box using the custom shielded 
RJ-45 cable specified on page 4-8.
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3. Connect the Dialogic shielded breakout box to the Dialogic BRI board using a 
Dialogic SCSI-3 BRI breakout box cable.

To connect BRI/2VFD boards

Connect the trunk lines from the telephone company directly to the Dialogic board using a 
custom RJ-48 cable, specified in the documentation that comes with the board.

Connecting Internet telephony boards
Do not plug phone lines directly into your DM/IPx Internet telephony board. TeleVantage 
supports Internet connections over a network interface only. Connect the built-in Network 
Interface Card (NIC) on your DM/IPx board to your office network using a standard network 
cable.

When you have connected all of your trunk boards, go to the next section.

Connecting analog station boards
This section describes how to connect MSI/x, DI/SIx, and HDSI/x station boards.

Connecting MSI/x boards
1. If the MS/x board is an ISA board: Use the 50-pin RJ-21X cable to connect the board 

to the port on the BCP connection panel port labeled MSI Board.

If the MS/x board is a PCI board: Attach the 50-pin RJ-21X cable to the port on the 
BCP connection panel port labeled MSI Board. Use the 37-pin D-shell adapter cable 
to connect the board to the RJ-21X cable.

Note: To avoid damaging the MSI/x board, do not plug trunk lines from the telephone 
company into Station Line jacks S1-S24 on the BCP connection panel.
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2. Connect your phones:

Q If you are setting up an analog system: Using phone cables, connect your phones 
to the RJ-11 jacks labeled Station Lines on the BCP connection panel. Use jacks 
S1-S8 for 8-station boards, S1-S16 for 16-station boards, or S1-S24 for 24-station 
boards.

Assign your Operator to station S1 and other people who can handle a large volume 
of calls to stations S2-S4. In Watchdog mode, your first 4 analog trunks (T1-T4) 
will be routed directly to stations S1-S4 in the event of a power failure.

Q If you are setting up a T1, E1, or Internet telephony system: Using phone cables, 
connect your phones directly to the MSI/x board.

Connecting HDSI/x boards
HDSI/x boards include an external station interface box (SIB) which provides the analog 
interface for station activity. 

The SIB sits between the HDSI/x board and the Dialogic Business Communications Platform 
(BCP) connection panel or breakout box. All connections are on the back of the SIB:

1. Connect the board to the SIB using the 4 RJ-45 cables. Connect the top port of the 
installed board to the left-most port on the back of the SIB, and so forth.

Note: Cables must be connected in the correct order. if not, TeleVantage stations will 
be numbered incorrectly. Also, stations may not be detected when you start the 
TeleVantage Server. See “TeleVantage Server fails to detect some or all stations on 
HDSI/x board” on page D-4.

2. Connect the SIB to the BCP via the 5 RJ-21X ports on the back of the SIB.
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3. Connect the SIB to a power outlet using the 3-prong power connector on the back of 
the SIB.

4. Using phone cables, connect your phones to the BCP or breakout box.

Connecting DI/SIx boards
DI/SIx boards are connected to stations via an external Intel Dialogic DI/SIx station breakout 
box, not via a BCP connection panel.

1. Connect the board to the station breakout box using a 68-pin SCSI-3 cable.

2. Using phone cables, connect your phones to the breakout box.

Connecting the station board power supply ___________________
Perform this step only if you are using MSI/x or DI/SIx station boards. 

These boards require a Dialogic MSI-GBL Power Module, which supplies ring voltage and loop 
current to the stations, as well as full availability of all trunks and stations on the BCP 
connection panel. Also, if you run TeleVantage in Watchdog mode, the power module ensures 
that trunks T1-T4 and stations S1-S4 are available in the event of a power failure. See 
“Watchdog mode” on page 2-3 for more information.

To connect the Dialogic MSI-GBL Power Module

1. Connect the joined end of a y-cable to the power module.

2. Attach one branch to the DC power plug on the rear of the MSI/x or DI/SIx board.

3. Attach the other branch to the plug labeled Power Supply on the BCP connection 
panel.

Note: For the BCP connection panel to get power, both the BCP connection panel and 
the PC to which the MSI/x or DI/SIx board is attached must be powered on.

An older configuration requires that you use the MSI board power cable to connect the DC 
power plug to the matching power plug labeled MSI Board Power on the BCP connection panel. 
A separate cord connects the DC power plug on the power supply to the matching power plug 
labeled Power Supply on the BCP connection panel.
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Setting up Watchdog mode ________________________________
Watchdog mode provides continued, limited telephone function in the event of a power failure 
or system crash. See “Watchdog mode” on page 2-3 for more information. Watchdog mode 
requires analog phone service and the BCP connection panel.

To configure the BCP connection panel for Watchdog mode

1. Use the slide switch on the top of the BCP connection panel to set the Mode of 
Operation to Watchdog mode.

2. Connect a serial cable from the COM port on the PC to the RS-232 Watchdog Signal 
port on the BCP connection panel.

The cable transmits a periodic “watchdog” signal from TeleVantage to the BCP 
connection panel that lets the system determine if there has been a power failure or a 
system crash. 

3. Set at least one of the Watchdog Signal Type switches on the BCP connection panel 
to the On position. More than one of the switches can be on.

Where to go next_______________________________________
When you have successfully installed Dialogic hardware as described in this chapter, go to 
Chapter 9.
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Introduction _____________________________________________
TeleVantage runs on Intel Dialogic telephony boards that connect your trunk lines and phones 
to the TeleVantage Server. Before installing and configuring the Intel Dialogic drivers as 
described in this chapter, install the Dialogic boards in the TeleVantage Server PC. See 
Chapter 8 for instructions.

Perform these steps
Use the following checklist as you install and configure the Intel Dialogic drivers on the 
TeleVantage Server PC.

Q Install Intel Dialogic SR 5.1.1 Drivers.

Q Install Intel Dialogic SR 5.1.1 SP1.

Q Install Intel Dialogic Driver Updates.

Q Configure Dialogic drivers for the trunk board types that you are using:

Q ISDN T1 PRI

Q ISDN E1 PRI

Q ISDN BRI

Q E1 CAS. Contact your TeleVantage provider for more information.

Q Internet telephony

Q Configure Robbed Bit T1 signalling, if you are using Robbed Bit T1 trunks.

If you experience problems with the Dialogic drivers after following the instructions in this 
chapter, see “Troubleshooting Intel Dialogic problems” on page D-3.

Important: Do not remove the Drivers CD from the CD drive until you are instructed to do so at 
the end of “Installing the Intel Dialogic Driver Updates” on page 9-5. If you remove the Drivers CD 
before or during a system restart, the installation may not complete successfully.

Installing the Intel Dialogic software _________________________
Important: The Dialogic SR 5.1.1 Drivers, SR 5.1.1 SP1, and Driver Updates setup programs 
have been customized for TeleVantage 5, and you must use these programs from the Drivers CD. 
If you use Dialogic setup programs from another source, the drivers will not work correctly with 
TeleVantage 5.

Note the following special cases:

Q Using non-English versions of Windows Server: If you are using a non-English 
version of Windows Server, create the directory C:\Program Files before installing the 
Dialogic drivers. Doing this prevents Dialogic error messages during the installation.

Q Using Dialogic PCI boards in Windows 2000 systems: Windows 2000 systems detect 
but do not recognize Dialogic PCI boards. This behavior, and how to deal with it, are 
described in step 2 of “Installing the Intel Dialogic SR 5.1.1 Drivers” on page 9-3.
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Uninstalling the old drivers
If you are upgrading from a previous version of TeleVantage, you must uninstall the old 
Dialogic drivers before installing the SR 5.1.1 drivers. If you have not already done so, see 
“Uninstalling the Dialogic drivers” on page 6-8 for instructions.

Installing the Intel Dialogic SR 5.1.1 Drivers
1. Start the TeleVantage Server PC if it is not running. Log on as a user with 

administrator privileges to the Windows Server on the PC on which the TeleVantage 
Server will be installed. On a Windows NT system, go to step 3.

2. Windows 2000 systems only: If you are upgrading from a previous version of 
TeleVantage and you installed Dialogic PCI boards since the last time you started the 
TeleVantage Server, the Found New Hardware wizard starts and prompts you to install 
drivers for the unknown PCI devices. This behavior occurs because Windows detects 
but does not recognize the new boards. 

Click Cancel to close the wizard. You will take steps to eliminate this behavior after 
you have installed Dialogic SR 5.1.1, SP1, and the Dialogic Driver Updates.

Important: Do not under any circumstances use the Found New Hardware wizard to 
install drivers for Dialogic boards. 

3. Insert the TeleVantage Drivers CD. The Driver Setup program starts automatically. If 
it does not start, or if the Drivers CD is already inserted, start the Driver Setup program 
manually by running autorun.exe from the root directory on the Drivers CD. For 
information about the Driver Setup program, see page 6-2.

4. Click Intel® Dialogic SR 5.1.1 Drivers, and follow the on-screen instructions. 
Installation may take 10 minutes or more.

5. In the Setup Complete dialog box, do one of the following:

Q If you do not have E1 CAS trunks, select Yes, I want to restart my computer now. 
Click Finish to restart your PC and complete the Dialogic Drivers installation. 

Go to step 6.
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Q If you have received supplementary E1 CAS protocol files from Dialogic, select 
No, I will restart my computer later. Click Finish. Install the supplementary files 
according to the instructions included with the files, or contact Dialogic. When you 
are done, restart your PC.

Important: Do not remove the TeleVantage Drivers CD until you are instructed to do 
so.

6. After your PC restarts, log on as the same user you logged on as in step 1. Installation 
continues. When the Setup Complete dialog box opens again, indicating that 
installation is complete, click Finish to exit the Driver Setup program.

Important: If the Found New Hardware wizard starts, click Cancel to close the wizard.

Go to the next section.

Installing Intel Dialogic SR 5.1.1 SP1 _________________________
1. Log on as a user with administrator privileges to the Windows Server on the PC on 

which the TeleVantage Server will be installed . 

2. Stop the Dialogic drivers if they are running. See Appendix H, “Using the Intel 
Dialogic Configuration Manager” for instructions.

Note: If you just installed the Intel Dialogic SR 5.1.1 Drivers from the TeleVantage 
Drivers CD, the drivers are stopped by default.

3. Insert the TeleVantage Drivers CD if you have not already done so. The Driver Setup 
program starts automatically. If it does not start, or if the Drivers CD is already 
inserted, start the Driver Setup program manually by running autorun.exe from the 
root directory on the Drivers CD. For information about the Driver Setup program, see 
page 6-2.

4. Click Intel® Dialogic SR 5.1.1 SP1, and follow the on-screen instructions.

5. In the InstallShield Wizard Complete dialog box, click Yes, I want to restart my 
computer now. Click Finish to complete SP1 installation.
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6. After your PC restarts, log on as the same user you logged on as in step 1. 

Important: If the Dialogic Found New Hardware wizard starts, click Cancel to close 
the wizard.

Go to the next section.

Installing the Intel Dialogic Driver Updates____________________
1. Log on as a user with administrator privileges to the Windows Server on the PC on 

which the TeleVantage Server will be installed. 

2. Stop the Dialogic drivers if they are running. See Appendix H, “Using the Intel 
Dialogic Configuration Manager” for instructions. 

Note: If you just installed the Intel Dialogic SR 5.1.1 Drivers or Intel Dialogic SR 5.1.1 
SP1 from the TeleVantage Drivers CD, the drivers are stopped by default.

3. Insert the TeleVantage Drivers CD if you have not already done so. The Driver Setup 
program starts automatically. If it does not start, or if the Drivers CD is already 
inserted, start the Driver Setup program manually by running autorun.exe from the 
root directory on the Drivers CD. For information about the Driver Setup program, see 
page 6-2. 

4. Click Intel® Dialogic Driver Updates, and follow the on-screen instructions. 

5. In the Setup Complete dialog box, select Yes, I want to restart my computer now, 
and then click Finish. Do not remove the TeleVantage Drivers CD yet.

6. After your PC restarts, log on as the same user you logged on as in step 1. The 
installation continues. 

Important: If the Found New Hardware wizard starts, click Cancel. To eliminate this 
behavior at future Server startups, see “PCI boards not recognized at Server startup” 
on page D-9.
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7. When the Setup Complete dialog box opens again, indicating that installation is 
complete, click Finish to exit the Driver Setup program. You can now remove the 
TeleVantage Drivers CD from the CD drive.

Important: You can recover a substantial amount of disk space after the Intel Dialogic 
Driver Updates installation completes by deleting the directory used to back up files. 
The default location is C:\Program Files\Dialogic\SAVE.

Go to the next section.

Configuring the Dialogic drivers_____________________________
After the Dialogic drivers and driver updates are installed, you must configure them for use with 
the specific Intel Dialogic telephony boards you are using. Dialogic drivers must be configured 
correctly before you can start the TeleVantage Server. You do not need to configure drivers for 
MSI/x or DISI/x station boards.

Important: After configuring your boards according to the instructions in this section, write down 
all of your non-default configuration settings. If at any time you need to run the Restore Device 
Defaults command in the Intel Dialogic Configuration Manager (DCM) in order to fix a Dialogic 
problem, you will lose all non-default configuration settings for all boards, and will need to 
reconfigure them.

Important: When the TeleVantage Server starts, it automatically starts the Dialogic drivers. Do 
not set the Dialogic drivers to autostart in DCM. If the drivers are already running when the 
TeleVantage Server starts, the Windows Service Control Manager may experience problems.

Basic board configuration tasks
Basic board configuration consists of the following:

Q Assign firmware files to DM3 boards. You are automatically directed to perform this 
step if DCM detects any new DM3 boards (DM/IPx Internet telephony boards, HDSI/x 
station boards, or DM/V2400A conference bridge boards). 

Q Verify that Dialogic is using a free IRQ and base memory address.  

Q Set trunk boards to use the clocking signal sent from the telephone company. All 
installations should perform this step to ensure that your trunk boards use the clocking 
signal sent from the telephone company. You specify a board that is connected to the 
telephone company, and that board then supplies signaling to the other boards.

Q Configure boards for use outside of North America and Japan. If you are outside 
North America and Japan, you must configure your Dialogic boards to use the a-law 
audio format.
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1. If you have all PCI or all ISA boards, go to the next step.

If you have a combination of ISA and PCI boards, do the following:

Q Invoke the BIOS configuration utility for your system.

Q Reserve a low IRQ (for example, 5) for use by ISA devices.

Note: To determine if a board is an ISA or a PCI board, see the hardware tables in 
“Intel Dialogic hardware requirements” on page 3-7.

2. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

If you do not have any DM3 boards installed (DM/IPx Internet telephony boards, 
HDSI/x station boards, or DM/V2400A conference bridge boards), go to step 3.

Otherwise, the Assign Firmware File dialog box opens.

Refer to the next table to find the firmware file for your board. Select that file in the 
Available Firmware list and then click OK. The Assign Firmware File dialog box 
opens for each DM3 board listed in the following table that is installed on the 
TeleVantage Server:

Board Firmware file

DM/IP241-1T1-10P iptk_t1_307_12.pcd

DM/IP301-1E1-10P iptk_e1_307_12.fcd

DM/IP241-1T1 100BT (PCI) iptk_t1_311.pcd

DM/IP2431A-T1 iptk_t1_307.pcd

DM/IP301-1E1 100BT (PCI) iptk_e1_311.pcd

DM/IP3031A-E1-120 iptk_e1_307.pcd
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3. The DCM main dialog box opens and shows all the boards that are detected on the 
system. 

Important: After installing new telephony boards and restarting the TeleVantage 
Server PC, DCM may fail to automatically detect some boards. If a board is not 
detected, it does not appear in the DCM main dialog box.

4. Compare the boards listed in DCM with the boards installed on your system. If any 
boards are undetected, see the following sections in Appendix D, “Troubleshooting”, 
for information about how to resolve the problem:

Q DM3 board. If a DM/IPx Internet telephony board, DI/SIx, or HDSI/x station 
board, or DM/V2400A conference bridge board is not detected, see “Dialogic 
Configuration Manager fails to detect a DM3 board” on page D-4.

Q D/41ESC analog trunk board. See “DCM fails to detect a D/41ESC board” on 
page D-8.

Q CTbus boards. If a CTbus board is not detected, see “Troubleshooting mixed 
CTbus board systems” on page D-9.

DM/IP481-2T1 100BT (PCI) ipt_2isdn_5ess_311.fc

DM/IP601-2E1 100BT (PCI) ipt_2isdn_5ess_311.fcd 

HDSI/x us_hdsi.pcd (US)

DM/V2400A ml9b_pcires.pcd

Board Firmware file
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5. Verify that Dialogic is using a free IRQ and base memory address. The Dialogic driver 
installation automatically assigns an IRQ and base memory address for the boards, but 
in some cases its choices may conflict with an existing IRQ or base memory address 
assignment. To do so:

Q Click Configured Devices in the main dialog box and then choose Action > 
Configure Device.

Q Click the System tab.

6. The BLTInterrupt parameter contains the IRQ assigned to Dialogic. To verify that this 
is a free IRQ, do one of the following: 

Q Windows NT: Click Start > Programs > Administrative Tools > Windows NT 
Diagnostics. In the Windows NT Diagnostics dialog box, click the Resources tab.

Q Windows 2000: Click Start > Programs > Accessories > System Tools > System 
Information. In the System Information dialog box, double-click Hardware 
Resources, and then double-click IRQs.

Do one of the following:

Q If the IRQ assigned to Dialogic is not listed, you do not need to change it. Go to the 
next step.

Q If the IRQ assigned to Dialogic is listed, make a note of one that is not. Close the 
screen. In DCM change the Value of the BLTInterrupt parameter to a free IRQ. 
Click OK.

Important: Windows assigns IRQs to PCI boards at startup, so they cannot be 
changed in DCM. Any IRQ change you make here will not be applied to PCI boards. If 
you have PCI boards, you need to work around existing IRQ assignments.
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7. The BLTAddress parameter contains the base memory address assigned to Dialogic. 
Verify that this base memory address is not being used by another board or program. 

Note: If there are other SCSI devices attached to the PC, they probably use the same 
base memory address (the default is d8000). It is easier to change the base memory 
address for the other devices than to change the address assigned to Dialogic in DCM.

8. To set your trunk boards to use the clocking signal sent from the telephone company, 
in the main DCM dialog box, under TDM Bus, double-click Bus-0.

9. Select the parameter Primary Master FRU (User Defined) and then select a trunk 
board from the Value drop-down list.

Note: Select a digital trunk board (T1, E1, or BRI) if one is installed, else select an 
analog trunk board. Internet telephony boards should not be used.

10. Click OK.

11. If you are located in North America or Japan, go to the next section, “Board-specific 
configuration tasks” on page 9-11.

If you are located outside North America and Japan, you must configure your Dialogic 
boards to use the a-law audio format. To do so, in the DCM main dialog box, under 
TDM Bus, double click Bus-0.

12. Select Media Type (User Defined) from the list.
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13. Select ALaw from the Value drop-down list. Do not select Automatic.

14. Click OK.

Note: During the TeleVantage Server installation, which is described in Chapter 11, 
you will choose your voice files format and your country. For more information see 
Administering TeleVantage.

Go to the next section.

Board-specific configuration tasks
Depending on the boards in your system or your location, you may need to perform one or more 
of the following additional tasks. See the referenced pages for details. 

Board Task

All DM3 boards Verify logical IDs. See page 9-12.

All ISA boards Set ISA Bus Width. See page 9-14.

Analog trunk boards Configure for best audio quality when 
forwarding calls.

See page 9-15.

ISDN PRI T1 or E1 trunk 
boards

Specify the ISDN protocol you are using. See page 9-16.

Configure Calling Name Identification. See page 9-17.

Enable Information Element (IE) based audio 
connection.

See page 9-17.
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When you have configured your boards and performed any additional required configuration 
tasks, go to “Test-starting the Dialogic drivers” on page 9-21.

Verifying logical IDs for DM3 boards
Perform this step only if you are using any of the following boards:

Q DM/IPx Internet telephony boards

Q DI/SIx or HDSI/x station boards

Q DM/V2400A conference bridge board

Logical IDs control the order of DM3 boards. If logical IDs are not ordered correctly, 
TeleVantage station and trunk numbers will not be correct. You should perform this step 
whenever you add, move, or remove a DM3 board. 

Note: DM3 boards cannot be moved or changed in a single operation. This restriction applies 
whether you are moving a board to a different slot, removing one board and installing another, or 
swapping a board for another of the same type. If you experience problems with DM3 boards after 
moving or changing them, see “Dialogic drivers may not start after moving or changing a Dialogic 
DM3 telephony board” on page D-10.

Configure delivery of overlapped DNIS digits. See page 9-17.

Configure for extended superframe service. See page 9-19.

ISDN BRI trunk boards Enable Information Element (IE) based audio 
connection.

See page 9-18.

Configure delivery of overlapped DNIS digits. See page 9-18.

Change the bearer channel protocol to uLaw 
(North America and Japan only).

See page 9-18.

Use Point-to-Point protocol. See page 9-18.

E1 CAS trunk boards If you plan to use E1 CAS trunk boards, 
contact your TeleVantage provider.

Robbed Bit T1 boards Configure for extended superframe service. See page 9-19.

Internet telephony 
boards

Specify IP address, subnet mask, and 
gateway IP address.

See page 9-20.

Board Task
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To verify logical IDs

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first board listed under the heading 
DM3. The Properties dialog box opens. 

Note: If a DM3 board is not listed, it was not detected by DCM. See “Dialogic 
Configuration Manager fails to detect a DM3 board” on page D-4.

3. For Internet telephony boards, click the System tab; for all other DM3 boards, click 
the Physical tab.

4. Make a note of the LogicalID parameter for the board. 

5. Repeat for the other DM3 boards.

6. Logical IDs should match the order of the boards in the DCM main dialog box (for 
example, 0, 1, 2, 3). If they are out of order (for example, 1, 0, 2, 3) change the 
LogicalID parameter for the affected boards to reorder them. To do so, in the 
Properties dialog box, select the LogicalID parameter, and then select the correct 
logical ID from the Value drop-down list. Click OK to save your changes.

If you have ISA boards, go to the next section. Otherwise, configure your trunk boards as 
described in the table on page 9-11.
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Configuring ISA boards
Perform this step if you have one or more ISA trunk or station boards installed. Because settings 
are shared across all ISA boards, you only need to make the following changes once. The values 
you select are applied to all ISA trunk and station boards.

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first ISA trunk or station board if you 
have one. 

Note: To determine if a board is an ISA or a PCI board, see the hardware tables in 
“Intel Dialogic hardware requirements” on page 3-7.

The Properties dialog box opens. 

3. On the System tab, select the ISABusWidth parameter and then select one of the 
following from the Value drop-down list:

Q Select 16-bit if all of your ISA boards are 16-bit boards. You can recognize a 16-bit 
ISA board because the edge connector has a gap in it.

Q Select 8-bit if all of your ISA boards are 8-bit boards, or if you have a mix of 8-bit 
and 16-bit boards. When you have a mix of ISA boards, all the boards must run at 
the slower rate. 

You can recognize an 8-bit ISA board because the edge connector does not have a 
gap in it, and is shorter than the edge connector on the 16-bit board.
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4. Click OK to save your changes. 

Use the following sections to configure your trunk boards. When you are done, go to 
“Test-starting the Dialogic drivers” on page 9-21.

Configuring analog trunk boards 
To get the best audio quality when forwarding calls over analog trunks, set the Receive Gain 
setting as described in this section.

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first analog trunk board. The Properties 
dialog box opens.

Note: If a E/41ESC board is not listed, it was not detected by DCM. See “DCM fails to 
detect a D/41ESC board” on page D-8

3. Click the Country tab.

4. Select the Receive Gain parameter.

5. Choose RXGAIN_P1 from the Value drop-down list.

6. Click OK. 

7. Repeat for each additional analog trunk board.

After you have configured all your analog trunk boards, configure other types of trunk boards if 
you have them. When you are done, go to “Test-starting the Dialogic drivers” on page 9-21.
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Configuring ISDN PRI T1 and ISDN PRI E1 trunk boards
For each ISDN PRI T1 and ISDN PRI E1 trunk board in your system, set the protocol to be used.

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first ISDN trunk board.

3. Click the Interface tab.

4. Select the board type from the list displayed.

5. Set the Value field to the appropriate protocol for the type of board, trunk, and ISDN 
protocol you are using. Find the appropriate entry from your carrier. For example, 
ISDN PRI T1 boards in the United States are usually set to NI2. ISDN PRI E1 boards 
in Europe are usually set to CTR4.

6. Click OK. 

7. Repeat for each additional ISDN trunk board.

If you experience problems with your ISDN PRI trunk boards after following the instructions in 
this section, see “Troubleshooting ISDN PRI T1/E1 problems” on page D-14.

For information about modifying protocols for ISDN PRI trunk boards, see Appendix B.
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Configuring Calling Name Identification
Depending on your ISDN PRI provider, Calling Name Identification is delivered in an 
Information Element (IE) either when the incoming call is offered (in the SETUP message) or 
on a subsequent FACILITY message. 

When you order Calling Name Identification, request the following information from your 
provider:

Q Message in which the calling name is delivered

Q IE in which the calling name is delivered

Q Offset within the IE where the calling name field begins

Q Length of the calling name field

This information is controlled via TeleVantage registry values which you set for each ISDN PRI 
trunk board in your system. See “Configuring Calling Name Identification on PRI boards” in 
Appendix A of Administering TeleVantage for details.

Enabling IE-based audio connection 
On ISDN PRI trunks, audio connection is based on Information Elements (IEs) that accompany 
Progress messages. 

Q When this feature is turned off, TeleVantage connects audio on all ISDN PRI calls 
regardless of Progress IEs. 

Q When turned on, TeleVantage connects audio on all ISDN PRI calls only with the IEs 1 
and 8 on PROCEEDING, SETUP_JACK, and ALERTING. 

This feature (turned off by default) is controlled via the TeleVantage registry value 
HandleProgressInd, which you set for each ISDN PRI trunk board in your system. See “E1 and 
T1 board settings” in Appendix A of Administering TeleVantage for details.

Configuring TeleVantage for delivery of overlapped DNIS digits 
Normally, DNIS digits are delivered completely on the SETUP message. Some European 
switches deliver DNIS digits one at a time after the SETUP message (overlapped digits).

By default TeleVantage is configured for complete delivery of DNIS digits on the SETUP 
message. DNIS digit delivery is controlled via the TeleVantage registry values OverlappedDNIS 
and DNISWaitTime, which you set for each ISDN PRI trunk board in your system. See “E1 and 
T1 board settings” in Appendix A of Administering TeleVantage for details.

After you have configured all your ISDN PRI trunk boards, configure other types of trunk 
boards if you have them. When you are done, go to “Test-starting the Dialogic drivers” on 
page 9-21. 
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Configuring ISDN BRI trunk boards

Enabling IE-based audio connection
On ISDN BRI trunks, audio connection is based on Information Elements (IEs) that accompany 
Progress messages. 

Q When this feature is turned off, TeleVantage connects audio on all ISDN BRI calls 
regardless of Progress IEs. 

Q When turned on, TeleVantage connects audio on all ISDN BRI calls only with the IEs 1 
and 8 on PROCEEDING, SETUP_JACK, and ALERTING. 

This feature (turned off by default) is controlled via a TeleVantage registry value, 
HandleProgressID. Add this setting for each ISDN BRI board in your system. See “BRI board 
settings” in Appendix A of Administering TeleVantage for details.

Configuring TeleVantage for delivery of overlapped DNIS digits
Normally, DNIS digits are delivered completely on the SETUP message. Some European 
switches deliver DNIS digits one at a time after the SETUP message (overlapped digits).

By default TeleVantage is configured for complete delivery of DNIS digits on the SETUP 
message. DNIS digit delivery is controlled via the TeleVantage registry values OverlappedDNIS 
and DNISWaitTime. Add these settings for each ISDN BRI trunk board in your system. See “BRI 
board settings” in Appendix A of Administering TeleVantage for details.

Changing bearer channel protocol to uLaw
By default, the protocol used on the 2 bearer channels is aLaw, the standard for Europe. If you 
are using ISDN BRI trunks in North America or Japan, you need to change the protocol to uLaw. 
See page B-4 for information on how to change ISDN span parameters using the TeleVantage 
Administrator. 

Using Point-to-Point protocol 
By default TeleVantage is configured to use Multipoint protocol with ISDN BRI boards. 
Protocol choice is controlled by a TeleVantage registry value and the firmware file associated 
with the BRI board.

To use Point-to-Point protocol, add the TeleVantage registry value PointToPoint for each 
ISDN BRI trunk board. See “BRI board settings” in Appendix A of Administering TeleVantage 
for details.

Also, perform the following procedure for each BRI board: 

1. Stop the Dialogic drivers if they are running. See Appendix H, “Using the Intel 
Dialogic Configuration Manager” for instructions.

2. Double-click the board in the DCM main dialog box.
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3. On the Misc tab, select the Firmware parameter. In the Value text box, enter 
Bripp.fwl. 

4. On the Telephony Bus tab, make sure that the PCMEncoding parameter is set to 
ALAW. 

5. Click OK. 

After you have configured all your ISDN BRI trunk boards, configure other types of trunk 
boards if you have them. When you are done, go to “Test-starting the Dialogic drivers” on 
page 9-21. 

Configuring T1 trunk boards for extended superframe service 
If you are using a T1 service with a framing type of extended superframe (Robbed Bit T1 using 
B8ZS/ESF or ISDN PRI T1), perform the following procedure for each T1 trunk board in your 
system. 

Note: You do not need to perform this step if you have Robbed Bit T1 using AMI/SF.

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first T1 trunk board.

3. Click the Misc tab.

4. Select the ParameterFile parameter.

5. In the Value field, enter Spandti.prm.
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6. Click OK.

7. Repeat for each additional T1 trunk board

8. In Windows Explorer, navigate to Program Files\Dialogic\Data\Spandti.prm. 
Open the file in Notepad.

9. Edit the file by adding the following lines: 

0014 01; ESF framing

0020 01; B8ZS

10. Save and close the file. 

After you have configured all your T1 trunk boards for extended superframe service, configure 
other types of trunk boards if you have them. When you are done, go to “Test-starting the 
Dialogic drivers” on page 9-21. 

Configuring Internet telephony boards
For each DM/IPx board, perform the following procedure:

1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

2. In the DCM main dialog box, double-click the first IP telephony board.

3. Click the Network tab.

4. Complete the following required fields. See your network or system administrator for 
the values to enter, or run the Windows IP Configuration utility to display the 
information. To do so, click Start > Programs > Accessories > Command Prompt, 
and then run the command ipconfig.exe.

Q For IPAddress, enter the IP address of the network interface card (NIC) that is 
attached to the Internet telephony board.

Q SubnetMask defaults to 0.0.0.0. It is not usually necessary to change the default.
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Q For GatewayIPAddress, enter the IP address of your router. In ipconfig, this value 
is labeled Default Gateway.

5. Click OK. 

6. Repeat for each additional IP telephony board.

After you have configured all your Internet telephony boards, configure other types of trunk 
boards if you have them. When you are done, go to “Test-starting the Dialogic drivers” on 
page 9-21. 

Test-starting the Dialogic drivers___________________________ 
1. Start the Intel Dialogic Configuration Manager (DCM) if it is not already running, and 

then start the Dialogic drivers. See Appendix H, “Using the Intel Dialogic 
Configuration Manager” for instructions.

The System Service Status displayed at the bottom of the DCM main dialog box 
changes to “Running” after the drivers have started.

Important: In some cases, especially with Internet telephony boards, the drivers can 
take several minutes to start. After five minutes, a dialog box may open and indicate that 
the drivers have not yet started. Click Continue to continue the startup procedure.
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If you encounter a problem, see the following troubleshooting topics:

Q “Dialogic drivers do not start” on page D-3 

Q “Troubleshooting mixed CTbus board systems” on page D-9

Q “Dialogic Service fails to start when a PCI board is installed in a PC with the 
Phoenix BIOS” on page D-10

Q “Dialogic drivers may not start after moving or changing a Dialogic DM3 telephony 
board” on page D-10

Q “‘Error 5aa’ or ‘PEB/SCBUS cable missing’ message when starting Dialogic 
drivers” on page D-11

Q “All phones ring when Dialogic drivers are started” on page D-11

2. When you have finished testing the Dialogic drivers, stop the Dialogic drivers. See 
Appendix H, “Using the Intel Dialogic Configuration Manager” for instructions.

If you experience problems starting the Dialogic drivers after following the instructions in this 
chapter, see “Troubleshooting Intel Dialogic problems” on page D-3.

To configure an ISDN or Robbed Bit T1 line, continue with the following sections. Otherwise, 
go to Chapter 10.

Configuring an ISDN line___________________________________
If you have an ISDN line, verify that it is working correctly before you proceed to the rest of the 
TeleVantage installation. See Appendix B, “Configuring ISDN Parameters” for details. When 
you are done, go to Chapter 10.

Configuring Robbed Bit T1 Signaling ________________________
If you have a Robbed Bit T1 line, you must verify that your T1 board is configured properly. Do 
not proceed to the rest of the TeleVantage installation until you have checked your T1 board. 
Although it is possible to configure your T1 line after you have installed TeleVantage, doing it 
now ensures that TeleVantage can use your T1 line correctly as soon as it is installed.

Note: This section is for Robbed Bit T1 installations only. If you have an ISDN T1 connection, 
you do not need to configure your board, and you can go directly to Chapter 10.

If you experience problems with your Robbed-Bit T1 line after following the instructions in this 
chapter, see “Troubleshooting Robbed Bit T1 problems” on page D-13.
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About Robbed Bit T1 signaling 
Robbed Bit T1 signaling replaces the least significant bits in specific locations in the T1 
transmission with signaling information, such as whether the caller’s line is on-hook or off-hook. 
The specific locations that contain signaling information are called A-bits, B-bits, C-bits, and 
D-bits. Robbed Bit T1 suppliers use different patterns of bit values to signal various events, 
including the following:

The signaling information is contained in A, B, C and D bits where each bit can be set High or 
Low Robbed Bit T1 suppliers use different patterns of these bit values to signal various events, 
including the following

Q Incoming call

Q Line drop

Q Inbound pickup (answering an inbound call)

Q Outbound pickup (seizing the line to make an outbound call)

Q Disconnect

Q Digit collection (capturing DID/DNIS or ANI information about an incoming call)

Check with your carrier to find out the precise patterns used to signal these events.

The method you use to configure Robbed Bit T1 signaling depends on how your carrier signals 
events:

Q If your carrier uses only A and B bits for T1 Robbed Bit signaling, you can use the 
TeleVantage Robbed Bit T1 Experimenter to test the line, manually change bit settings, 
or import signaling templates via the TeleVantage Administrator.

Q If you carrier uses C and D bits for Robbed Bit signaling, you must configure the C and 
D bits manually using the TeleVantage Administrator. See “Configuring Robbed Bit T1 
signaling manually” on page 9-28.

Note: Most carriers who use C and D bits can optionally set up their system to use only 
A and B bits, so that you can still use the Robbed Bit T1 Experimenter.

Installing the Robbed Bit T1 Experimenter
Install the Robbed Bit T1 Experimenter on the TeleVantage Server PC by running the following 
file on the TeleVantage Master CD:

\server\rbt1.exe 

Follow the on-screen instructions to complete the installation. Restart your PC when you are 
prompted to do so.
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Using the Robbed Bit T1 Experimenter 
Use the Robbed Bit T1 Experimenter to configure event signaling correctly in TeleVantage if 
your carrier only uses A and B bits for Robbed Bit signalling. If your carrier uses C and D bits, 
you must configure signaling manually, according to the instructions on page 9-28.

The Robbed Bit T1 Experimenter dialog box explains exactly how to ask your carrier for this 
information for each event, for example:

Q “What are A and B bits set to when I receive an incoming call?”

Q “What do I have to set the A and B bits to in order to seize the line when I detect an 
incoming call?”

Q “What is the setting of the line's A and B bits when the line is idle?”

Your carrier will also provide other information based on the services you ordered on the 
Robbed Bit T1 line, including the following:

Q Whether the digit signaling is Dual Tone Multi-Frequency (DTMF) or Multi-Frequency 
(MF)

Q What signal to send the central office to indicate TeleVantage is ready to receive the 
digit string (this is usually a wink)

Q The Transmit and Receive Wink definition

Q The format of the incoming ANI/DID/DNIS string

The default values that appear in the Experimenter are the E&M supervisory signaling 
protocols. If your Robbed Bit T1 line supports a supervisory signaling protocol other than E&M, 
you might need to modify events using information provided by your carrier. If you ordered 
ANI/DID/DNIS services on your Robbed Bit T1 line, you must customize the event signaling 
for digit collection. 
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To use the Robbed Bit T1 Experimenter

1. Make sure the Dialogic drivers are started.

2. Start the Robbed Bit T1 Experimenter by choosing Start > Programs > Artisoft 
TeleVantage > TeleVantage Robbed Bit T1 Experimenter.

Note: The Robbed Bit T1 Experimenter starts only if you have a T1 trunk board and 
an MSI board installed on your PC.

3. If you have more than one T1 board installed in your PC, select which board to 
configure. Click Options > Analyze Board > Board n, where n is the number of the 
board you want to configure. The T1 Board with the lowest ID number is selected by 
default.

4. Click File > Load Template. If you have a local T1 trunk, select local1.dst. If you 
have a long-distance T1 trunk, select longdistance.dst.

The template loads configuration information that will be valid in most cases. 

5. On the Basic tab, make sure the wink definition described under Transmit wink 
definition matches the wink definition of your T1 carrier. Most carriers toggle the A 
and B bits for a wink, and most use a wink length in the 150-400 ms range.

6. Under Send/receive digit type, choose DTMF or MF, depending on the type of digits 
your carrier uses.
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7. Under Collection Sequence, make sure your digit collection setting matches the 
sequence in which your carrier sends DID and ANI data to begin a call. Define the 
sequence by adding Retrieve Digits actions of the appropriate type, either DID, ANI, 
or Filler, to match how your carrier sends the data. Click Add to choose each Retrieve 
Digits action in the Digit Collection - Action dialog box.

For example, if your carrier sends data in the format *AAAAAAAAAA*DDDD (where A 
is an ANI digit and D is a DID digit), you can add Retrieve Digits actions in any of 
the following sequences:

Q Exactly 1 filler digit

Q Exactly 10 ANI digits

Q Exactly 1 filler digit

Q Exactly 4 DID digits 

Q Exactly one filler digit

Q Variable ANI digits up to * 

Q Exactly 4 DID digits

Click OK to add the new action to the digit collection sequence. From the Basic tab 
you can also delete actions, or edit existing ones by clicking the appropriate button. 
Use the arrow buttons to move an action up or down in the list.

8. Complete the digit collection definition by checking Send wink before collection 
digits or Send wink after collection digits according to the specifications of your 
carrier.

9. Try to place and receive a call (see “Placing and receiving test phone calls” on 
page 9-30). If the calls succeed, your T1 line is set up correctly, and you can go to step 
12.

If the calls fail, go to step 10. 

10. Make sure that all call events are defined to match your carrier's usage by using the 
following instructions: 
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Click the Advanced tab. From the Actions for list, select each event in turn, ask your 
carrier how it defines that event, and check that the definition is entered exactly as it 
needs it to be entered. If an event does not match the definition used by your carrier, 
redefine the actions that make up the event. To define an action, click Add to open the 
Action dialog box, and then select one of the choices under Actions:

Q Wait for bit state. In this action, TeleVantage waits to receive bits sent by the 
carrier. Select the Bit state (pattern of bits to be sent by the carrier), and then enter 
the Timeout in milliseconds.

Q Send bit state. In this action, TeleVantage sends bits to the carrier. Select the Bit 
state that TeleVantage will send to the carrier.

Q Pause. In this action, TeleVantage waits for a specific number of milliseconds. 
Enter the Timeout in milliseconds.

Q Retrieve digits. In this action, TeleVantage retrieves ANI, DID/DNIS, or filler 
digits sent by the carrier. This action is a duplicate of the action on the Basic tab. 
See step 7 on page 9-26 for more information.

Click OK to save the action. From the Advanced tab you can also delete actions or edit 
existing ones by clicking the appropriate buttons. Use the arrow buttons to move an 
action up or down in the list.

11. Try to place and receive a call (see “Placing and receiving test phone calls” on 
page 9-30). If the calls succeed, your T1 trunk is set up correctly, and you go to step 12.

If the calls still fail, use the custom option to test sending and receiving individual bit 
states. See “Testing individual bit states with the custom actions option” on page 9-30.

12. When your T1 line is configured correctly, choose File > Apply to TeleVantage 
Server. Doing this saves the Robbed Bit T1 Experimenter's configuration data for the 
specified board to the Windows registry in the format that TeleVantage requires, 
which ensures that the TeleVantage Server can use your T1 trunk.

13. If the board you just configured is the only T1 board, save the file as a template that 
you can use in the event that it needs to be reloaded, by choosing File > Save 
Template. Close the Robbed Bit T1 Experimenter by choosing File > Exit.

14. If you have multiple T1 boards, go to the next section.
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Using a template to configure additional Robbed Bit T1 boards
If you have more than one T1 board, you can apply the correct settings from the first board to 
the others by saving the settings as a template, and then loading them for the other boards, as 
follows:

1. With the settings for the first board showing in the Robbed Bit T1 Experimenter, 
choose File > Save Template. Choose a new name for the template, so that you do not 
overwrite the original TeleVantage file.

2. Select another of your T1 boards, and then click Options > Analyze Board > Board 
n, where n is the ID number of the board you want to configure.

3. Choose File > Load Template. Select the template you just saved.

4. With the template loaded, choose File > Apply to TeleVantage Server. 

5. Repeat steps 2-4 for any other T1 boards in your system.

6. Close the Robbed Bit T1 Experimenter by choosing File > Exit.

When you are done, go to “Placing and receiving test phone calls” on page 9-30.

Configuring Robbed Bit T1 signaling manually
If your carrier uses C and D bits for Robbed Bit signalling, you must configure the C and D bits 
manually. 

Note: See Administering TeleVantage for information on adding a Robbed Bit T1 span.

1. In the TeleVantage Administrator, edit the Robbed Bit T1 span in the Trunks view.

2. Click the Signaling tab. Make sure that all call events are defined to match your 
carrier's usage. Double-click each event in turn to open it in the Definition dialog box.

3. Ask your carrier how it defines each event, and check that the definition is entered 
exactly as it needs it to be entered. If an event does not match the definition used by 
your carrier, redefine the actions that make up the event. If an action is undefined, click 
Add. To define an action, click Edit to open the Action dialog box, and then select one 
of the choices under Actions:

Q Wait for bit state. In this action, TeleVantage waits to receive bits sent by the 
carrier. Select the Bit signal (pattern of bits to be sent by the carrier), and then enter 
the Timeout in milliseconds.

Q Send bit state. In this action, TeleVantage sends bits to the carrier. Select the Bit 
signal that TeleVantage will send to the carrier.

Q Pause. In this action, TeleVantage waits for a specific number of milliseconds. 
Enter the Timeout in milliseconds.
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Q Retrieve digits. In this action, TeleVantage retrieves ANI, DID/DNIS, or filler 
digits sent by the carrier. Make sure your digit collection setting matches the 
sequence in which your carrier sends DID and ANI data to begin a call. Define the 
sequence by adding Retrieve Digits actions of the appropriate type, either DID, ANI, 
or Filler, to match how your carrier sends the data. Click Add to choose each 
Retrieve Digits action in the Digit Collection - Action dialog box.

For example, if your carrier sends data in the format *AAAAAAAAAA*DDDD (where 
A is an ANI digit and D is a DID digit), add the following Retrieve Digits actions:

Q Exactly 1 filler digit

Q Exactly 10 ANI digits

Q Exactly 1 filler digit

Q Exactly 4 DID digits 

Q Exactly one filler digit

Q Variable ANI digits up to * 

Q Exactly 4 DID digits

Click OK to add each new action to the digit collection sequence. From the Digit 
Collection - Definition dialog box, you can also delete actions, or edit existing ones 
by clicking the appropriate button. Use the arrow buttons to move an action up or 
down in the list.

4. Click OK to save your changes until you return to the Trunks view.

Go to the next section.
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Placing and receiving test phone calls
To determine the correct configuration for your T1 line, you must place and receive test phone 
calls. Your T1 carrier can give you a number to call.

To place a call

1. On the Advanced tab, set Actions for to Outbound pickup.

2. Click Place Call.

3. In the Place Call dialog box, enter the phone number to dial and the timeslot to use for 
the call.

4. Click OK to place the call.

5. To end the call, click Hangup.

No audio connection is made, but the Logging dialog box tells you whether the call was made 
successfully.

To receive a call

1. When the incoming call arrives, you will know it by the Logging dialog box, and also 
by the Place Call button, which changes to Inbound Pickup.

2. To pick up the call, click Inbound Pickup.

3. To end the call, click Hangup. 

Testing individual bit states with the custom actions option
Transmitting custom actions between you and your T1 carrier is a powerful troubleshooting 
tool. Use this tool while you are on the phone with your carrier to make sure that it is receiving 
what you send, and that you are receiving what it sends. If any problems arise, you can solve 
them by redefining the actions.

To transmit custom actions

1. Click Options > Set Custom Timeslot. Enter the timeslot to use for sending outbound 
custom actions, and then click OK.

2. Uncheck Options > Respond to Events. Doing this ensures that events sent by your 
carrier will be used only for testing and will not be interpreted by the system as an 
actual incoming call.

3. On the Advanced tab, select Custom from the Actions for drop-down list.

4. Click Add.
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5. In the Action dialog box, select the action and bit state you have agreed with your 
carrier to test.

Examples: To send a wink, select Send bit state from the Actions list, and then select 
Wink from the Bit State drop-down list. To receive an “A high B high” state from your 
carrier, select Wait for bit state from the Actions list, and then select A high B high 
from the Bit State drop-down list.

6. Click OK to add the action to the Actions for list.

7. Click Execute to execute the command. If the command is to send an action, the action 
is sent. If the command is to receive an action, the Robbed Bit T1 Experimenter stands 
by to receive it. The results of the transmission appear in the Logging dialog box. 

Where to go next_______________________________________
When you have successfully installed and configured the Dialogic drivers as described in this 
chapter, go to Chapter 10.
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Introduction _____________________________________________
TeleVantage requires a database server to manage and access the TeleVantage database, which 
is the repository for both the current system configuration and historical Call Log information. 

Database server options
TeleVantage supports three database servers, Microsoft SQL Server 7.0, Microsoft SQL Server 
2000, and Microsoft Data Engine (MSDE), which is a SQL Server-compatible data engine 
included on the TeleVantage CD. The database server you should use depends on the type of 
installation you are performing:

Q Upgrading from TeleVantage version 3.0 or higher. You can continue to use 
Microsoft SQL Server 7.0 as your database server. 

Q To install SQL Server Service Pack 4 (optional with TeleVantage), go to page 10-4.

Q If you do not plan to install SP4, go to Chapter 11.

Q Upgrading from TeleVantage version 2.1. You must install MSDE from the 
TeleVantage Master CD. Go “Upgrading from TeleVantage 2.1” on page 10-2.

Q Installing this version of TeleVantage for the first time. You should install MSDE 
from the TeleVantage Master CD, or install your own copy of SQL Server 2000 or SQL 
Server 7.0, as described in “TeleVantage database server requirements” on page 3-7. To 
install MSDE, go to “Installing MSDE from the TeleVantage Master CD” on page 10-2.

If MSDE is already installed on your PC:

Q To install SQL Server Service Pack 4 (optional with TeleVantage), go to page 10-4.

Q If you do not plan to install SP4, go to Chapter 11.

Upgrading from TeleVantage 2.1_____________________________
When you upgrade TeleVantage 2.1, verify that the TeleVantage Server is not set to autostart 
before you begin installing the database server. 

To turn off autostart 

1. Choose Start > Settings > Control Panel > Services. 

2. Select TeleVantage Service, click Startup, and select Manual.

Go to the section, “Installing MSDE from the TeleVantage Master CD” on page 10-2. 

Installing MSDE from the TeleVantage Master CD ______________
Important: The database server installation has been customized for TeleVantage. You must 
install the database server using the Master Setup program on the TeleVantage Master CD, as 
described in the next procedure. 
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To install MSDE from the TeleVantage Master CD 

1. Insert the TeleVantage Master CD if you have not already done so. The Master Setup 
program starts automatically. If it does not start, or if the Master CD is already 
inserted, start the Master Setup program manually by running autorun.exe from the 
root directory on the Master CD. For information about the Master Setup, see page 6-2. 

2. Click Microsoft Data Engine.

3. The Master Setup program searches to see if Microsoft Internet Explorer 5.0 is already 
installed on your PC. If you do not get a warning message, Internet Explorer 5.0 or 
higher was detected. Go to the next step.

If Internet Explorer 5.0 or higher is not detected, you are prompted to install Internet 
Explorer 5.5 from the TeleVantage CD. Click Yes, and then follow the on-screen 
instructions to complete the installation.

Note: After the Internet Explorer 5.5 installation completes, your PC restarts 
automatically but does not return you the Master Setup program. Therefore, you must 
repeat steps 1 and 2 of this procedure and then go to step 3. Be sure to select Microsoft 
Data Engine again from the Master Setup program.

4. If Microsoft Data Engine is detected on your PC, click OK at the prompt. Click Cancel 
in the Select Destination Directory dialog box, and then go to “Installing SQL Server 
Service Pack 4” on page 10-4.

If Microsoft Data Engine is not detected on your PC, the Select Destination Directory 
dialog box shows the default directory in which the Microsoft SQL Server database 
files will be installed. To install the files in a different location, click Browse. Click 
Next to continue.
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5. After file copying starts, a command window opens and remains open while the 
database server installation is taking place. The installation will take while, from 20 
minutes when you are installing for the first time to up to an hour when you are 
upgrading.

Important: Do not close the command window. Closing it can cause the MSDE 
installation to fail.

6. When the installation is finished, the command window closes. If you are prompted to 
restart the PC, do so.

Go to the next section.

Installing SQL Server Service Pack 4
Installing SQL Server SP4 is optional. SP4 improves SQL Server security and performance on 
some PCs, but it is not required for TeleVantage. If you do not plan to install SP4, go to 
Chapter 11.

Note: You can install SQL Server SP4 whether you use SQL Server 7 or MSDE as your 
database server. It cannot be installed with SQL Server 2000.

To install SQL Server SP4 

1. Run the following program on the TeleVantage Master CD:

\msde\SP4\setup.exe 

Follow the on-screen instructions. 

2. When you are prompted to restart your PC, do so.

If you experience problems with your database server after following the instructions in this 
chapter, see “Troubleshooting database server problems” on page D-11.

Where to go next ______________________________________
When you have successfully installed the database server, go to Chapter 11.
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Introduction _____________________________________________

Perform these steps
You perform the following steps to install and configure the TeleVantage Server:

Q Install the TeleVantage Server.

Q Install the TeleVantage Administrator.

Q Install a dongle, if you plan to use that method of hardware locking for your TeleVantage 
licenses.

Q Enter and activate your TeleVantage licenses.

Q Test the TeleVantage Server.

Q Set the TeleVantage Server to autostart.

Q Set access rights to the TeleVantage Server.

Q Optional. Configure TeleVantage for use with a proxy server. Perform this step if you 
use a proxy Server to access the Internet from a local area network.

Q Optional. Configure e-mail notification support. Perform this step if your users want to 
receive e-mail notification of voice messages.

Q Optional. Configure TeleVantage to use Lotus Notes for e-mail notification. Perform 
this step to use Lotus Notes with TeleVantage.

Q Optional. Configure any TeleVantage 3.x Servers that communicate with the 
TeleVantage 5.x Server over an IP Gateway connection.

If you experience problems after following the instructions in this chapter, see “Troubleshooting 
TeleVantage Server problems” on page D-12. 

Requirements
For a list of the hardware and software requirements for the TeleVantage Server PC, see 
“TeleVantage Server requirements” on page 3-2.

Installing the TeleVantage Server ____________________________
1. Close all open Windows applications.

2. Log on to the network using the Windows Server user created for the TeleVantage 
Server.

Note: If you have not already created this user, which will be used to run the 
TeleVantage Service, see Chapter 7 for information about creating the Windows Server 
user.
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3. Verify that the MSSQLServer Service is running. To do so:

Q Right-click the SQL Server Manager icon in the system tray and then click 
Open SQL Server Service Manager. 

Q In the SQL Server Service Manager dialog box, select MSSQLServer from the 
Services drop-down list. 

Q If the status bar at the bottom of the SQL Server Service Manager dialog box 
says “Running,” exit the dialog box and go to the next step.

Q If MSSQLServer is not running, click Start/Continue to start it. When the 
MSSQLServer Service is running, exit the dialog box.

4. Insert the TeleVantage Master CD if you have not already done so. The Master Setup 
program starts automatically. If it does not start, or if the Master CD is already 
inserted, start the Master Setup program manually by running autorun.exe from the 
root directory on the Master CD. For information about the Master Setup, see page 6-2.

5. Click TeleVantage Server.

The Artisoft TeleVantage Server 5 installation begins.

6. On a Windows NT 4.0 PC, if you have not already installed Windows NT 4.0 Service 
Pack 6 or higher, you are prompted to install Service Pack 6 now. See “Installing 
Windows NT 4.0 SP6a” on page 7-10 for details.

7. The Welcome dialog box prompts you to exit any other programs that are running. 
After doing so, click Next to continue. If you are installing TeleVantage for the first 
time, go to step 8.

Note: When upgrading from a previous version of TeleVantage, you are prompted to 
copy the TeleVantage database backup file and voice files to another location. If you 
already have backed up your TeleVantage database and voice files as described in 
“Preparing your system for upgrade” on page 6-6, you do not need to repeat the process 
here.

8. In the Software License Agreement dialog box, signify your agreement with the 
conditions by clicking Yes. 
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9. When upgrading from a previous version of TeleVantage, the TeleVantage License 
Codes dialog box appears and reminds you that you need license codes. Click Next. 
Go to step 13.

10. In the User Information dialog box, enter your name and your company name, and then 
click Next to continue.

11. If you are installing TeleVantage for the first time, in the VAR Contact Information 
dialog box, enter the name, company, and telephone number or e-mail address of your 
TeleVantage provider, and then click Next to continue.

Note: It is important to enter this information, because it is helpful to users who must 
contact technical support. They obtain this information by choosing Help > About from 
the TeleVantage Client or Administrator.

12. If you are installing TeleVantage for the first time, the TeleVantage Server Destination 
dialog box shows the default directory in which the TeleVantage Server will be 
installed. To install the TeleVantage Server in a different location, click Browse. Click 
Next to continue

13. In the Language Selection and Voice Files Destination dialog box, specify the 
language versions of the system prompts that you want to install.

If you are installing TeleVantage for the first time, select the checkboxes for all the 
languages that your callers and users are likely to want to use, but note that this will 
require significant extra disk space. You can specify languages later for individual 
users and callers in the Administrator and Client, but to install additional languages, 
you will have to reinstall the TeleVantage Server.

Voice files for the languages you select (including prompts that both callers and users 
hear) will be installed in the Destination Folder. To install the files in a different 
location, click Browse. 

Click Next to continue. If you are upgrading from a previous version, go to step 15.

14. If you selected more than one language, in the Select Default Language dialog box, 
select the default language for system prompts. This language will also be used as the 
default when creating new users and contacts. Click Next. If you are installing 
TeleVantage for the first time, go to step 16.

15. If you are upgrading your TeleVantage system, in the TeleVantage Voice File 
Upgrade dialog box, choose what to do with any customized system prompts that have 
you have previously recorded. 

Note: This choice affects only the system prompts that you have customized, not other 
recordings that you have made such as greetings or auto attendants. Custom greetings 
and auto attendants are always preserved during an upgrade.

Q If you have not customized any system prompts, or if you want to retain your 
customized system prompts, click Preserve existing. Any system prompts that 
have been customized are retained, while unmodified system prompts are 
overwritten with TeleVantage 5 versions. Click Next to continue and go to the next 
step.
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Q To update all system prompts, or if you are upgrading from TeleVantage 2.1 or 
earlier, click Backup and overwrite. You must choose this option when you are 
upgrading from TeleVantage 2.1 or earlier because the system prompts have 
changed extensively since that version.

Your existing system prompts are automatically backed up, and the TeleVantage 5 
system prompts are installed. The default backup location is:

c:\Program Files\TeleVantage Server\VFiles\EN00\Backup

If you choose Backup and overwrite, you can use the System Prompts view in the 
TeleVantage Administrator to selectively review and import your customized 
system prompts later. See Administering TeleVantage for more information.

Click Next to continue.

16. In the Windows Account Name and Password dialog box, enter the name and 
password of the account you will use to run the TeleVantage Server. Click Next to 
continue.

17. In the TeleVantage Area Code dialog box, enter your telephone area code or city code. 
Click Next to continue.

18. In the TeleVantage Voice File Format dialog box, choose uLaw or aLaw depending 
on the format used in your country, and then click Next. Confirm your choice if you 
are prompted.

Note: If you must change voice file format after installing the TeleVantage Server, see 
Administering TeleVantage. This dialog box does not appear if you reinstall the same 
version of the TeleVantage Server again on the same PC.

19. Review your choices in the Start Copying Files dialog box. To make changes, click 
Back. Click Next to begin copying files. The informational messages let you follow 
the progress of the installation, which can take several minutes.

20. In the Restart to Continue Setup dialog box, select Yes, I want to restart my computer 
now, and then click Finish to restart the PC. 

Important: Be sure to leave the TeleVantage Master CD in the drive while the PC 
restarts.

After the PC restarts, log on as the same user you used previously. The Master Setup 
program will resume, copy additional files, and then complete the installation 
automatically. 

Important: This may take a significant amount of time, so be sure to allow the Master 
Setup program to complete.

21. In the Setup Complete dialog box, select the Launch TeleVantage Workstation 
Setup checkbox to install the TeleVantage Administrator on the TeleVantage Server 
PC in order to enter your licenses. Click Finish. 
CHAPTER 11. INSTALLING THE TELEVANTAGE SERVER 11-5



22. If you are prompted to restart your PC, do so. After your PC restarts, log on as a user 
with administrator privileges. The TeleVantage Workstation Setup starts. If it does not 
start automatically, start it manually as described in the next section.

Note: Microsoft SQLServerAgent service may not restart automatically after installing 
TeleVantage Server. See page D-11 for more information.

Installing the TeleVantage Administrator______________________
This section explains how use the TeleVantage Workstation Setup to install the TeleVantage 
Administrator in the default location on the TeleVantage Server PC.

Note: You will use Workstation Setup again in Chapter 12 to install the TeleVantage workstation 
applications on other PCs or to install other workstation applications on the Server. All the 
Workstation Setup options are described in that chapter.

To install the TeleVantage Administrator on the TeleVantage Server PC

1. Log on to the TeleVantage Server PC as the same user you specified when you 
installed the TeleVantage Server. 

2. Close all open Windows applications.

3. If the TeleVantage Workstation Setup is not running, from the Start menu, choose 
Programs > Artisoft TeleVantage Server > TeleVantage Workstation Setup. 
Follow the on-screen instructions.

4. Review the License Agreement. Click I accept the terms in this license agreement, 
and then click Next to continue.

5. In the Customer Information screen, enter your User Name and Organization. 

6. In the TeleVantage Server Information screen, enter the TeleVantage Server Name 
and the Telephone Station ID of the phone that will be used by the person 
administering the TeleVantage system from this PC (the Admin user). 

The station ID corresponds to the port number on the station board to which the phone 
is connected. To hear your station ID, pick up the phone and dial *0. 

Note: If there is not a TeleVantage phone near this PC, enter a station ID of 0. Without 
a phone, the user administering TeleVantage from this PC will be able to perform all 
administrative functions with the exception of recording voice prompts. If you enter a 
station ID of 0, when you click Next, the No Telephone Station ID Specified screen 
opens to make sure that you understand this limitation, and gives you the opportunity 
to go back and enter a valid station ID.

Select Only for me if you want only this user to be able to run the Administrator from 
this PC.

Click Next to continue.
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7. In the Setup Type screen, select Typical to install the TeleVantage Administrator in 
the default location. To install additional workstation applications on the TeleVantage 
Server, perform a custom installation, as described in Chapter 12.

Click Next to continue.

8. In the Ready to Install screen, click Install. Installation may take several minutes.

9. In the Installation Completed screen, select the Show What’s New checkbox to see a 
complete listing of the new features available in this version of TeleVantage. Click 
Finish to complete the installation.

If you are prompted to restart your PC, do so.

Go to the next section.

Entering and activating your TeleVantage licenses _____________
This section explains how to do the following:

Q Enter licenses manually, using the TeleVantage Administrator.

Q Activate licenses over the Internet to enable full functionality on your TeleVantage 
system.

Please note the following important information:

Q You need to enter new licenses even if you are upgrading from a previous version. 
To enter a license, you need to know the serial number and verification key for the 
license. Typically, this information is supplied by your TeleVantage provider as a 
printed document or in a license file. If your TeleVantage provider supplies you with a 
license file, see page F-6 for instructions on how to import it.

Keep your license serial numbers and verification keys in a safe location and do not 
share them with others. This information forms the basis for your ability to install and 
use TeleVantage.

Q You must activate your licenses. Activation requires the following:

Q Hardware ID. When you activate your licenses, you must choose a hardware ID on 
the TeleVantage Server PC to which your licenses are locked. Be sure to review the 
hardware locking options described in “How hardware locking works” on page F-9. 
If you plan to use a dongle for hardware locking, install it according to the 
instructions in “Installing a dongle” on page F-10 before entering and activating 
your licenses.

Q Internet access on the PC on which you are running the TeleVantage 
Administrator. If you do not have an Internet connection, you can activate your 
licenses from another PC in the network that does have Internet access. See 
“Activating licenses via the web” on page F-4 for instructions.

Q VAR Authorization number. Request this number from the place where you 
purchased TeleVantage.
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See “TeleVantage license requirements” on page 3-20 for information about the different 
licenses that are available.

For details about how TeleVantage licensing works see Appendix F, “Managing TeleVantage 
Licenses.” 

To enter and activate TeleVantage licenses

1. Start the TeleVantage Administrator by choosing Start > Programs > Artisoft 
TeleVantage > TeleVantage Administrator.

2. In the Administrator Log On dialog box, enter your User name and Password, and 
then click OK. 

Note: After first installing the TeleVantage Administrator, log on using the default User 
name Admin and the default Password of 100.

3. If you logged on using the default User name and Password, the Security Warning 
dialog box opens, reminding you to change the defaults to protect your system.

Click OK to continue.

4. Change the default passwords for the Admin and Operator user accounts right now to 
protect yourself against toll fraud. To do so:

Q Open the Users view by clicking its button in the view bar on the left side of the 
Administrator window.

Q Double-click the Admin user.

Q Change the default Password to one that is at least 5 digits long and cryptic. Retype 
the new password in the Confirmation field. Click OK.

Q Change the password for the Operator user as well. 
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See Administering TeleVantage, Appendix C, “Protecting Your Phone System Against 
Toll Fraud” for more information. For more about password security for TeleVantage 
workstation applications, see Administering TeleVantage.

5. Choose Tools > System Settings, and then click the Licenses tab.

6. Enter your Server license first. Select Server from the License category drop-down 
list, and then enter the Serial number and Verification key for the Server license.

7. For the next license, select the appropriate license category from the drop-down list.
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8. Click Add. The Modify License dialog box opens.

Enter the Serial number and Verification key for the license, and then click OK. 

For each remaining license, repeat this step.

9. If this PC is connected to the Internet, click Activate to activate your licenses. If you 
do not have Internet access on this PC, see “How to activate your licenses” on page F-4 
for other ways to activate your licenses.

The Activation Information dialog box opens.

Note: If you do not have Internet access on this PC, see “How to activate your 
licenses” on page F-4 for other ways to activate your licenses.

10. Complete the information in the Activation Information dialog box. All fields in bold 
are required. Completing all the fields will help your technical support representative 
when troubleshooting problems, and will keep you informed of any updates. 

Note: If you do not know your VAR Authorization Number (a required field), you can 
request it from the place where you purchased TeleVantage.
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11. Specify the hardware ID to which you want to lock your TeleVantage licenses by 
selecting one of the following from the drop-down list. Once locked to a hardware ID, 
your licenses will only work on a PC with that hardware ID. For more information, as 
well as details on the pros and cons of each type of hardware ID, see “How hardware 
locking works” on page F-9.

Q Hard drive. The serial number of each hard drive on the TeleVantage Server PC.

Q Network card. The MAC address of each NIC on the TeleVantage Server PC.

Q Dongle. Serial number of a dongle, if one is installed on the TeleVantage Server PC 
along with the dongle drivers. See page 3-6 for information on how to obtain a 
dongle.

12. The next message box confirms the hardware ID that you selected since it is an 
important decision. Click OK to continue, or Cancel to go back and specify a different 
hardware ID.

13. Click OK. TeleVantage submits your license information to Artisoft. 

If activation was successful, activated licenses are returned and automatically added 
to your system. 

Click OK twice, to acknowledge the message and exit the System Settings dialog box.

If activation was not successful, the reason is displayed. See “Licensing errors” on 
page F-6 for more information.

For more information, see Appendix F, “Managing TeleVantage Licenses.” 

Testing the TeleVantage Server _____________________________
At this point in the installation or upgrade process, you should test the TeleVantage Server to 
make sure that it has been installed correctly. Testing the Server consists of starting the Server 
from the Device Monitor and checking for errors.

Note: The TeleVantage Server will not start until you have entered a valid Server license. See 
“Entering and activating your TeleVantage licenses” on page 11-7.

Important: If you have Dialogic PCI boards installed on the Server, perform the process 
described in “PCI boards not recognized at Server startup” on page D-9 if you have not already 
done so. Otherwise, the Found New Hardware wizard will start after every Server restart. 
However, do not under any circumstances use the Found New Hardware wizard to install drivers 
for Dialogic boards.
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To test the TeleVantage Server

1. Close all Windows applications, including the TeleVantage Administrator if it is 
running. 

2. Shut down the TeleVantage Server PC. To do so:

Q Right-click the Device Monitor icon in the system tray and then click Show Device 
Monitor. If the Device Monitor is not running, start it manually. The default 
location is:

C:\Program Files\TeleVantage Server\tvdevmon.exe

Q Stop the TeleVantage Server by selecting Tools > Stop Server. 

The status of the TeleVantage Server is displayed at the bottom of the Device Monitor.

3. To simulate a normal startup, restart the TeleVantage Server PC. To do so, select 
Tools > Start Server from the Device Monitor.

4. The TeleVantage splash screen indicates that the Device Monitor is starting. Open the 
Device Monitor by right-clicking the Device Monitor icon in the system tray. Then 
choose Show Device Monitor (by default, the Device Monitor starts minimized when 
you log on).

5. Start the TeleVantage Server from the Device Monitor by selecting Tools > Start 
Server. 

After the TeleVantage Server starts, the Device Monitor displays the status of all 
station ports on the MSI board and all trunks on the trunk boards. You can close the 
Device Monitor without affecting the operation of the TeleVantage Server.

6. Check for startup errors. Not all error messages are displayed in the Device Monitor, 
so you should also use the Windows Event Viewer to check the System Log for any 
startup warnings or Dialogic errors. To do so:

Q Choose Start Menu > Programs > Administrative Tools > Event Viewer. In the 
Tree pane, click Application Log to view TeleVantage or database server 
messages, warnings, or errors. Expand System Log to view operating 
system-related events.

Note: If you are not running the Windows Event Viewer on the TeleVantage Server, 
choose Log > Select Computer.

If you encounter database server errors, see “Troubleshooting database server problems” on 
page D-11. For TeleVantage Server-related problems, see “Troubleshooting TeleVantage 
Server problems” on page D-12.

When you are satisfied that the TeleVantage Server is running correctly, go to the next section, 
“Setting the TeleVantage Server to autostart.” 
11-12 INSTALLING TELEVANTAGE



Setting the TeleVantage Server to autostart ___________________
In the previous section, you started the TeleVantage Server manually to test it. When you are 
satisfied that the Server is working correctly, you should set the Server to start automatically so 
that telephone service is automatically restored whenever the TeleVantage Server PC restarts.

Important: When the TeleVantage Server starts, it automatically starts the Dialogic drivers. Do 
not set the Dialogic drivers to autostart in the Intel Dialogic Configuration Manager. If the drivers 
are already running when the TeleVantage Server starts, the Windows NT Service Control 
Manager may experience problems.

To set the TeleVantage Server PC to autostart

1. Depending on your operating system, do one of the following:

Q Windows NT: Click Start > Settings > Control Panel > Services. 

Q Windows 2000: Click Start > Settings > Control Panel > Administrative Tools > 
Services. 

2. In the Services dialog box, locate and double-click TeleVantage server. 

3. In the TeleVantage server Properties dialog box, select Automatic from the Startup 
type drop-down list. 

4. Click OK, and then exit the Services dialog box.

5. To test automatic startup, first perform an orderly shutdown:

Q In the Device Manager, stop the TeleVantage Server by choosing Tools > Shut 
down Server.

Q In the Intel Dialogic Configuration Manager (DCM), stop the Dialogic drivers. See 
Appendix H, “Using the Intel Dialogic Configuration Manager”  for instructions. 

6. Restart the TeleVantage Server PC.

7. In the Device Monitor, check the status of the TeleVantage Server. “Started” means 
that the autostart was successful. 

8. Verify that the Startup type for the TeleVantage Server is Automatic, according to 
the instructions in steps 1-3. On subsequent reboots of the TeleVantage Server PC, the 
TeleVantage Server will start automatically. 

Note: If you configure your TeleVantage system for e-mail notification, e-mail notification will not 
be enabled after Server startup until the TeleVantage user logs on to the system. E-mail 
notification is used to alert TeleVantage system administrators that the TeleVantage Server is 
being stopped and restarted.
CHAPTER 11. INSTALLING THE TELEVANTAGE SERVER 11-13



Completing the TeleVantage Server installation ________________
After you install and test the TeleVantage Server, you can perform any of the following tasks to 
complete the installation for your specific environment:

Q Set access rights to the TeleVantage Server (see page 11-14.) 

Q Configure TeleVantage for use with a proxy server (see page 11-14.) 

Q Configure e-mail notification support (see page 11-15.) 

Q Use Lotus Notes for e-mail notification (see page 11-17.) 

Q Configure any TeleVantage 3.x Servers that communicate with the TeleVantage 5.x 
Server using an IP Gateway connection (see page 11-18.) 

Setting access rights to the TeleVantage Server
Make sure that any user who will use the TeleVantage Client or run the TeleVantage 
Administrator remotely has network access to the TeleVantage Server. 

Also make sure that each TeleVantage user can log on to a PC that is on the same network as 
the TeleVantage Server PC.

As a prerequisite, the user’s PC must be able to see the TeleVantage Server in Network 
Neighborhood. Also, the buffer share on the TeleVantage Server must be accessible. Verify that 
it is accessible by attempting to open the buffer share in Network Neighborhood.

Configuring TeleVantage for use with a proxy server 
If you use a proxy server (MS Proxy Server 2.0 or later) to access the Internet from a local area 
network, you must configure your network in one of the ways described in this section. If you 
do not configure your network appropriately, Windows NT 4.0 and Windows 2000 PCs that also 
use the proxy server will be unable to run TeleVantage workstation applications (such as the 
Client or Administrator) correctly.

If you do not use a proxy server, go to “Configuring e-mail notification support” on page 11-15.

Configuration options
Configure your network in one of the following ways:

Q Make sure that local IP traffic does not go through the proxy server (by means of local 
address translation tables).

Q For each Windows NT or 2000 PC running a TeleVantage workstation application, 
change the protocol for client-server configuration to TCP (from the default UDP). 
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To change the protocol to TCP on a Windows PC

1. Choose Start > Run.

2. Enter dcomcnfg.exe in the Open field. The Distributed COM Configuration 
Properties dialog box opens.

3. If Connection-oriented TCP/IP is not at the top of the DCOM Protocols list, select it 
and click Move Up until it is the first protocol in the list.

4. Click OK.

5. Restart the PC.

6. Repeat steps 1-4 for each PC running a TeleVantage workstation application.

Configuring e-mail notification support
If your users want to receive e-mail notification of voice mail messages, you must configure 
your TeleVantage Server and possibly your network, as follows:

Q If you are using Microsoft Exchange for your post office, the TeleVantage e-mail user 
(user account) must be a domain user, see Appendix E, “Changing the Domain of the 
TeleVantage Server” for more information.

Q If you are using TeleVantage on a non-Microsoft network such as NetWare, you may 
have to install the network client for that network on the TeleVantage Server PC to 
establish communications between Windows NT/2000 and the post office.

See “Requirements for e-mail notification of voice messages” on page 3-19 for more 
information.
CHAPTER 11. INSTALLING THE TELEVANTAGE SERVER 11-15



To configure e-mail notification support on the TeleVantage Server

1. If necessary, create an e-mail user for the TeleVantage Server. Doing this is not 
necessary on UNIX sendmail Servers, but is required for Exchange, Notes, and many 
other e-mail systems.

Use the tools provided with your e-mail post office (see the documentation from the 
manufacturer) to create a mail user for the TeleVantage Server. The name you give this 
mail user appears on all voice mail notification messages, so you should use a name 
that indicates the purpose of the message, for example, TeleVantage or 
VoiceMailReceived.

2. Install and configure a MAPI-compatible e-mail client for the TeleVantage user, such 
as Microsoft Outlook or Lotus Notes. Follow the instructions in the documentation for 
the particular application you are configuring. If you are installing Microsoft Outlook 
for Microsoft Exchange, select the Corporate or Workgroup option during 
installation and configuration.

Important: If you are using e-mail notification with Microsoft Outlook, install Outlook 
with full MAPI support. See “E-mail notification through Microsoft Outlook does not work 
if Outlook is installed in Internet Only mode” on page D-17.

3. Configure the default MAPI profile for the TeleVantage user, as follows.

Q On the TeleVantage Server PC, log on using the account that you use to run 
TeleVantage. This is the same account that you provided during the installation of 
the TeleVantage Server.

Q Click Start > Settings > Control Panel, and double-click the Mail icon. 

Q Click Add to start the wizard. Follow the Setup wizard directions to configure a 
MAPI profile. This MAPI profile must be the default profile for the user. 

4. Set the default MAPI profile as follows:

Q Double-click the Mail icon from Control Panel, and then click Show Profiles. 

Q From the When starting Microsoft Outlook, use this profile drop-down list, select 
the MAPI profile that you just configured. 

Q Click Close.

5. In the TeleVantage Administrator, choose Tools > System Settings, and then click 
the Other tab.

6. Select the Server is configured to send e-mail notifications checkbox. Click OK to 
save your change.

E-mail notification of voice messages will be available the next time the TeleVantage Server PC 
is started. E-mail notifications will be sent to any user who is set up to receive them. 
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There are two ways to set up individual users to receive e-mail notifications:

Q In the TeleVantage Administrator, edit the user in the Users view, then click the 
Notifications tab. See Administering TeleVantage for more information.

Q In the TeleVantage Client, users can set up e-mail notification of voice messages 
themselves by choosing Tools > Options, and then clicking the Notification tab. See 
Using TeleVantage for more information.

Using Lotus Notes for e-mail notification 
To use Lotus Notes with TeleVantage, you must perform the following tasks:

Q Install Windows Messaging.

Q Enable automatic emptying of the Notes Sent folders of TeleVantage users.

Q Enter a password for Notes e-mail notification.

Installing Windows Messaging
Windows Messaging for Windows NT is an optional component that is available on the 
Windows NT 4.0 Server CD. It may be installed by default when you installed your Windows 
NT 4.0 Server, or you can install it at a later time.

Windows Messaging for Windows 2000 is available only in Microsoft Outlook 2000. To use 
Lotus Notes with TeleVantage in a Windows 2000 environment, you must install Outlook 2000.

Enabling automatic emptying of the Notes Sent folders of TeleVantage 
users 
TeleVantage systems that use e-mail notification with Lotus Notes must add a Windows registry 
setting that enables automatic emptying of the Notes Sent folder. This setting fixes a Lotus 
Notes MAPI version 5.0.2 or earlier problem that causes the Notes Sent folder of TeleVantage 
users to fill up with old e-mail notifications. 

The following Windows registry setting must be added and set to a value of 1:

HKEY_LOCAL_MACHINE\Software\Artisoft\TeleVantage\Server
\Settings\EmptySentItemsFolder

To add the Windows registry setting

1. Click Start > Run, type Regedit, and then click OK.

2. Navigate to the Settings key.

3. Click Edit > New > DWORD value.

4. Type EmptySentItemsFolder as the name of the value. Make sure you spell it exactly 
as shown.
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5. Double-click the value icon to open the Edit dialog box.

6. Set Value Data to 1 and click OK.

7. Exit Regedit.

Entering a password for Notes e-mail notification
The TvNotes.dll file provides the password for e-mail notification to Notes programmatically. 
If the Notes password is not provided by the TvNotes.dll, Notes will prompt individual users 
for the password at startup. If the password is not provided, e-mail notification will be disabled 
until the password is provided, either manually or programmatically.

TvNotes.dll is provided on the TeleVantage CD, but is not installed automatically. 

To install TvNotes.dll

1. Make sure Notes is not running.

2. Copy TvNotes.dll and TvNotes.pdb from the \lotus directory on the TeleVantage 
Master CD to the Notes executable directory.

3. Edit the notes.ini file on the TeleVantage Server. The default location for this file 
is C:\WinNT for Notes R4 or C:\Lotus\Notes for Notes R5.

4. Add the following line to the notes.ini file:

EXTMGR_ADDINS=TvNotes.dll

5. Create a string value NotesPwd in the following Windows registry key:

HKEY_LOCAL_MACHINE\Software\Artisoft\TeleVantage\Server\
Settings

6. Enter your Notes password as the NotesPwd registry value.

Communicating with a TeleVantage 3.x Server using an IP 
Gateway connection

Important: The information in this section applies only if you are upgrading an existing 
TeleVantage Server that needs to communicate with a TeleVantage 3.x Server using an IP 
Gateway connection.

If your current Server upgrade plan requires that a TeleVantage 5.x Server must connect over 
an IP Gateway connection to a TeleVantage 3.x Server, then you need to do the following on 
the TeleVantage 3.x Server before the TeleVantage 5 Server will be able to communicate with it.

1. Create an Artisoft ObjID.

2. Edit the following Windows registry key on the TeleVantage 3.x Server using 
Regedit.exe:

HKLM\Software\Artisoft\TeleVantage\Server\Settings\
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3. Right-click the setting and choose New > String Value. Create the following string 
value: 

”GatewayMakeCallObjID”=”2 16 840 1 114123 10 10”

4. Restart the TeleVantage 3.x Server.

This allows the TeleVantage 3.x Server to communicate using gateway calls with a TeleVantage 
5 Server.

Note: If at a later time you upgrade a Server that has this Windows registry key to TeleVantage 
5, you must remove the key in order for the upgraded TeleVantage 5 Server to communicate with 
other TeleVantage 5 Servers.

Where to go next_______________________________________
When you have successfully installed the TeleVantage Server and the Administrator on the 
TeleVantage Server PC, go to Chapter 12.
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Introduction _____________________________________________
The TeleVantage workstation applications are a set of programs that can optionally be installed 
on other PCs. The workstation applications connect with the TeleVantage Server remotely over 
your network. With these applications, users can take full advantage of how TeleVantage 
integrates the PC and the phone. The following TeleVantage components are the workstation 
applications:

Q The TeleVantage Client

Q The TeleVantage Administrator

Q The TeleVantage TAPI Service Provider

Q The TeleVantage Contact Manager Assistant

Note: You installed the TeleVantage Administrator on the TeleVantage Server PC according to 
the instructions in Chapter 11. Before installing the Administrator on other PCs in the network, see 
“About installing the TeleVantage Administrator” on page 12-4.

Requirements
Important: In order to install any of the TeleVantage workstation applications on a PC, you 
must be logged on as a user with Administrator rights.

You can install the TeleVantage workstation applications on any Windows PC on the network, 
including the TeleVantage Server, that meets the requirements described in Chapter 3.

Q For Administrator and Client PC requirements, see page 3-22. 

Q For TAPI SP and Contact Manager Assistant PC requirements, see page 3-23.

Important: TeleVantage requires Internet Explorer 5.0 or later. If you are installing any of the 
workstation applications on a PC with Internet Explorer version 4.x, upgrade to Internet Explorer 
5.0 or higher before running the TeleVantage Workstation Setup as described in this chapter. 
Although Internet Explorer 5.5 is provided on the TeleVantage Master CD, it should not be 
installed on top of Internet Explorer 4.x.

Microsoft Terminal Server support 
You can install the workstation applications on a Microsoft Terminal Server. For instructions, 
see Appendix C.

Installation checklist
Use the following checklist as you install and configure the TeleVantage workstation 
applications.

Q Windows 98 systems. Download DCOM 98 onto your TeleVantage Server so that 
TeleVantage workstation applications can be installed on Windows 98 systems.

Q Install the TeleVantage Administrator on the PCs of users who need to administer the 
TeleVantage Server, queues, auto attendants, and so forth. You can limit each user’s 
administrator privileges as described in Administering TeleVantage.
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Q Install the TeleVantage Client on the PCs of users who will manage their calls and voice 
messages from their desktop.

Q Install the TeleVantage TAPI Service Provider on the PCs of users who will run the 
Contact Manager Assistant or want to use some other TAPI-compliant application to 
place calls using TeleVantage. 

Q Install the TeleVantage Contact Manager Assistant on the PCs of users of Microsoft 
Outlook, GoldMine, GoldMine FrontOffice, or GoldMine Business Contact Manager 
will receive screen pop notification of incoming calls.

Q Synchronize system clocks. This step ensures that message time stamps set by the Server 
clock match the time on the PCs of users.

Downloading DCOM 98 onto your TeleVantage Server __________
If your network does not have any Windows 98 PCs that need to run one or more of the 
TeleVantage workstation applications, go to the next section. Otherwise, install Microsoft 
DCOM 98 on each Windows 98 PC.

Because Microsoft does not allow other companies to redistribute DCOM 98, you must 
download it yourself according to the following instructions.

Once downloaded onto the TeleVantage Server PC, DCOM 98 is automatically installed as 
needed when you install one or more TeleVantage workstation applications on a Windows 98 
PC.

Note: If you first run the Workstation Setup and attempt to install the Client or Administrator 
workstation application on a Windows 98 SE PC without a previous version of TeleVantage 
installed or DCOM 98 installed, you will receive an MDAC installation error. If this happens, see 
“TeleVantage Client and Administrator fail to install on Windows 98 SE if DCOM 98 is not 
previously installed” on page D-16.: 

To download DCOM 98

1. Download DCOM 98 from the following location:

http://www.microsoft.com/com/dcom/dcom98/dcom1_3.asp. 

2. Click the DCOM98 1.3 link and follow the on-screen instructions.

3. In the File Download dialog box, click Save this program to disk. 

4. Save the downloaded file (dcom98.exe) to the following location:

C:\Program Files\TeleVantage Server\NetSetup\DCOM98 
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Installing the TeleVantage workstation applications_____________

About installing the TeleVantage Administrator
You can install the TeleVantage Administrator on any Windows PC on the network that meets 
the requirements described in “Administrator and Client requirements” on page 3-22. 

If you install more than one TeleVantage Administrator, you must coordinate work among the 
users who have authority to run the Administrator.

Important: If two people make changes to the same data, only the changes that are saved last 
are retained. 

For information about setting up TeleVantage users with administrative privileges, see 
Administering TeleVantage.

About installing the TeleVantage Client
The TeleVantage Client is the most efficient way to use TeleVantage, and some TeleVantage 
features are available only through the Client. However, the Client is not required in order to 
make and receive calls, and most TeleVantage features can be accessed without it by using the 
telephone commands. See Using TeleVantage for a list of Client-only features. 

You can install the Client on any Windows PC on the network that meets the requirements 
described in “Administrator and Client requirements” on page 3-22. See “TeleVantage license 
requirements” on page 3-20 for information about Client license requirements.

The TeleVantage Call Center and Call Center Reporter are installed automatically with the 
Client. See “TeleVantage license requirements” on page 3-20 for information about required 
Call Center Agent and Call Center Reporter licenses.

About installing the TeleVantage TAPI Service Provider
In addition to the PC requirements described on page 3-23, a user must have the following to 
install and use the TAPI Service Provider:

Q A TeleVantage user name and station ID. You cannot use station ID 0.

Q A Windows telephony location that allows the user to place calls. Typically, you need 
to configure your area code and external dialing prefix, for example “9”. 

Performing unattended installs
For information on installing the TeleVantage workstation applications without user input, see 
Appendix G.

Using the TeleVantage Workstation Setup
The TeleVantage Workstation Setup can install any or all of the workstation applications. On 
all PCs except the TeleVantage Server, if an older version of the TeleVantage Administrator or 
Client is installed, Workstation Setup will automatically run when you start the Administrator 
or Client.
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If you have upgraded your TeleVantage Server from a previous version, any user who attempts 
to run the old versions of the TeleVantage Client or Administrator receives a message saying 
that new versions need to be installed. All workstation applications detected on the PC will be 
upgraded. However, this message does not appear and the upgrade does not take place if the user 
only has TAPI Service Provider or Contact Manager Assistant installed. If you are upgrading 
and have users who only use those applications, you should notify them that they need to install 
the new software as described later in this chapter. 

If you encounter problems installing the TeleVantage workstation applications, or running them 
after installation, see “Troubleshooting Client/Administrator installation problems” on 
page D-15.

To install the TeleVantage workstation applications

1. Review the “Client/Administrator installation tips” on page D-15.

1. Log on to the PC on which the workstation applications will be installed as a user with 
administrator privileges. 

2. Close all open Windows applications.

3. Start the TeleVantage Workstation Setup by running setup.exe, located in the 
Netsetup directory on the TeleVantage Server. The default location is:

\\<TeleVantage Servername>\Netsetup\setup.exe

4. When Workstation Setup starts, follow the on-screen instructions. If you cannot run 
the Workstation Setup, see “‘Corrupt installation’ dialog box” on page D-15.

5. Review the License Agreement. Click I accept the terms in this license agreement, 
and then click Next to continue.

6. In the Customer Information dialog box, enter the User Name associated with this PC 
and Organization. If you want only this user to be able to run the workstation 
applications from this PC, select Only for me. Click Next to continue.

7. In the TeleVantage Server Information dialog box, enter the TeleVantage Server 
Name and the Telephone Station ID of the phone that will be used by the person at 
this PC. 

The station ID corresponds to the port number on the station board to which the phone 
is connected. To hear your station ID, pick up the phone and dial *0. 

Note: If there is not a TeleVantage phone near this PC, enter a station ID of 0. Without 
a phone, the user at this PC will be able to perform all functions with the exception of 
managing calls and recording voice prompts. If you enter a station ID of 0, when you 
click Next the No Telephone Station ID Specified dialog box opens to make sure that 
you understand this limitation, and gives you the opportunity to go back and enter a valid 
station ID.

Click Next to continue.
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8. In the Setup Type dialog box, select one of the following:

Q Select Typical to install the listed workstation applications in the default 
location.When installing TeleVantage for the first time, the Client and 
Administrator are installed. When upgrading from a previous version of 
TeleVantage, Workstation Setup detects the workstation applications that are 
installed, and upgrades those applications to the current version. 

Click Next to continue. Go to step 10.

Q Select Custom to choose which workstation applications to install, or to change the 
installation drive or folder.

Click Next to continue.

9. In the Custom Setup screen, you can do any of the following:

Q Click a workstation application to see a description of it as well as the amount of 
disk space it requires.

Q Click Space to check the available space on each hard drive on the PC.

Q Click Change to change the destination drive or folder where the selected 
workstation application will be installed. You can specify a different location for 
each workstation application.

Q If you do not want to install one of the listed workstation applications on this PC, 
click the drop-down list for the application and then select This feature will not be 
available. 

Q To install another listed workstation application, click the drop-down list for the 
application and then select This feature will be installed on local hard drive.

Click Next to continue.

10. In the Ready to Install screen, click Install. Installation may take several minutes.

11. When Workstation Setup finishes copying files, if you are installing the TAPI Service 
Provider, the TAPI Service Provider Configuration Wizard is displayed. 
12-6 INSTALLING TELEVANTAGE



Q Enter the name of the TeleVantage Server PC and the Station ID of the phone that 
will be used by the person at this PC. 

The station ID corresponds to the port number on the station board to which the 
phone is connected. To hear the station ID, pick up the phone and dial *0. If there is 
not a TeleVantage phone near this PC, enter a station ID of 0. Click Next to 
continue.

Q Select the User Name of the person assigned to this station ID from the drop-down 
list, and enter the user’s Password. Click Finish to continue.

Q If you are installing the TAPI Service Provider for the first time, Workstation Setup 
prompts you to define a Windows telephony dialing location for your PC, which is 
required to place outbound calls. If you see this prompt, click OK.

In the Location Information dialog box, select your country from the drop-down 
list, enter your area code, and enter the number you must dial to get an outside line, 
for example “9”. Click OK.

In the Phone and Modem Options dialog box, select the location from which you 
are dialing, and click OK.

12. In the Install Completed screen, select the Show What’s New checkbox to see a 
complete listing of the new features available in this version of TeleVantage. Click 
Finish to complete the installation.

Configuring the TeleVantage workstation applications__________

Configuring the TeleVantage Administrator and Client
For information about customizing and using the TeleVantage Administrator, see Administering 
TeleVantage.

For information about customizing and using the TeleVantage Client, see Using TeleVantage.
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Configuring the TeleVantage TAPI Service Provider 
Workstation Setup runs the TAPI Service Provider Configuration wizard automatically when 
you install the TAPI Service Provider for the first time on a PC. You can run the Configuration 
Wizard later, for example to change your station ID. To do so:

1. Click Start > Programs > Artisoft TeleVantage > TeleVantage TAPI Service 
Provider Configuration Wizard.

2. Follow the on-screen instructions. Click Help for more information.

Configuring your contact manager for use with 
the TAPI Service Provider
Before making calls from the contact manager, you must configure it to recognize the TAPI 
Service Provider. Use one or more of the following procedures as needed.

To configure Outlook 

1. Open the Contacts view in Outlook.

2. Choose Actions > Call Contact > New Call.

3. In the New Call dialog box, click Dialing Options.

4. In the Dialing Options dialog box, verify that Connect Using Line is set to 
“TeleVantage Line 1.” This option is available after the TAPI Service Provider is 
installed. 

5. Click OK.

To configure GoldMine, GoldMine FrontOffice, or GoldMine Business Contact 
Manager

Use the following procedure after you refer to the documentation that came with the product:

1. Choose Edit > Preferences.

2. Click the Modem tab.

3. Under Modem Settings, verify that TAPI Line is set to “TeleVantage Line 1.” This 
option is available after the TAPI Service Provider is installed.

4. Click OK.

To configure Act! 

1. In Act!, Choose Edit > Preferences.

2. Click the Dialer tab.

3. Select the Use Dialer checkbox.

4. Under Modem or Line, verify that “TeleVantage Line 1” is selected. This option is 
available after the TAPI Service Provider is installed.
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5. To receive screen pops with contact information when a contact calls, select the 
Lookup contact using caller ID checkbox. Deselect the checkbox if you do not want 
to receive screen pops.

6. Click OK.

Calling from another application 
After installing the TAPI Service Provider, users can call contacts by using the instructions 
provided with their contact managers. Calls appear in their Call Logs as if they had dialed them 
from the Client or phone.

Configuring the TeleVantage Contact Manager Assistant 
1. If the Contact Manager Assistant is not running, start it by clicking 

Start > Programs > Artisoft TeleVantage > TeleVantage Contact Manager 
Assistant. 

2. If only the Contact Manager Assistant splash screen appears, right-click the Outlook, 
GoldMine, GoldMine FrontOffice, or GoldMine Business Contact Manager icon on 
the system tray at the lower right of your screen. Select Setup.

3. Click Help for detailed instructions.

Synchronizing system clocks ______________________________
It is recommended that you make sure that the system clocks on the TeleVantage Server PC and 
user PCs are synchronized. This ensures that message time stamps, which are set by the Server 
clock, agree with the time displayed on the user PCs.

In Microsoft domain-based networks, you can synchronize the workstation clock with the 
TeleVantage Server clock by including the following statement in the logon script that executes 
when the workstation connects to the domain controller:

net time \\<TeleVantageServerName> /set /yes

Where to go next_______________________________________
When you have installed the TeleVantage workstation applications, go to Chapter 13 if you 
want to support the Web Client.
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Introduction _____________________________________________
TeleVantage Web Services is the TeleVantage component that allows you to offer users the 
TeleVantage Web Client. 

The Web Client is a version of the TeleVantage Client that users access by using their Web 
browsers. Because the Web Client is HTML-based, users can access it from non-Windows 
platforms such as Macintosh and UNIX. The Web Client gives users access to most 
TeleVantage features. For information about using the Web Client, see Using TeleVantage and 
the Web Client online Help.

Requirements
For your system to offer the Web Client, you must install the following on a PC that will become 
your Web server:

Q Microsoft Internet Information Server (IIS) 4.0 or higher. IIS is installed automatically 
with Windows 2000.

Q TeleVantage Web Services

You can install TeleVantage Web Services on the same PC as the TeleVantage Server if you 
plan to use the Microsoft Internet Information Server to support a small number of simultaneous 
connections for TeleVantage purposes only. However, if you plan to use the TeleVantage Web 
Services to support many TeleVantage users or for other high-volume Web-related activity, it is 
recommended that you install it on a separate networked PC from the TeleVantage Server.

For a complete list of requirements for the Web server PC, see “Web Services requirements” on 
page 3-23.

Important: Versions of Internet Explorer with security patches may not be able to connect to a 
TeleVantage Server that contains an underscore in its name. This behavior was introduced by 
Microsoft to improve security. There are two workarounds—rename the Server, or use the 
Server's IP address in place of its name when you run the Web Client. For more information, go 
to http://support.microsoft.com and search the Knowledge Base for article #Q321232.

Installing Microsoft Internet Information Server ________________
IIS is installed automatically with Windows 2000 Server. If your Web server is a Windows 2000 
Server PC, go to “Installing TeleVantage Web Services” on page 13-3.

If your Web server is a Windows NT 4.0 Server PC, install the Windows NT 4.0 Option Pack, 
which includes IIS. You can download the latest version from Microsoft using the instructions 
on page 13-3. Your copy of Windows NT 4.0 Server may also contain the Windows NT 4.0 
Option Pack. 

Note: IIS requires Windows Internet Explorer 4.01 or later. If you need to upgrade, Internet 
Explorer 5.5 is included on the TeleVantage CD. See page 13-3 for instructions.
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To install Internet Explorer 5.5 from the TeleVantage CD

1. Insert the TeleVantage CD. 

2. Click Start > Run. Type the following and then click OK:

TeleVantage Server\NetSetup\IE5\IE5Setup.exe

3. Follow the on-screen instructions to complete the installation.

To install Microsoft IIS on a Windows NT 4.0 server

1. Download the Windows NT 4.0 Option Pack from the following location:

http://www.microsoft.com/ntworkstation/downloads/

You may be asked to fill out a form with customer information before you can 
download the software.

2. Run the file to install the option pack. Choose the Typical installation. Follow the 
on-screen instructions to complete the installation.

3. If you are prompted to restart your PC, do so.

Installing TeleVantage Web Services_________________________
1. Close all applications running on the Web server.

If you are installing Web Services on the TeleVantage Server PC, shut down the 
TeleVantage Server and Dialogic System Service. You do not need to close your 
database server. 

2. Insert the TeleVantage Master CD. The Master Setup program starts. If the Master CD 
is already inserted, start Master Setup program by running autorun.exe from the root 
directory on the Master CD. For information about the Master Setup, see page 6-2.

3. Click TeleVantage Web Services.

4. Follow the on-screen instructions.
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5. In the Setup Complete dialog box, click OK to complete the installation. 

6. Restart the TeleVantage Server and Dialogic System Service.

TeleVantage Web Services starts automatically after installation and whenever the Web server 
is restarted.

Running the Web Client____________________________________
After TeleVantage Web Services is installed, you can run the Web Client from any Web browser 
by entering the following URL. 

http://<Webserver>/TeleVantage

Replace <Webserver> with the name of the PC running the TeleVantage Web Services or with 
its IP address, as in the following examples:

http://TeleVantage/TeleVantage

http://124.64.77.68/TeleVantage

If you get “The page cannot be displayed” messages while running the Web Client, see “Web 
Services installer seems to complete without requiring a reboot, but a reboot is required to 
finish” on page D-17.

Where to go next ______________________________________
When you have successfully installed TeleVantage Web Services, go to Chapter 14.
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Your TeleVantage system so far _____________________________
You should have already completed the following tasks:

Q Installed the Windows Server

Q Installed Dialogic hardware, the Dialogic System Release 5.1.1, SP1, and Driver 
Updates

Q Installed and configured the TeleVantage database server

Q Installed the TeleVantage Server

Q Added and activated your TeleVantage licenses

Q Installed the TeleVantage workstation applications (optional)

Q Installed TeleVantage Web Services on the TeleVantage Server to support the 
TeleVantage Web Client (optional)

Note: Be sure you have finished all of the tasks before you proceed.

After upgrading from TeleVantage 2.1 or earlier ________________
If you upgraded from TeleVantage 2.1 or earlier, you can uninstall Microsoft SQL Server 6.5 at 
any time after you complete the database server installation described in Chapter 10. If you 
upgraded from TeleVantage 3.0 or higher, or if you installed TeleVantage for the first time, you 
do not need to uninstall SQL Server.

Note: Your Microsoft SQL Server 6.5 database was upgraded to an MSDE database when you 
upgraded. Do not uninstall the Microsoft SQL Server 6.5 database until you are satisfied that the 
upgraded TeleVantage system is working properly. At that time, you can uninstall Microsoft SQL 
Server 6.5. 

Uninstalling Microsoft SQL Server 6.5 frees about 300 MB of disk space. The process does not 
affect your new database server in any way.

To uninstall SQL Server 6.5

1. Shut down the TeleVantage Server and the Device Monitor if they are running.

2. Stop the MSDE server using the Windows Control Panel.

3. Choose Start > Programs > Microsoft SQL Server Switch > Microsoft SQL Server 
6.5.

4. Insert the TeleVantage 2.1 CD. Exit the autorun program if it starts.

5. Start the setup program which is located in the i386 directory 
(\mssql\i386\setup.exe).

6. Click Continue in the Welcome and the SQL Server Already Installed dialog boxes.

7. Select Remove SQL Server when the Microsoft SQL Server 6.5 Options dialog box 
opens.
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8. Select Remove files from C:\MSSQL\ when the next dialog box opens.

9. Click Resume to uninstall SQL 6.5 from the PC.

10. Choose Start > Programs > Microsoft SQL Server Switch > Microsoft SQL Server 
7.0 to switch to MSDE 7.0.

Note: The following prompt may appear in a message box: “The MSSQL Server 
Service did not exist, so it has been re-created. Please use the open services control 
panel to set any user options (such as logon and startup type)”. Click OK if you see this 
message.

11. Choose Start > Programs > MSDE > Service Manager, and verify that the MSSQL 
Server Service has “Auto start service when OS starts” selected.

12. Click Start/Continue. Microsoft SQL 6.5 has been completely removed from the PC.

If you want to change the TeleVantage Server PC domain, see Appendix E, “Changing the 
Domain of the TeleVantage Server.” 

Setting up and configuring your TeleVantage system___________
After you install the TeleVantage components according to the instructions in this manual, you 
must set up and configure your system using the TeleVantage Administrator. 

See Administering TeleVantage and the TeleVantage Administrator online Help. 
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APPENDIX A

APPENDIX A

VOICE RESOURCE USAGE IN 
TELEVANTAGE

You need to be aware of the number of voice resources that your system requires to support its voice 
processing and dial tone needs. This is especially important for large or international TeleVantage 
installations. 

TeleVantage uses one voice resource in each of the following situations:

Q When playing or recording a voice file over the telephone, including playing a telephone 
command prompt to a user or caller, and when a user plays or records a voice message, 
greeting, voice title, auto attendant greeting, and so forth. Audio files played over PC 
speakers do not use voice resources.

Q While playing a tone, such as the dial tone or callback, or while collecting digits from the 
user.

Q For the half-second it takes to send Caller ID or message-waiting information to a CLASS 
phone: 

Q For Caller ID, this event occurs once per call. 

Q For message waiting information, it occurs when the message waiting indicator needs to 
be lit and again when it needs to be unlit (a blinking light is considered lit). Note that 
this can result in up to half of your voice resources being used at once at Server startup 
if many users have received new voice messages. See “Conserving voice resources” on 
page A-2 for information on how to ensure that adequate voice resources are reserved 
for other purposes.

Q For ADSI phones, when performing voice-first answering, paging or intercom. Note that 
paging multiple phones can result in up to half of your voice resources being used at once. 
See “Conserving voice resources” on page A-2 for information on how to ensure that 
adequate voice resources are reserved for other purposes.

Q When a user is logged in remotely from a trunk, for the duration of the call, so that the remote 
user can press ** to access the Hold menu, instead of pressing Flash.

Q If the Keys are only active while prompts are playing checkbox (on the Hold tab of the 
Queue dialog box) is not selected, when a caller to a call center queue is waiting on hold, so 
that the caller can press a key to leave a message or transfer out while listening to music on 
hold. You can opt to not use a voice resource in this case by choosing when the queue offers 
special-key options to callers. See TeleVantage Call Center Administrator’s Guide.



Q If you are using system call recording to record all system calls. System call recording 
requires one additional voice resource for each call occurring in the TeleVantage system 
at any given time, including internal (station to station) calls, if configured that way. 
Calls that you have exempted from system call recording do not require the additional 
voice resource. See “Conserving voice resources” on page A-2 for information on how 
to ensure that adequate voice resources are reserved for other purposes.

Q E1 CAS trunks require a dedicated voice resource at all times.

Dedicated vs. shareable voice resources
Intel Dialogic telephony boards come with both dedicated and shareable voice resources:

Q A dedicated voice resource is associated with a trunk.

Q A shareable voice resource can be used by TeleVantage as needed for a station or trunk.

See “Voice resources by Intel Dialogic board” on page A-4 for a listing of dedicated and 
shareable voice resources by board.

Note: Analog trunk boards have dedicated voice resources. If a channel on an analog trunk 
board is not connected to your phone company, or is disabled in the Windows registry, its 
dedicated voice resources become shareable. 

See “Disabling Dialogic devices” in Appendix A of Administering TeleVantage for instructions 
on how to disable channels on an analog trunk board in the Windows registry.

Maximum possible voice resource use _______________________
TeleVantage needs enough voice resources to handle the peak expected voice resource load on 
the system. 

The theoretical maximum peak load with system call recording turned off is all trunks and all 
stations each requiring 1 voice resource at the same time. For example, on an 8-trunk by 
8-station system, the maximum number of voice resources required is 16, which is the amount 
provided by a D/160SC-8LS board. With system call recording turned on, there are 8 possible 
calls, so the number of voice resources required increases to 24, requiring an additional voice 
resource board.

However, actual peak loads are much less. In most situations, a D/160SC-8LS board (8 trunks) 
can support up to 16 stations.

Conserving voice resources
As described above, some situations—using system call recording to record all calls, sending 
message-waiting information to CLASS phones, and paging to ADSI phones—can consume 
many voice resources. TeleVantage can be tuned to conserve some voice resources for other 
purposes, to ensure that users can get dial tone and answer calls. See the Advanced 
Configuration Settings chapter in Administering TeleVantage for more information.
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Identifying if you need more voice resources
If all trunks are busy using voice resources (for example, leaving voice mail), and a user picks 
up a station, the user will not get a dial tone, and a voice resource error will be written to the 
Windows Event Log on the TeleVantage Server. These errors can be e-mailed to you if you 
configure TeleVantage system settings appropriately in the Administrator. If this problem 
happens, the remedy is to add more voice resources to your system.

Important: BRI trunk boards (with the exception of the BRI/2VFD board) supply no voice 
resources. Therefore, you must install extra voice resources if you want to use BRI boards with 
TeleVantage. Extra voice resources are also recommended with the D/41ESC analog trunk 
board.

Gaining extra voice resources______________________________
Administrators of large or international TeleVantage installations should analyze usage patterns 
of callers and users before determining voice resource requirements. Depending on call usage, 
the number of voice resources required can vary wildly.

To obtain additional voice resources to support the needs of your system, you can do the 
following:

Q Add a voice resource-only board such as a D/80SC or D/240SC board.

Q Add a regular D/41ESC or other analog board as a resource-only board, or do not attach 
trunks to several of the trunk ports on the board. The dedicated voice resources for 
unattached trunks can be used by TeleVantage as shared resources.

Q Add a dual T1 or E1 card, and do not connect the second channel to trunks. Doing this 
frees the 24 or 30 voice resources for shareable use.

Note: If you are using E1 CAS on an E1 trunk board and want to dedicate some of its voice 
resources to stations, you must reserve the Dialogic devices on the E1 board as described in 
Administering TeleVantage. If you do not reserve the Dialogic devices, TeleVantage will dedicate 
those voice resources to the E1 trunks.

Configuring the D/41ESC board for trunk or 
voice resource use 
When configuring a D/41ESC board, set the board as follows:

Q Frontend. If you will be plugging trunks into the board.

Q Route resource to SC bus. If you will be using the board just for the voice resources.
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Voice resources by Intel Dialogic board ______________________
Dialogic boards that provide voice resources to TeleVantage are listed in the following table. 
See page A-2 for an explanation of the difference between dedicated and shareable voice 
resources.

Model number Board type Dedicated 
voice resources

Shareable
 voice resources

D/80SC-4LS Analog trunk 4 4

D/160SC-8LS Analog trunk 8 8

D/160SC-LS Analog trunk 16 0

D/41ESC Analog trunk 4 0

D/41ESC-Euro Analog trunk 4 0

D/41EPCI Analog trunk 4 0

D/41JCT-LS Analog trunk 4 0

D/120JCT-LS Analog trunk 12
See Note below.

0

D/240SC-T1 T1 trunk 0 24

D/240PCI-T1 T1 trunk 0 24

D/240JCT-T1 T1 trunk 0 24

D/480SC-2T1 T1 trunk 0 48

D/480JCT-2T1 T1 trunk 0 48

D/300SC-E1 E1 trunk 0 30

D/300PCI-E1 E1 trunk 0 30

D/300JCT-E1 E1 trunk 0 30

D/600SC-2E1 E1 trunk 0 60

D/600JCT-2E1 E1 trunk 0 60

BRI/2VFD ISDN BRI trunk 0 4

D/80SC
Dedicated voice 
resource

0 8

D/160SC
Dedicated voice 
resource

0 16

D/240SC
Dedicated voice 
resource

0 24
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Note: The D/120JCT-LS analog trunk is not typically configured for 12 dedicated voice 
resources. Rather, 4 of the channels are unplugged so that they become shareable resources 
that can be used for station activity.

D/320SC
Dedicated voice 
resource

0 32

D/80-PCI
Dedicated voice 
resource

0 8

D/320-PCI
Dedicated voice 
resource

0 32

D/160-JCT
Dedicated voice 
resource

0 16

D/320-JCT
Dedicated voice 
resource

0 32

Model number Board type Dedicated 
voice resources

Shareable
 voice resources
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APPENDIX B 

CONFIGURING ISDN PARAMETERS

Some sites may need to modify the ISDN parameters used for outgoing calls so that their ISDN 
trunks will work with TeleVantage. 

To determine if you have a problem, do the following:

Q Install TeleVantage according to the instructions in this manual. See “Configuring ISDN PRI 
T1 and ISDN PRI E1 trunk boards” on page 9-16 and “Configuring ISDN BRI trunk boards” 
on page 9-18. Also, see Administering TeleVantage for information on adding an ISDN span 
using the TeleVantage Administrator. 

Q Try placing calls on the ISDN line using TeleVantage. If calls from TeleVantage work, there 
is no need to troubleshoot your line or modify any ISDN parameters. 

If you cannot place calls successfully, follow the instructions in this Appendix to use the following 
two Dialogic troubleshooting utilities to place calls and diagnose problems on your ISDN line. Both 
utilities are included on the TeleVantage Drivers CD:

Q The Dialogic Makecall Utility (DMU)

Q The Dialogic ISDIAG utility

To troubleshoot problems on your ISDN line 

1. Ask your ISDN carrier for the optimal protocol values for your line. Enter them into the 
Windows registry as described in “Changing TeleVantage ISDN protocol parameters” on 
page B-4.

2. If calls from TeleVantage still fail, use the DMU to determine the protocol values for your 
line. See the next section, “Using the Dialogic Makecall Utility.” 

3. If calls from the DMU fail, use ISDIAG to determine why the Dialogic board cannot 
communicate with your ISDN line. See “Using ISDIAG” on page B-2.



Using the Dialogic Makecall Utility
The Dialogic Makecall Utility (DMU) is included on the TeleVantage CD in the 
Dialogic\Support\DMU directory. To run it, copy the entire DMU directory from the 
TeleVantage CD to your hard drive, and then run the file DMU.exe, which is in the DMU 
directory.

Important: The pathname for the DMU directory must not contain long file names. Copy the 
DMU directory to your local drive or another path containing only short file names.

For instructions on using the DMU, see its Help file, DMU.hlp, in the DMU directory.

Note: The DMU works best with only one ISDN board in the PC. If you have multiple ISDN 
boards installed, you may have problems running the DMU.

If you are able to make calls successfully using the DMU, you do not need to use ISDIAG. Enter 
the correct protocols in the Windows registry as described in “Changing TeleVantage ISDN 
protocol parameters” on page B-4.

Using ISDIAG 
Use ISDIAG only if you have already tried the DMU and are still unable to solve your ISDN 
line problems.

With ISDIAG you can place test calls on an ISDN line and generate a trace that provides 
valuable feedback to your carrier on the cause of failed calls.

Note: After running ISDIAG, be sure to shut down the Dialogic drivers and restart them before 
starting the TeleVantage Server. If you do not do this, the TeleVantage Server does not initialize 
the data channel at startup, which may cause unpredictable results.

To run ISDIAG

1. On the TeleVantage Server PC, open a command prompt window.

2. Go to the following directory:

C:\Program Files\Dialogic\BIN

Note: This is the default directory. If you specified a different directory for the Dialogic 
drivers when you installed them, go to that location instead.
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3. Enter ISDIAG. The syntax for launching ISDIAG appears, as shown in the next figure.

4. Enter ISDIAG followed by the appropriate codes. For example:

ISDIAG 1 1 t s v

Doing this launches ISDIAG to test the first channel on the first board, where the board 
is a T1 board on an SCbus connection, using the voice option. 

The menu shown in the next figure appears.
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For information about using the ISDIAG menu to test calls and generate trace 
information, see the following document on the Dialogic technical support website:

http://resource.intel.com/telecom/support/appnotes/isdn03.htm

Changing TeleVantage ISDN protocol parameters 
When you have determined the protocols that your ISDN line requires to make and receive calls, 
you can update TeleVantage with those protocols by using the TeleVantage Administrator.

Use the following procedure if you were able to determine the correct protocols when you used 
the DMU or if you want to change a particular parameter. For example, if you are using ISDN 
BRI trunks in North America or Japan, you need to change the Layer 1 protocol on bearer 
channel to G.711 uLaw (see “Changing bearer channel protocol to uLaw” on page 9-18.)

1. In the TeleVantage Administrator Trunks view, right-click a trunk in the ISDN span 
that you want to update and choose Open Span.

2. Click the Tuning tab.

3. Update the ISDN protocols in one of the following ways:

Q Automatically. If you were able to determine the correct protocols using the DMU, 
you can import all of those protocols at one time. Click Import, and then choose the 
file Outbound_mcb.txt from the DMU/Output directory.

Q Manually. To edit an individual protocol, click the cell for that protocol. Choose the 
new value from the drop-down list.

4. Click OK.
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APPENDIX C

USING TELEVANTAGE WITH
MICROSOFT TERMINAL SERVER
OR CITRIX METAFRAME

Using Microsoft Terminal Server or Citrix Metaframe with TeleVantage enables you to do the 
following:

Q Manage a TeleVantage Server remotely.

Q Run the TeleVantage Administrator or Client on a PC that does not meet the minimum 
requirements described in “Administrator and Client requirements” on page 3-22.

Q Centrally manage the installation and maintenance of the TeleVantage Administrator and 
Client workstation applications by installing them on an application server, instead of on 
individual users’ PCs.

Microsoft Terminal Server or Citrix Metaframe can be used in one of two modes, Application Server 
or Remote Administration. Both of these modes can be used with TeleVantage, as follows: 

Q Application Server. In this mode, remote PCs can be used as terminals for programs running 
in a multisession environment on an application server. For example, several users on remote 
PCs can start terminal sessions to run the TeleVantage Client. Each session starts a new 
instance of the Client, and all instances of the Client run simultaneously on the application 
server. No TeleVantage software is required on the remote PCs. 

Both the TeleVantage Administrator and TeleVantage Client are compatible with the 
multisession environment provided by Microsoft Terminal Server and Citrix metaFrame. See 
the next section for details. 

Note: The TeleVantage TAPI Service Provider and Contact Manager Assistant are not 
supported on Microsoft Terminal Server or Citrix MetaFrame.

Q Remote Administration. In this mode, you can use a remote PC to access a server over the 
network just as if you were sitting at the server console. Remote Administration can be used 
to perform upgrade and maintenance tasks remotely. For details, see “Using Terminal Server 
for remote administration” on page C-4.



Installing TeleVantage on an application server ________________
Bear the following considerations in mind when you set up an application server for 
TeleVantage:

Q The application server should not be the same PC as your TeleVantage Server PC. 

Q Applications should not be installed in the same partition as the Windows operating 
system. In most cases, Windows will be installed on your C: drive and applications will 
be installed on a D: drive. The D: drive can either be a separate hard disk or another 
partition on the same disk as the C: drive. 

Q Always use Add/Remove Programs (located on the Windows Control Panel) to install 
programs. This ensures that the programs are set up properly for multisession use. 

Note: The server must be in remote administration mode to remotely install any TeleVantage 
workstation applications. See “Using Terminal Server for remote administration” on page C-4.

Installing workstation applications on a Windows 2000 server
To install the TeleVantage workstation applications on a Microsoft Windows NT Terminal 
Server, use the following procedure:

1. On the Terminal Server PC, open the Windows Control Panel and click Add/Remove 
Programs.

2. In the Install/Uninstall tab, click Install.

3. In the Install Program dialog box, click Next, and then click Browse.

4. In the Browse dialog box, go to the TeleVantage installation directory. The default 
location is:

\\<TeleVantage Servername>\Netsetup

5. Select either admin.exe or client.exe, depending on the workstation application that 
you want to install.

6. Click Finish, and then proceed with the installation. Add/Remove Programs will make 
sure that the application is set up for multisession use. 

7. If you want to install more than one application, close Add/Remove Programs and 
restart it for each new application that you want to add. 
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Installing workstation applications on a Windows NT server
To install the TeleVantage workstation applications on a Microsoft Windows NT Terminal 
Server, use the following procedure:

Note: This procedure can also be used with Citrix MetaFrame. 

1. At the Terminal Server PC, open a command prompt window and type change user 
/install.

2. Stop all ODBC-dependent services including, but not limited to, IIS, SQL Server, SQL 
Server Enterprise Manager, Terminal Server licensing service, and the ODBC 
Administrator.

3. Install MDAC 2.7 by running the file <Servername>\NetSetup\Mdac\Mdac_typ.exe,
where <Servername> is your TeleVantage Server PC.

Follow the on-screen instructions to install MDAC with the “Complete” option. 

4. With this installation window still open, run the application compatibility script by 
running the following file:

C:\Application Compatibility Scripts\Install\Odbc.cmd

5. Find the following file:

C:\Application Compatibility Scripts\rootdrv2.cmd

If that file is not present, repeat step 4, and it should appear.

When you have located the file, edit it in Notepad and add the following line to the end 
of the file. You can set RootDrive to W: or any unused drive letter. 

Set RootDrive=W:

Save and close the file when you are done.

6. Run the following file again:

C:\Application Compatibility Scripts\Install\Odbc.cmd

7. Return to the final window of the MDAC 2.7 installation. Click Restart Windows.

8. If you see the following error message after restarting your PC, click OK, and then 
restart your PC again.
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9. At the Terminal Server command prompt, type change user /install.

10. Install any of the TeleVantage workstation applications, such as the TeleVantage 
Client, from the TeleVantage Server NetSetup directory. For detailed instructions, see 
Chapter 12.

11. At a command prompt, type change user /execute.

The Terminal Services Client on Windows 2000________________
Remote PCs use the Terminal Services Client to run sessions in Terminal Server. In Windows 
2000, you have a choice between two different versions of the Terminal Services Client:

Q Terminal Services Client. The standard Terminal Services Client is provided with 
Terminal Server. To install it, you must create a set of installation disks with Terminal 
Server Client Creator. You can use this option if you do not want to install Microsoft 
Internet Explorer. 

Q Terminal Services Advanced Client (TSAC). The Terminal Services Advanced Client 
(TSAC) is an ActiveX control that can be used to run Terminal Services sessions within 
Microsoft Internet Explorer. It provides almost the same functionality as the full 
Terminal Services Client, but is designed to deliver this functionality over the Web. 

TSAC is somewhat easier to install because you do not have to create and use a set of 
floppy disks. The TSAC installation package can be downloaded from the following 
location:

http://www.microsoft.com/windows2000/downloads/ 
recommended/TSAC/default.asp

Using Terminal Server for remote administration_______________
In Remote Administration mode, you can use a remote PC to access a server over the network 
just as if you were sitting at the server console. Remote Administration can be used to perform 
upgrade and maintenance tasks remotely.

When you start a session, your remote terminal may not be aware of applications that are already 
running on the server and will not display them on the console or in the task manager. This does 
not apply to all applications. For example, neither the TeleVantage Client nor the Administrator 
would be visible, but the TeleVantage Device Monitor would be visible in the system tray. 
Before attempting to upgrade an application, you should restart the server to make sure the 
application is no longer running. 
C-4 INSTALLING TELEVANTAGE



APPENDIX D

APPENDIX D

TROUBLESHOOTING

This appendix contains information that may be helpful when you are troubleshooting problems with 
various TeleVantage components. It is divided into the following sections:

Q “TeleVantage system overview” on page D-2

Q “Troubleshooting telephone problems” on page D-3

Q “Troubleshooting Intel Dialogic problems” on page D-3.

Q “Troubleshooting database server problems” on page D-11

Q “Troubleshooting TeleVantage Server problems” on page D-12

Q “Troubleshooting Robbed Bit T1 problems” on page D-13.

Q “Troubleshooting ISDN PRI T1/E1 problems” on page D-14

Q “Troubleshooting Client/Administrator installation problems” on page D-15

Q “Troubleshooting Web Services/Web Client problems” on page D-17

Q “Other troubleshooting topics” on page D-18



TeleVantage system overview_______________________________
The following figure shows the logical structure of a TeleVantage Server. Understanding this 
information will be helpful when you are trying determine the significance of system behavior 
when you are troubleshooting problems.

The TeleVantage Server connects to a user by means of two different physical sets of wiring: 

Q Phone wire connects the station telephone to the Server (by means of the station board 
and optional BCP connection panel). 

Q The network connects the Client software to the Server.

When troubleshooting networking problems, keep in mind that TeleVantage uses three kinds of 
communication between the TeleVantage Server and the TeleVantage Client or TeleVantage 
Administrator.
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As shown in the previous figure, the network connection between the Server and the 
TeleVantage Client software actually consists of three different logical connections:

Q The Server software and the Client software communicate using DCOM.

Q The Client accesses voice files stored on the Server through file sharing.

Q The MSDE Client software, which is embedded in the TeleVantage Client, 
communicates with the MSDE database on the Server using its own IPC protocol.

Understanding these different data paths can be important in understanding and troubleshooting 
the TeleVantage system. For example, the previous diagram shows that if a user can listen to 
voice mail messages using the telephone commands, but cannot do so using the Client, problems 
with file sharing or accessing the MSDE database may be the cause. To solve the problem, you 
would use Windows Explorer to check the file sharing privileges on the Server machine. 

Reporting problems
For information about how to report problems, see Administering TeleVantage.

Troubleshooting telephone problems________________________

Calls are rejected
Possible causes for the error message, “I’m sorry, the other party rejected the call” include the 
following:

Q The call is placed on an Internet telephony trunk, and the receiving party does not have 
an IP phone.

Q None of the trunks at the receiving end are configured to accept incoming calls.

Q An outbound call is placed on an ISDN line, but the switch sends TeleVantage a 
disconnect message before the call is connected to the intended recipient.

Troubleshooting Intel Dialogic problems _____________________

Dialogic drivers do not start
If you are unable to start the Dialogic drivers after they are installed, do the following:

Q Verify that no other device is using the IRQ assigned to the Dialogic drivers. To do so:

Q Windows NT: Click Start > Programs > Administrative Tools > Windows NT 
Diagnostics. In the Windows NT Diagnostics dialog box, click the Resources tab.

Q Windows 2000: Click Start > Programs > Accessories > System Tools > System 
Information. In the System Information dialog box, double-click Hardware 
Resources, and then double-click IRQs.
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Be sure to access the network with the Dialogic drivers running to ensure the IRQ is not 
conflicting with the network card. IRQ conflicts can also cause the system to crash. If 
there is a conflict, enter a different free IRQ number for the affected boards.

Q If you experience intermittent problems with boards not starting, and your configuration 
includes both PCI and ISA boards, in BIOS reserve for ISA devices the IRQ that is 
assigned to Dialogic. This prevents the PCI boards from intermittently using the same 
IRQ.

Q Make sure that the network card on the DM/IPx board and the third-party network card 
are both connected to the Ethernet hub, and that the IP address of the DM/IPx network 
card is not in use by another PC.

Q Verify that DCM recognizes all of your boards, each at the correct ID. 

Q If you have a T1 trunk board, in the DCM main dialog box, double-click it and then click 
the Interface tab. Verify that the ISDNProtocol setting reflects the switch protocol used 
by your carrier. For a Robbed Bit T1 line, ISDNProtocol should be set to None.

TeleVantage Server fails to detect some or all stations on HDSI/x 
board 

If you encounter this problem, do the following:

1. Verify that all four cables that connect the HDSI/x board and the station interface box 
(SIB) are connected properly and in the correct order. For more information about 
connecting the HDSI/x board to the SIB, see “Connecting HDSI/x boards” on 
page 8-11.

2. Power off the SIB to reset it, and then restart the TeleVantage Server.

Dialogic Configuration Manager fails to detect a DM3 board
The Dialogic Configuration Manager (DCM) is occasionally unable to automatically detect one 
or more of the following DM3 boards:

Q Internet telephony boards

Q DI/SIx or HDSI/x station boards

Q DM/V2400A conference bridge board

If you encounter this problem, do the following:

1. Determine if the undetected boards passed the Power-on System Test (POST). You 
will need to remove the PC cover to see the diagnostic LEDs on the Dialogic boards. 
Full POST is performed only when a board has gone from a power off to a power on 
state. It is not performed in response to a soft restart, or when the Dialogic drivers are 
started in DCM. 

Note: After the TeleVantageServer starts, the LEDs on a board indicate the various 
tests that are being performed. POST may take awhile to complete, but should be 
complete by the time the Windows logon screen appears.
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Do one of the following:

Q If the board does not pass POST. Reseat or replace the board and run DCM 
again. If it still fails, contact your Technical Support representative.

Q If the board passes POST. Go to the next step.

The diagnostic settings in the following table indicate that a DM3 board has passed 
POST:

2. To verify whether Windows is able to detect the board and IRQ, run PCITree, a utility 
that lists installed PCI boards. PCITree may show boards that do not appear in 
Windows Device Manager.

You can download PCITree from the following location:

http://www.pcitree.de/

Dialogic PCI boards are identified by one of the following Vendor IDs (VID):

Q 10b5 PLX Technology. Identifies a DM3 board.

Q 12C7 Dialogic Corp. Identifies a non-DM3 board.

To display the VID for a board, click on the board in the PCITree main window. The 
VID is displayed in the PCI Device pane at the upper right of the PCITree window. 

Model number Board type LED settings after successful POST

DM/IPx IP telephony All lights are off.

DI/SI32 Station
2 yellow lights are blinking, green and red 
lights are solid on.

HDSI/x Station All lights are off.

DM/V2400A
Conference 
bridge

Green light stays on.
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The following graphic shows the VID for a DM3 board:

For comparison purposes, the following graphic shows the VID for a non-DM3 board:
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Add up all of your DM3 vs. non-DM3 PCI boards, and see if you can account for all 
of them in the PCITree main window. 

Also, verify that Windows assigned an IRQ to the boards. The IRQ is displayed in the 
last byte in hex in the Config Space Dump pane at the bottom right of the PCITree 
window. (In the 2 previous graphics, this value is ‘11’ and ‘0B’ respectively.) Any 
value other than ‘FF’ means that an IRQ was assigned. If this value is ‘FF’, report this 
to your technical support representative.

Do one of the following:

Q If all the boards and IRQs are detected in PCITree. Go to step 4.

Q If any boards or IRQs are not detected. Go to the next step.

3. Try the following:

Q Install the affected board in one or more different slots.

Q Make sure that the chassis is PCI-compliant.

Q Install the latest version of BIOS.

Q Make sure that the BIOS setting for Plug and Play OS is set to No.

If none of these resolves the problem, go to the next step.

4. Verify that no other device is using the IRQ assigned to the Dialogic drivers. To do so:

Q Windows NT: Click Start > Programs > Administrative Tools > Windows NT 
Diagnostics. In the Windows NT Diagnostics dialog box, click the Resources tab.

Q Windows 2000: Click Start > Programs > Accessories > System Tools > System 
Information. In the System Information dialog box, double-click Hardware 
Resources, and then double-click IRQs.

Do one of the following:

Q If there is no IRQ conflict. Go to the next step.

Q If there is an IRQ conflict. Resolve the conflict. If there is still a problem, go to the 
next step.

5. One final troubleshooting step that may result in DM3 boards being detected 
successfully is to restore device defaults in DCM. To do so:

Q Write down all of your non-default configuration settings. The Restore Device 
Defaults command resets all Dialogic board configuration settings to their default 
values, and you will need to reconfigure all of your boards. 

Q In the DCM main dialog box, choose Action > Restore Device Defaults. 

If this does not resolve the problem, go to the next step.
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6. Run the TeleVantage Problem Report Wizard, which is installed automatically when 
you install the TeleVantage Server. For more about the Problem Report Wizard, see 
Administering TeleVantage. The appropriate log files are automatically added to the 
Problem Report .cab file. E-mail the .cab file to your technical support representative.

If you have not yet installed the TeleVantage Server, assemble the following 
information manually and send it to your technical support representative.

Q Windows registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\dlgcmpd\NumOfDe
vicesFound

Q Log files, located in the <W2K System dir>\SYSTEM32\ directory:

Q merc.log

Q dm3bsp.log

Q poweron.log

Q clusterpkg.log.* (* is 1, 2, 3, and so forth)

Q dm3fdspdll.log

DCM fails to detect a D/41ESC board
The Dialogic Configuration Manager is occasionally unable to automatically detect a D/41ESC 
board. If you encounter this problem, manually add the board, as follows:

1. If the Dialogic Configuration Manager (DCM) is not already running, start it 
according to the on-screen instructions. 

2. Choose Action > Add Device.

3. In the Add Hardware Wizard dialog box, under Family, select D/x1E.

4. From the Model list, select D/41ESC.

5. Click Next.

6. Enter a name to identify the board, for example, “First D/41ESC.” Click Next.

7. In the Properties dialog box, select the appropriate parameters for the board. For 
RXGAIN settings, see “Configuring analog trunk boards” on page 9-15.

8. Click OK.

The next time you start the DCM, it will automatically detect the D/41ESC board and any other 
D/41ESC boards in your system.
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Troubleshooting mixed CTbus board systems
If your system uses CTbus (H.100) Dialogic boards, and you experience problems with board 
detection or operation, you may need to change the order of your boards in the PC chassis. 

Q Determine your board type. A board with an H.100 connector can be either an H.100 
board or an SCbus board. To determine which type it is, check to see if there is a 
dedicated CTbus ASIC chip (-OKI ML53812-x) located within 2 inches of the H.100 
connector. 

If there is one, it is an H.100 board. If there is not such a chip, it is an SCbus board. For 
more assistance in identifying the type of board you have, contact your technical support 
representative.

Q Insert your boards in the correct order. Perform this step only if one or more boards 
in your system are H.100 boards. If no H.100 boards are in your system, the board order 
does not matter.

The appropriate order for the boards in your PCI slots is as follows:

Q SCbus boards with SCbus connectors (26-pin) must be placed closest to the ISA 
slots in the chassis. (If your chassis has no ISA slots, place the boards farthest to the 
right, when viewed from the face plates of the boards.)

Q H.100 boards with H.100 connectors (68-pin) must be next.

Q SCbus boards with H.100 connectors (68-pin) must be next.

PCI boards not recognized at Server startup
Windows 2000 systems detect but do not recognize Dialogic PCI boards. As a result, when you 
restart a Server in which you have installed Dialogic PCI boards, the Windows Found New 
Hardware wizard starts for each new board detected. The wizard prompts you to install drivers 
for the unknown PCI device.

Important: Normally, you should NEVER use the Found New Hardware wizard to install drivers 
for Dialogic boards. The only time you should use the Found New Hardware wizard is as 
described below to resolve this problem with unrecognized PCI boards.

To prevent the Found New Hardware wizard from starting when new PCI boards 
are detected

1. Follow the instructions in Chapter 9 to install Intel Dialogic SR 5.1.1, Dialogic SR 
5.1.1 SP1, and the Dialogic Driver Updates.

2. Verify that the files dlgcdm3_nt4.inf and dlgcsram_nt4.inf are located in the \DRVR 
directory in the Intel Dialogic system directory. The default location is:

C:\Program Files\Dialogic\DRVR\

3. Shut down the TeleVantage Server PC, and then restart it and log on.

4. The Found New Hardware wizard starts. Follow the on-screen instructions.
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5. In the Install Hardware Device Drivers dialog box, select Search for a suitable driver 
for my device (recommended). Click Next to continue.

6. In the Locate Driver Files dialog box, select the Specify a location checkbox. Click 
Next to continue.

7. Click Browse and point to the directory listed in step 2. Click OK.

8. In the Driver Files Search Results dialog box, verify that the correct file was found as 
a driver for the new device:

Q For DM3 PCI boards: dlgcdm3_nt4.inf

Q For legacy PCI boards: dlgsram_nt4.inf

Click Next to continue.

9. In the Completing the Found New Hardware Wizard dialog box, verify that the board 
name is correct, and then click Finish.

Dialogic Service fails to start when a PCI board is installed in a PC 
with the Phoenix BIOS

Dialogic PCI boards cannot be auto detected when installed in a PC that uses the Phoenix BIOS. 
This problem results from an incompatibility between the Dialogic System Service and the 
BIOS Advanced Configuration and Power Interface (ACPI). Resolving this issue involves 
disabling the ACPI functionality.

To configure BIOS so that the Dialogic System Service can start, invoke the BIOS configuration 
utility for your system. The configuration choice depends on the version of the Phoenix BIOS:

Q In earlier versions, there is an option for Plug and Play O/S installed (Y/N). For this 
option, select N.

Q In later versions, there is an O/S Installed selection with the following options: Win2000 
/ Win98, Win95 or Other. For this option, select Other.

Dialogic drivers may not start after moving or changing a Dialogic 
DM3 telephony board

Dialogic DM3 boards—DM/IPx Internet telephony boards, DI/Six or HDSI/x station boards, or 
the DM/V2400A conference bridge board—cannot be moved or changed in a single operation. 
This restriction applies whether you are moving a board to a different slot, removing one board 
and installing another, or swapping a board for another of the same type.

As a workaround, do the following.

1. Stop the TeleVantage Server.

2. Remove the board.

3. Restart the Server.

4. Run the Dialogic Configuration Manager (DCM) and verify logical IDs for DM3 
boards. See “Verifying logical IDs for DM3 boards” on page 9-12.
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5. Shut down the Server.

6. Install the board (either the same board or a different one.)

7. Restart the Server.

8. Run DCM and verify logical IDs again.

9. Start the Dialogic drivers.

‘Error 5aa’ or ‘PEB/SCBUS cable missing’ message when starting 
Dialogic drivers

If the SCBus cable that connects your ISA boards is installed correctly (see “Installing Dialogic 
boards” on page 8-5), the problem may be IRQ related.

First, in BIOS, reserve an IRQ for use by legacy ISA devices. You can usually use IRQ 5.

Restart the Dialogue drivers. If the problem recurs, contact your technical support 
representative.

All phones ring when Dialogic drivers are started
If all the phones ring for approximately 30-60 seconds when the Dialogic drivers are started, the 
MSI boards are not getting power from the MSI power supply. Check the power supply, the fuse, 
and so forth. You may need a different power supply.

Troubleshooting database server problems___________________

Cannot access the TeleVantage database server
If you cannot connect to or load the database server, verify the following:

Q The system was restarted after Microsoft MSDE was installed and the MSDE service is 
running.

Q The correct MSDE password was entered during installation. (The password is entered 
if you followed the installation instructions.) Contact your TeleVantage provider for 
assistance.

Microsoft SQLServerAgent service may not restart automatically 
after installing TeleVantage Server

At the end of the TeleVantage Server installation, a restart is required after which the Server 
installation completes. SQLServerAgent service may not restart automatically as it should after 
the restart.
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If SQLServerAgent does not restart, do the following:

1. Select Start > Settings > Control Panel.

Q On a Windows NT Server, click Services.

Q On a Windows 2000 Server, click Administrative Tools > Services.

2. Double-click SQLServerAgent.

3. On the General tab, select Automatic from the Startup type drop-down list.

4. Click Start.

5. Click OK, and then exit Control Panel.

Troubleshooting TeleVantage Server problems ________________
If you encounter problems after successfully installing the TeleVantage Server, check the 
following:

Q Is there sufficient free disk space on the drive containing the vfiles directory?

Q Is there sufficient free database space? (Choose Tools > System Settings and click the 
Storage tab to check.)

Q What is the accessibility of database, voice files, and shares on the network?

Q Can the server be pinged? (Try entering C:\ping <Servername> from a DOS prompt.)

Specific conditions and remedies
Q TeleVantage Server is unknown. Run the utility TVAccUtl.exe as described in 

Appendix E.

Q TeleVantage Service will not start. Verify that the account (valid license) from which 
the user is trying to start the TeleVantage Server has administrator privileges.

Q Device Monitor does not appear when the Device Monitor menu item is selected. 
Click the Device Monitor icon in the system tray (lower right area of the task bar). By 
default, the Device Monitor starts minimized. 

Q “Unable to find libdxxmt.dll” error displayed when starting Server. This error 
indicates that the Dialogic drivers are not properly installed and started. Reinstall the 
drivers according to the instructions.

Q A trunk or station displays a “Error!” in Device Monitor. The trunk or station is 
experiencing an error from which it cannot automatically recover. Use the Device 
Monitor Restart command to reinitialize the device.

Q All stations show “Error!” when the system is started. The power supply is not 
connected to the BCP connection panel. Connect the power supply.

Q Faint music heard on calls. This problem is probably due to radio interference. 
Installing a Radio Shack RF Filter (Part Number 43-150) on the user end between the 
jack and the phone should correct the problem.
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Q All incoming calls hear a busy signal but the phones are not busy. Use the Services 
icon on the Windows Control Panel to ensure the Dialogic service is running. When 
Dialogic boards are powered up and no drivers are present, the reaction to incoming calls 
is controlled by the setting of the hook-state switch (SW1) on the boards. This switch 
may be set to generate a busy signal.

Q Gateway calls between TeleVantage Servers failed. See “Communicating with a 
TeleVantage 3.x Server using an IP Gateway connection” on page 11-18.

Troubleshooting Robbed Bit T1 problems ____________________
TeleVantage supports Robbed Bit T1 spans. These installations often require significant 
configuration work because of the nature of Robbed Bit protocols. This section covers ordering 
and troubleshooting Robbed Bit T1 spans on TeleVantage systems.

Obtaining details about your T1 span
It is critical to have the right signalling information for your T1 span. The following questions 
should be submitted to your T1 carrier so that you have the correct information.

It is important that you speak with a switch technician when you call your carrier. 

Incoming calls:

Q What are the A and B bits set to when you receive an incoming call? 

Line drop:

Q What are the A and B bits set to when the caller hangs up? 

Inbound pickup:

Q What do I have to set the A and B bits to in order to seize the line when an incoming call 
is detected? 

Q Does the CO respond by sending back additional signals? If Yes, what are the line's A 
and B values set to? 

Q Do I have to respond again with another bit signal? If Yes, what is it? 

Outbound pickup:

Q What do I have to set the A and B bits to in order to seize the line to place a call? 

Q Does the CO respond by sending back additional signals? If Yes, what are the line's A 
and B values set to? 

Q Do I have to respond again with another bit signal? If Yes, what is it? 
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Hangup:

Q What do I have to set A and B bits to in order to hang up the line? 

Q Does the CO respond by sending back additional signals? If Yes, what are the line’s A 
and B values set to? 

Q Do I have to respond again with another bit signal? If Yes, what is it? 

Initialize:

Q What are the settings of the line’s A and B bits when the line is idle? 

Digit collection (if applicable):

Q What signal should TeleVantage send to indicate that it is ready to receive the digit 
string? 

Q What is the format of the incoming ANI/DID string, including any filler characters? 

Q Do you use fixed or variable format strings? 

Q If you use variable format strings, what is the delimiter character? 

Q What is the Transmit and Receive Wink Definition?   

Q Is digit signaling DTMF or MF? 

Troubleshooting ISDN PRI T1/E1 problems____________________
TeleVantage supports ISDN PRI T1/E1 spans. Although these tend to be more straightforward 
to configure and test than their Robbed Bit T1 counterparts, some special utilities are available 
to troubleshoot these configurations.

Testing and optimizing ISDN PRI T1/E1 spans
TeleVantage supports two Dialogic utilities to help trace and debug your ISDN span. Details 
about these utilities can be found in Appendix C as well as on the Dialogic support website: 

www.support.dialogic.com

Dialogic MakeCall Utility (DMU)
This utility allows you to test inbound and outbound calls on an ISDN PRI span. It is included 
on the TeleVantage CD and is available for download from

http://support.dialogic.com/appnotes/dmu/

ISDIAG 
If you have tried the DMU and are still unable to place or receive calls, run the ISDIAG utility. 
Detailed diagnostic information is provided.

ISDIAG is a DOS-based application that will monitor a single channel on the ISDN T1/E1 span.
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Troubleshooting Client/Administrator installation problems _____

Client/Administrator installation tips
Q ‘Class Automation’ errors 430 or 1720 can occur if Windows Scripting Runtime is not 

installed. Install Windows Scripting Runtime, then try installing the Client again by 
running Client.exe from the Server's \NetSetup directory. You can download 
Windows Scripting Runtime from the following location: 

http://msdn.microsoft.com/downloads/default.asp?URL=/downloads/sampl
e.asp?url=/msdn-files/027/001/733/msdncompositedoc.xml 

Q If you run the Client installation while Microsoft Outlook is running, you may see an 
error message that says, ‘Microsoft Outlook cannot run the add-in. This feature is 
currently not installed. Would you like to install it now?’ If you see this message, do the 
following:

Q Click No. 

Q Another dialog box then appears with the message, ‘Add-in fldpub.dll could not be 
installed or loaded. Problem may be resolved by using Detect and Repair on the 
Help menu.’

Q Click OK. 

Q Manually restart your system by choosing Start > Shut Down.

When your system restarts, the Client installation will continue.

Q Error 1904 may occur when installing the Client on Windows NT, ending the Client 
installation. If this happens, reboot the system and run the Client installation again. 

‘Corrupt installation’ dialog box
This error means you are unable to install TeleVantage workstation applications. You must log 
on as a user with administrator privileges to the PC on which the workstation applications will 
be installed. If you do not, a “Corrupt Installation” dialog box may open.

‘Server not available’ dialog box appears when upgrading the 
TeleVantage Client or Administrator

If the TeleVantage Server has been started, close the “Server not available” dialog box and 
continue with the installation. 
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TeleVantage Client and Administrator fail to install on Windows 98 
SE if DCOM 98 is not previously installed 

To safely install the TeleVantage Client or Administrator on a Windows 98 SE PC that does not 
have a previous version of TeleVantage installed, you must install DCOM 98 first as described 
in “Downloading DCOM 98 onto your TeleVantage Server” on page 12-3.

Note: If you first run the Workstation Setup and attempt to install the Client or Administrator 
workstation application on a Windows 98 SE PC without a previous version of TeleVantage 
installed or DCOM 98 installed, you will receive an MDAC installation error. If this happens, 
perform the following steps: 

1. Close all open applications on the affected PC.

2. Run the Microsoft Data Access Components (MDAC) installer (mdac_typ.exe) from 
either of the following locations:

Q \Program Files\TeleVantage Server\netsetup\mdac directory on the 
TeleVantage Server PC

Q \server\netsetup\mdac directory on the TeleVantage Master CD

3. Restart the affected PC. 

4. Obtain the file installedmdac.reg from the \support directory on the TeleVantage 
Master CD, and then run it on the affected PC. 

5. Install the Client or Administrator workstation application again and restart the PC.

‘Error 3706 (Provider cannot be found. It may not be properly 
installed.) has occurred’ when starting the Client

This error can occur on some PCs when starting the Client. To fix the problem:

1. Using a program such as WinZip (www.winzip.com), open the file mdac_typ.exe 
from either of the following locations:

Q \Program Files\TeleVantage Server\netsetup\mdac directory on the 
TeleVantage Server PC

Q \server\netsetup\mdac directory on the TeleVantage Master CD

2. Using WinZip, double-click the file sqloldb.cab to view its contents in a new 
window.

3. In that new window, extract all the files in sqloldb.cab into C:\Program 
Files\Common Files\System\Ole DB.

4. At a command prompt, enter the following:
regsvr32 "C:\Program Files\Common Files\System\Ole DB\sqloledb.dll"

5. Start the TeleVantage Client again.
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Cannot start Administrator to back up the TeleVantage database
If you are unable to start the Administrator, you can still back up the TeleVantage database by 
running the Administrator from the command line.

From Start > Run, enter the path of the application in quotes, and then enter the /backup 
command, that is, “\\<system name>\C\Program Files\TeleVantage 
Administrator\TVAdmin.exe” /backup.

E-mail notification through Microsoft Outlook does not work if 
Outlook is installed in Internet Only mode

E-mail notification through Microsoft Outlook will not work if Outlook is installed in Internet 
Only mode. Outlook must be installed with full MAPI support to be used with the TeleVantage 
Server. To change modes, go to Microsoft Outlook and select Tools > Options > Mail Services 
> Reconfigure Mail Support.

Troubleshooting Web Services/Web Client problems___________

Web Services installer seems to complete without requiring a 
reboot, but a reboot is required to finish 

If the Web Services installer completes without requiring a restart, it is recommended that you 
restart anyway to ensure that the setup is really completed.

‘The page cannot be displayed’ messages while running the Web 
Client

These messages may be the result of anti-virus software scanning that causes IIS to restart the 
Web Client. Turning off virus scanning for the file global.asa may help resolve this issue. For 
more information, go to http://support.microsoft.com and search the Knowledge Base for 
article #Q248013
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Other troubleshooting topics _______________________________
This section describes several other problems that you may encounter.

Microsoft WinSock Proxy problems

Microsoft WinSock Proxy blocks local UDP traffic
Microsoft Proxy Server is a gateway to the Internet that allows multiple workstations on a single 
network to share one Internet connection.

MS Proxy Server can sometimes block UDP (User Datagram Protocol) traffic on the network. 
If DCOM is configured to use UDP first and UDP traffic is blocked by MS Proxy Server, 
TeleVantage client applications may not be able to establish a DCOM connection with the 
Server.

Microsoft WinSock Proxy client DLL causes deadlock in RPCSS
Microsoft Proxy Server is a gateway to the Internet that allows multiple workstations on a single 
network to share one Internet connection. RPCSS is the DCOM resolver/end-point mapper 
process. MS Proxy Client can sometimes cause a deadlock in RPCSS.

Preconditions Symptoms Resolution

MS Proxy Server 
installed on the 
network.

The following error(s) will be 
visible in the TeleVantage logs.
In TvInfo log: Automation error 
–2147023174

In TVComLog.txt: 
AtlAdvise("{1D7D9320-64EC-11D1-B
866-006097C0E8CC}") failed; 
HRESULT 0x800706ba: The RPC 
server is unavailable.

Move Connection-oriented TCP 
to the top of the DCOM protocol 
list. See “To change the protocol 
to TCP on a Windows PC” on 
page 11-15.

Preconditions Symptoms Resolution

MS Proxy Client is 
installed on the 
client PC.

TeleVantage Client hangs at the 
splash screen.

Uninstall MS Proxy Client.
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Hang up not being detected
Not all CO lines indicate a disconnect in the same way. Most will drop loop current (which is 
fairly easy to detect) but some may do other things, including:

Q Go silent

Q Play a dial tone

Q Play a reorder tone

Q Play some other kind of tone

To determine the disconnect tones, see Administering TeleVantage.

Slow Server and station startup after migrating TeleVantage to a 
new Server with a new name

This problem is caused by importing a database from another machine with a different machine 
name.

Resolution
When migrating to a new machine and new TeleVantage version, do the following:

1. Move your existing version of TeleVantage to a new machine and verify that it works.

2. Back up the database on the existing Server.

3. Copy TVDB.Dmp and TVServer.Reg to the backup directory on the new Server 
(C:\Program Files\TeleVantage Server\Data\Backup).

4. Copy the voice (.VOX) files to the new Server.

5. Restore the TeleVantage database.

6. Upgrade to the new version of TeleVantage and verify that it works.

TeleVantage Server does not start because account password 
changed

When you installed the TeleVantage Server, you entered the Windows NT account name and 
password used to run the TeleVantage Server. If the password for this account changes, the 
TeleVantage Server will not start. 

Resolution
Use the DCOM config utility to update the account password in the Identify settings for 
TeleVantage Starter application.
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APPENDIX E

APPENDIX E

CHANGING THE DOMAIN OF THE 
TELEVANTAGE SERVER

This appendix describes how to change the domain of the TeleVantage Server PC for any of the 
following reasons:

Q Your network configuration has changed, and you now have a domain that you want the 
TeleVantage Server to be a part of.

Q You recently installed a Microsoft Exchange Server on your network, and you now want to 
support e-mail notification in TeleVantage. To support this feature, the TeleVantage Server 
must be on a domain.

Q You changed the name or password of the domain user.

Q You moved the TeleVantage Server to a different domain.

If you do not have a TeleVantage Server user on the new domain, create one. 

Q For a Windows NT domain, see “Creating the Windows NT 4.0 user for TeleVantage” on 
page 7-8. 

Q For a Windows 2000 domain, see “Creating the Windows 2000 user for TeleVantage” on 
page 7-3.

Running the TeleVantage Password Change Utility 
You must reconfigure Windows NT services and DCOM to enable TeleVantage to start on the new 
domain. The TeleVantage Password Change Utility automatically updates services and DCOM 
settings to your new specifications.

1. Run the file TVAccUtl.exe, which is located in the TeleVantage Server directory. The 
default location for this directory is C:\Program Files\TeleVantage Server.

2. Enter the Domain name, Account name, and Password for the domain.

3. Click OK.
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APPENDIX F

MANAGING TELEVANTAGE LICENSES

This appendix provides background information on how TeleVantage licenses work, and addresses 
the following topics:

Q How TeleVantage licenses affect system behavior. See page F-1.

Q How to activate licenses manually. See page F-4.

Q How to import and export license information to a license file. See pages F-6 and F-8.

Q How hardware locking works. See page F-9.

Q Installing an optional dongle. See page F-10.

Q Terms of use. See page F-9.

Q Special licensing situations. See page F-10.

For information on how to enter licenses using the TeleVantage Administrator, and activate them 
using Web-based one-click activation, see “Entering and activating your TeleVantage licenses” on 
page 11-7.

How TeleVantage licenses affect system behavior______________
It is strongly recommended that you enter all of your licenses and activate them immediately after 
installing the TeleVantage Server, as described on page 11-7. Also, if you add licenses to a 
previously-activated system (for example, adding 10 new Trunk licenses), you must activate again. 
In either case, activating licenses immediately avoids all of the disruptions (described below) that 
occur before licenses are activated.

For more about license activation, see page F-3.

Before your licenses are activated
You can use your TeleVantage system for 60 days without activating your licenses. The 60-day grace 
period starts on the day you enter the licenses using the TeleVantage Administrator. You can activate 
your licenses at any time during or after the 60 days. 

Until you activate your licenses, starting any TeleVantage workstation application will pause at the 
splash screen, to remind you of the number of days left. Users must click OK to continue running the 
application. 

After your licenses are activated
Once you activate your TeleVantage licenses, the 60-day grace period is eliminated and your system 
is fully licensed. All of theTeleVantage workstation applications are fully enabled, and remain so 
unless the hardware ID you choose stops operating or is removed.



After 60 days without activation
If you do not activate your licenses within 60 days, the following occur:

Q All TeleVantage workstation applications—with the exception of the TeleVantage 
Administrator—display a message at startup stating that “Your licenses have expired. 
Ask your TeleVantage Administrator to activate system licenses to fully enable the 
features of this application.” When the user clicks OK to close the message window, the 
application shuts down. 

Q The TeleVantage Server continues to function normally, so users can place and take 
calls, including emergency calls. However, users must use the phone to do so, as they 
will no longer be able to use the TeleVantage Client.

Q The only functions available in the TeleVantage Administrator are the ability to start and 
stop the TeleVantage Server, perform backups, and enter and activate licenses. You can 
no longer add users, make configuration changes, and so forth.

Using trial licenses
Trial licenses allow you to evaluate TeleVantage for 60 days, starting on the day you enter the 
trial licenses using the TeleVantage Administrator. Trial licenses cannot be activated.

At any time during or after the trial period, you can purchase full licenses from your 
TeleVantage provider, and then enter and activate them. The trial period can only be extended 
by obtaining a new set of trial licenses from your TeleVantage provider.

With trial licenses, starting any TeleVantage workstation application will pause at the splash 
screen, to remind you of the number of days left. Users must click OK to continue running the 
application. In addition, when users take their phone off-hook during the last 5 days of the trial 
period, they hear a message warning of the upcoming end of the trial period before they get dial 
tone.

After the 60-day trial license period ends, the following occur:

Q TeleVantage will not answer any calls, no new calls can be placed, and all active 
calls are dropped. The TeleVantage Server shuts down and cannot be restarted.

Q All TeleVantage workstation applications—with the exception of the TeleVantage 
Administrator—display a message at startup stating that “Your licenses have expired. 
You must purchase full licenses to fully enable the features of this application.” When 
the user clicks OK to close the message window, the application shuts down. 

Q The only available function in the TeleVantage Administrator is the ability to enter and 
activate licenses.

Viewing the status of licenses on your system
The status of the licenses on your system is displayed in the splash screen and About dialog box 
for any of the TeleVantage workstation applications. 
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The following graphic shows the TeleVantage Administrator splash screen on a system with 
licenses that have not yet been activated. Note that the number of days left in the 60-day grace 
period is also displayed.

About entering licenses ___________________________________
You use the TeleVantage Administrator to enter licenses into your system. There are two ways 
to enter licenses:

Q Enter licenses manually. For details, see “Entering and activating your TeleVantage 
licenses” on page 11-7.

Q Import licenses from a license file. For details, see “Importing license information” 
on page F-6.

About activating licenses__________________________________
Activating your TeleVantage licenses does the following:

Q Eliminates the 60-grace period so your system is fully operational.

Q Disables on-screen messages and telephone warnings that occur before licenses are 
activated and when using trial licenses. See “How TeleVantage licenses affect system 
behavior” on page F-1 for more information about how systems behave before and after 
licenses are activated, and when using trial licenses.

Q Locks the licenses to your TeleVantage Server hardware so they cannot be used on more 
than one system at the same time.
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Activation consists of the following steps:

1. You submit your license and hardware information to Artisoft using one of the 
methods described in the next section. 

2. Artisoft verifies the information and locks your licenses to a hardware ID on your 
TeleVantage Server.

3. Activated licenses are returned to you and applied to your TeleVantage system.

Note: When you activate licenses, the license information you submit to Artisoft is verified and 
saved for future troubleshooting purposes. 

Once a system is activated, it stays activated until you add additional licenses (for example, you 
purchased another Station license to support more users), or the hardware ID against which the 
licenses are locked stops operating or is removed. At that time, the system becomes inactivated 
and the 60-day grace period begins, until you activate again. You will also need to activate your 
licenses again if you change the hardware ID on the TeleVantage Server. See “Terms of use” on 
page F-9 for information on how hardware locking works.

How to activate your licenses
You can activate TeleVantage licenses in two ways:

Q Automatically, using one-click activation

Q Manually, by submitting your exported license information directly to the Artisoft 
activation website

If you encounter problems with any of the activation methods or have questions, contact your 
TeleVantage provider, or call Artisoft at 617-354-0600, extension 555.

About one-click activation
If you have Internet access on the PC on which you are running the TeleVantage Administrator, 
one-click activation is the easiest way to activate your licenses. When you use one-click 
activation, all the required information is submitted and imported automatically for you. See 
“Entering and activating your TeleVantage licenses” on page 11-7 for details about using 
one-click activation.

Activating licenses via the web
If you do not have Internet access on your Administrator PC or have a problem with one-click 
activation, you can go directly to the Artisoft activation website to activate your licenses.
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To activate licenses via the web

1. Export your licensing information as described on page F-8. The license file contains 
all the required information for successful activation

2. Using your browser, go to http://activation.artisoft.com/activation 

Note: If you have problems with one-click activation or activating via the web, make 
sure that the TeleVantage Administrator can connect on TCP Port 80 to the host 
activation.artisoft.com. Note that Port 80 is the default port for HTTP so it is the 
most common port to be open, but it is possible that your network administrator has 
blocked that Port and redirected HTTP traffic over a different Port.

3. Supply your licensing in either of the following ways:

Q If your browser supports file uploads, enter the name of the license file you exported 
from the Administrator, and then click Upload.

Q If your browser does not support file uploads, paste the contents of your license file 
into the web page. To do so:

Q Open your exported license file using Windows Notepad.

Q In Windows Notepad, select Edit > Select All, and then select Edit > Copy.
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Q Click in the text box on the Artisoft activation database web page. In your 
browser, select Edit > Paste.

Q Click Activate.

4. A license file containing activated licenses—called activation.lic—is downloaded to 
you after a brief pause. Save the file to your PC, and then import the file according to 
the instructions in “Importing license information” on page F-6.

Licensing errors
If activation was not successful, one of the following error messages is displayed. If you have 
further questions or need help, contact your TeleVantage provider.

Q “Unknown activation failure”. An unexpected error has occurred.

Q “Activation database unavailable”. The activation database is not available. Please try 
activating again later.

Q “Invalid license”. One or more licenses in an exported license file is invalid. Export 
your licenses again from the TeleVantage Administrator and activate them again.

Q “Exceeded maximum activation count”. One or more of your licenses has already 
been activated using a different hardware ID. See “Terms of use” on page F-9 for more 
information.

Q “Exceeded maximum activation depth”. One or more of your licenses has already 
been locked to the maximum number of hardware IDs allowed. See “Terms of use” on 
page F-9 for more information.

Q “Invalid activated license”. The license file that you are importing contains one or 
more invalid licenses. Activate your licenses again.

Importing license information
You import license information for any of the following reasons:

Q To enter licenses, if your TeleVantage provider supplied you a license file that contains 
your license serial numbers and verification keys

Q After successfully activating your licenses manually via the Artisoft activation website

Q To use licenses exported from another PC, for example, if you have moved your 
TeleVantage Server to another PC

Q To rebuild a TeleVantage Server

During an import, only new license records are imported. Licenses that were that were imported 
or activated previously are ignored.
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To import licensing information

1. In the TeleVantage Administrator, choose Tools > System Settings, and then click 
the Licenses tab.

2. Click Import. The Import File From dialog box opens. Browse to the license file that 
you want to import, select it, and then click Open.

3. After the import finishes, click OK to close the message window that displays the 
number of license records that were imported.

Note: Only new license records are imported. Licenses that were imported or 
activated previously are ignored.

After importing new licenses, be sure to activate them using one of the methods described in 
“About activating licenses” on page F-3.
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Exporting license information
You export license information for any of the following reasons:

Q To activate your licenses manually, via the Artisoft activation website

Q To create a record of all your licenses that you can view and print

Q To use the licenses on another PC, if you need to move your TeleVantage Server to 
another PC

Q To use the licenses to rebuild a TeleVantage Server 

Exporting your TeleVantage licenses creates a license file—a text file with the extension 
.LIC—that contains the following information:

Q Serial numbers and verification keys for all the licenses in your system

Q MAC address of the network interface cards (NICs) on the TeleVantage Server, if one 
is present

Q Serial number of the hard disk drive where the TeleVantage Server was installed

Q Serial number of your dongle, if one is present

Q Profile information that you entered when you activated licenses

You can view the exported license file using a text editor.

To export license information

1. In the TeleVantage Administrator, choose Tools > System Settings, and then click 
the Licenses tab.

2. Click Export.

3. In the Registration Information dialog box, update or add customer profile 
information, and then click OK. 

Note: If you do not know your VAR Authorization Number (a required field), you can 
request it from the place where you purchased TeleVantage.

4. The Export Licenses To dialog box opens. Browse to the location where you want to 
save the exported license file, and then click Save.

5. Click OK to close the message window that displays the number of license records that 
were exported.
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More about TeleVantage licensing___________________________

How hardware locking works
Your TeleVantage licenses can only be used on one system at a time. When you activate your 
TeleVantage licenses, they are locked to one of the following hardware IDs on your 
TeleVantage Server PC. You can choose which hardware ID to use. There are pros and cons to 
each one.

Q Network card (NIC). Locking your licenses to the MAC address of a NIC on the 
TeleVantage Server PC is probably the best choice, since NICs are cheap and easy to 
move to another PC. However, if your NIC is located on the PC motherboard it cannot 
be moved. In that case, lock your licenses to a dongle or hard drive, or buy another NIC 
and install it in the TeleVantage Server PC.

Q Dongle. You can lock your licenses to the serial number of a dongle, if one is installed 
on the TeleVantage Server PC along with the dongle drivers. Dongles are very easy to 
transport to another PC, and are a good choice if you may eventually move the 
TeleVantage Server to a different PC, or you do not want to or cannot move your NIC 
or hard drive. Also, since a dongle serves no other purpose, it will rarely fail. However, 
dongles cost money and must be purchased separately. If you choose this option, see 
“Installing a dongle” on page F-10.

Q Hard drive. Locking your licenses to the serial number of a hard drive on the 
TeleVantage Server PC is another option. However, hard drives are more difficult to 
move to another PC, and may have to be replaced or upgraded.

The hardware ID is verified each time the TeleVantage Server or any of the workstation 
applications start. If the hardware ID is not detected (for example, the dongle fell out or your 
NIC failed), your licenses revert to an unactivated state, and the 60-day grace period starts again.

If necessary, you can relock your licenses to a different hardware ID once, as described in the 
next section. 

Terms of use
The following terms of use apply when you activate licenses. License locking and relocking are 
automatic until these limits are reached. At that point, you must contact your TeleVantage 
provider or technical support representative for assistance. 

Q You can activate a license once. Once an license is activated, it can never be activated 
again. 

For example, if you activate Trunk license 1 on TeleVantage Server A, and then try to 
activate Trunk license 1’s serial number and verification key on a TeleVantage Server 
B, the activation will fail.
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Q You can change the hardware ID for an activated license once. There may be 
circumstances under which you need to use your activated TeleVantage licenses with a 
different hardware ID, for example, a failure on the network card or hard disk drive used 
for the initial activation, a catastrophic hardware failure such as a flood or fire, or a 
complete upgrade or migration of the TeleVantage Server, where you do not want to 
move any of the old hardware over to the new PC. You are allowed to relock your 
licenses to a new hardware ID once without contacting your TeleVantage provider.

For example, if you activate your licenses on a TeleVantage Server with hardware ID A, 
and then need to replace your network card, you can reactivate the licenses using 
hardware ID B. However, if you try to reactivate the same licenses a third time using a 
different hardware ID, the activation will fail. Also, after activating the licenses using 
hardware ID B, the licenses on hardware ID A can no longer be upgraded to new 
versions of TeleVantage, and additional licenses cannot be added to hardware ID A 
unless a fresh set of licenses is entered and activated.

Installing a dongle
See page 3-6 for a list of supported dongles.

To install a dongle on the TeleVantage Server

1. Run the Sentinal System Driver installation program from the following location on 
the TeleVantage Drivers CD:

\dongle\setup.exe

Follow the on-screen instructions.

2. In the Setup Type dialog box, select Complete, and then click Next.

3. Plug the dongle into the appropriate port.

4. Restart the TeleVantage Server.

Now when you run the TeleVantage Administrator, the dongle will appear in the Lock your 
licenses to this hardware key drop-down list in the Activation Information dialog box.

Special licensing situations
This section describes situations that may require you to relock your TeleVantage licenses to a 
different hardware ID, as described in “Terms of use” on page F-9. 

Once you have installed the TeleVantage Server on a PC with the new hardware, you must 
activate the licenses again using the one of the methods described on page page F-4.

Moving licenses to another TeleVantage Server
If you want to use your TeleVantage licenses on a different Server, be aware that once activated, 
they will no longer be available on the original Server.
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Moving the TeleVantage Server
If you are moving the TeleVantage Server to another PC, you can avoid having to activate the 
licenses again if you move the network interface card (NIC) as well. If you have more than one 
NIC on the TeleVantage Server, you only have to move the one to which the TeleVantage 
licenses are locked. If you have no NIC, move your hard drive where the TeleVantage Server 
was installed.

Moving the hardware is optional. If you cannot move the NIC or hard drive—for example, the 
NIC is attached to the PC’s motherboard, or the hard drive failed or is too small—simply 
activate the licenses again on the new PC. See “Terms of use” on page F-9 for information about 
limits on activating TeleVantage licenses again on new hardware.
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APPENDIX G

APPENDIX G

PERFORMING UNATTENDED 
WORKSTATION INSTALLATIONS

You can install the TeleVantage workstation applications unattended (silently), so that your 
organization can perform automatic software updates or use a network maintenance system that 
performs remote installations. When running Workstation Setup unattended, you can perform either 
of the following types of installation:

Q Typical installation. In a typical installation, the following occur. You cannot change any of 
these options.

Q When installing TeleVantage for the first time on the TeleVantage Server, only the 
Administrator is installed. On all other PCs, when installing TeleVantage for the first 
time, only the Client is installed. 

When upgrading from a previous version of TeleVantage, Workstation Setup detects the 
workstation applications that are installed, and upgrades those applications to the current 
version. 

Q The workstation applications are installed in the default location. 

Q Custom installation. In a custom installation, you can specify which workstation 
applications to install, change the installation drive or folder, uninstall workstation 
applications, and specify other options.

Note: Because the PC where the workstation applications are installed must be restarted to 
complete the installation, you should perform unattended installations when users will not be 
interrupted while they are working.

Performing a typical unattended installation___________________
To perform a typical unattended workstation application installation, run the following command on 
the PC where the workstation applications will be installed:

\\<TeleVantage Servername>\Netsetup\setup.exe /s /v"/qn /l*v 
%TEMP%\wssetup.log"



Performing a custom unattended installation__________________
To perform a custom unattended workstation application installation, run the following 
command on the PC where the workstation applications will be installed, including any of the 
parameters described in the table on page G-3. 

\\<TeleVantage Servername>\Netsetup\setup.exe /s /v"/qn CUSTOM_INSTALL=1 
/l*v %TEMP%\wssetup.log"

Note: This example only shows the parameters required for any custom unattended installation. 

For examples of custom installation commands, see the next section.

Custom unattended installation examples
The following examples demonstrate different unattended installations. See “Workstation Setup 
command parameters” on page G-3 for details on the command parameters you can sue.

This command installs only the TeleVantage Administrator in the default location:

setup.exe /s /v"/qn CUSTOM_INSTALL=1 ADDLOCAL=Admin"

This command installs the TeleVantage Administrator and Client in the default location:

setup.exe /s /v"/qn CUSTOM_INSTALL=1 ADDLOCAL=Admin,Client"

This command installs all of the workstation applications in the default location:

setup.exe /s /v"/qn CUSTOM_INSTALL=1 ADDLOCAL=ALL"

This command does the following:

Q Installs the TAPI Service Provider in the default location.

Q Installs the Contact Manager Assistant in the specified location.

Q Configures the TAPI Service Provider.

Q Launches the Contact Manager Assistant when the installation completes, if a restart is 
not required.

setup.exe /s /v"/qn CUSTOM_INSTALL=1 ADDLOCAL=TSP,CMA TVSERVER=TeleVantage 
TVSTATION=1 TVUSER=Operator TVPASSWORD=0 TVTSPAPPHANGUP=1 TVTSPTRACE=1 
TVCMAFOLDER=/"C:\Program Files\CMA/" TVLAUNCHCMA=1 /l*v 
%TEMP%\wssetup.log"

Note: Any string value that contains a space must be delimited with the characters /" before 
and after the string value, as in the following example:

TVCMAFOLDER=/"C:\Program Files\CMA/"
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Workstation Setup command parameters
The following parameters can be specified in any order. Separate parameters with spaces.

Name Value Description

CUSTOM_INSTALL Integer Installation type: 
0 = Typical installation (Default)
1 = Custom installation 

ADDLOCAL Admin
Client
CMA
TSP
ALL

Workstation application to install:

To install more than one 
application, separate each one 
with a comma (,), for example:
ADD_LOCAL=Admin,Client

To install all of the workstation 
applications, specify ALL, for 
example:
ADDLOCAL=ALL

REMOVE Admin
Client
CMA
TSP
ALL

Workstation application to 
remove:

To remove more than one 
application, separate each one 
with a comma (,), for example:
REMOVE=Admin,Client

To remove all of the workstation 
applications, specify ALL, for 
example:
REMOVE=ALL

TVSERVER String Name of the TeleVantage Server 
PC:
TVSERVER=TELEVANTAGE
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TVSTATION String Station ID of the phone that will 
be used by the person at this 
PC: 
TVSTATION=186

If you do not know the station ID, 
pick up the phone and dial *0. 

If there is not a TeleVantage 
phone near this PC, enter a 
station ID of 0.
TVSTATION=0

SUPPRESS_MSGS Integer 0 = Workstation Setup displays 
message boxes on the PC 
where the applications are 
installed (Default). Workstation 
Setup stops processing and 
waits until someone responds to 
each message box.

1 = Suppress display of 
message boxes. The messages 
are still written to the 
Workstation Setup Log (see 
“Performing a typical unattended 
installation” on page G-1.)

Use the following 4 parameters to specify the complete path to the 
location where a workstation application will be installed, for example:

TVCLIENTFOLDER=/"C:\Program Files\TV Client/"

If not specified, the application will be installed in the default location.

TVCLIENTFOLDER String Location where the Client will be 
installed. 

TVADMINFOLDER String Location where the Administrator 
will be installed. 

TVTSPFOLDER String Location where the TAPI Service 
Provider will be installed. 

TVCMAFOLDER String Location where the Contact 
Manager Assistant will be 
installed. 

Name Value Description
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Optionally, use the following 4 parameters if you are installing the TAPI 
Service Provider (ADD_LOCAL=TSP or ADD_LOCAL=ALL.) If you do not 
provide this information during the unattended install, you must run the 
TAPI Configuration Wizard later to configure TAPI SP for the user at 
this PC. See “Configuring the TeleVantage TAPI Service Provider” on 
page 12-8 for more information

TVUSER String TAPI SP only. User name of the 
person assigned to the station ID 
in TVSTATION:
TVUSER=SRyan

Note: TVUSER must be the user 
assigned to the station ID in 
TVSTATION, else this parameter is 
ignored.

TVPASSWORD String TAPI SP only. User’s 
TeleVantage password:
PASSWORD=17530

TVTSPAPPHANGUP Integer TAPI SP only. Specifies whether 
applications using TAPI SP can 
hang up calls.

0 = Applications using the TAPI 
SP cannot hang up calls 
(Default). 
1 = Applications using the TAPI 
SP can hang up calls. 

Important: Some contact manager 
programs experience problems 
when TVTSPAPPHANGUP=1. For 
details, run the TAPI SP 
Configuration Wizard after installing 
TAPI SP, and read the Help for the 
second Wizard screen. Do set 
TVTSPAPPHANGUP=1 for users who 
use Microsoft Outlook as their 
contact manager.

Name Value Description
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TVTSPTRACE Integer TAPI SP only. Specifies whether 
TAPI SP writes debugging 
information to disk when placing 
calls. This information is useful 
when communicating with 
technical support. 

0 = TAPI SP does not create a 
trace file (Default).
1 = TAPI SP creates a trace file.

Note: The trace file is located at the 
following location:

C:\Program Files\TeleVantage 
Client\Logs\Tvtsp.txt

Use the following 3 parameters to launch a workstation application after 
the installation completes. 
Note: Each parameter takes effect only if the application was installed 
successfully and no restart is necessary. These parameters are not affected by 
the REBOOT parameter setting.

TVLAUNCHCLIENT Integer 0 = Do not start the Client after 
the installation completes 
(Default).
1 = Start the Client after the 
installation completes.

TVLAUNCHADMIN Integer 0 = Do not start the Administrator 
after the installation completes 
(Default).
1 = Start the Administrator after 
the installation completes.

TVLAUNCHCMA Integer 0 = Do not start the Contact 
Manager Assistant after the 
installation completes (Default).
1 = Start the Contact Manager 
Assistant after the installation 
completes.

Name Value Description
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Verifying that an unattended installation was successful________
You can determine if a unattended installation was successful by viewing the Workstation Setup 
Log. This file is created in the \Temp directory on the PC where Workstation Setup was run. 
When an installation is successful, an entry appears near the end of the file:

MSI (c) (80:34): Product: TeleVantage workstation applications -- Installation 
operation completed successfully.

Note: You can also examine the Windows Event Log on the PC to see if the installation 
completed successfully.

REBOOT String Force = Automatically restarts 
the PC where the workstation 
applications are installed after 
the installation completes 
(Default).
ReallySuppress = Do not 
restart the PC after installation 
completes. If you specify 
REBOOT=ReallySuppress, the 
PC must be restarted later.

Name Value Description
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APPENDIX H

USING THE INTEL DIALOGIC 
CONFIGURATION MANAGER

The Intel Dialogic Configuration Manager (DCM) is used to perform many of the 
configuration tasks in Chapter 9, “Installing and Configuring the Intel Dialogic 
Drivers.” 

This appendix describes how to perform the following basic functions using 
DCM:

Q Start DCM.

Q Start the Dialogic drivers.

Q Stop the Dialogic drivers. In order to make changes to how boards are 
configured, the Dialogic drivers must be stopped.

Detailed instructions for performing specific configuration tasks are provided in 
Chapter 9.

To use the Intel Dialogic Configuration Manager

1. Click Start > Programs > Intel Dialogic System Software > 
Configuration Manager - DCM. 

2. In the Computer Name dialog box, select the TeleVantage Server PC, 
and then click Connect. Wait while DCM detects the telephony boards 
installed on the Server.

3. After board detection is complete, the status of the Dialogic drivers 
(“Stopped”, “Running”, and so forth) is displayed at the bottom of the 
DCM main dialog box.

Q To start the Dialogic drivers if they are stopped, click the green 
button on the toolbar, or choose Service > Start Service.

Q To stop the Dialogic drivers if they are running, click the red button 
on the toolbar, or choose Service > Stop Service.

4. To exit DCM, choose File > Exit.
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